Bug 10511 - GPS never finds my exact position when I have no internet connection
: GPS never finds my exact position when I have no internet connection
Status: RESOLVED DUPLICATE of bug 7026
Product: Location
General
: 5.0:(10.2010.19-1)
: N900 Maemo
: Unspecified normal with 5 votes (vote)
: ---
Assigned To: unassigned
: location-framework-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-06-02 20:41 UTC by Will
Modified: 2012-04-15 18:48 UTC (History)
7 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Will (reporter) 2010-06-02 20:41:37 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Visit a new location on the planet, e.g. anywhere in Europe, but a place
that you know where you are to within a few tens of metres (you might not need
to be in a new location, but if not, it might use a cache your previous
location which is not helpful for testing, that's all)
2. Ensure you are NOT connected to internet at all (either via WiFi or 3G)
3. Go outdoors with a clear view of the sky and no buildings around
4. Fire up Ovi maps on the N900 (I have version that come with PR1.2 and I have
all the maps for the whole of Europe downloaded)
5. When it asks you for an internet connection, deny it one by clicking at the
top of the screen (in the blurred out area.)  Do this every time it asks you.
6. Wait for the map application to show you your current position, press the
red dot icon if and when it becomes available to try and find out your exact
location to within a few metres
7. I've waited over 10 minutes so far and got no position, so I give up.  My
friend waited 30 minutes and got no position and gave up he said.  The best it
does is give you a very poor approximation.

Note: I do have the Network Positioning enable check box ticked, but I am sure
I have tried it with this unticked too.  It shouldn't make a difference anyway,
I believe.

EXPECTED OUTCOME:
I expect the maps to show me my exact location with the red dot icon within
about 5 minutes, and certainly within 10 minutes, even when I have no internet
connection.

ACTUAL OUTCOME:
The GPS device never gets a full lock on my position it seems and never tells
me where I am when I have no internet connection.  Sometimes it gives my an
approximate location of about half a mile down the road (presumably from the
GPRS cell triangulation) but it never tells me where I am until I finally give
in and let it connect to the internet (to use A-GPS I assume)

REPRODUCIBILITY:
ALWAYS!!!

EXTRA SOFTWARE INSTALLED:
Nope.

OTHER COMMENTS:
Although GPS (i.e. A-GPS) works really well I have an internet connection,
plain old GPS does not work when I have no internet connection.

It would be helpful if the Ovi maps actually showed me how many satellites it
has found as it searches for them. That way I would have some feedback at
least, but I am I am pretty sure it can see plenty of satellites as I have
tried it outdoors with clear skies and no tall buildings around. It simply does
not give me my exact position ever, no matter how long I wait.

This is a big problem if you are on a walk somewhere remote, e.g. in the
countryside, and are out of range of any mobile phone cells and so cannot get a
GSM/GPRS signal. If someone gets lost outdoors they will want to know on their
GPS position, but without an internet connection the N900 won't tell you where
you are.

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.9.2.3)
Gecko/20100423 Ubuntu/10.04 (lucid) Firefox/3.6.3
Comment 1 Will (reporter) 2010-06-02 23:29:41 UTC
Hi again,

I've just done some specific tests.

In short, Step 1 is imperative otherwise the N900 appears to use the previous
position and if it's not too far away, it quickly finds where it is now.

For my first test I went about 1 mile from my house and fired up Ovi maps.
I chose not to connect to internet (of course) and within 1 minute it had
correctly found my position accurately, to within about 10 metres I would say.

For my second test I went about 10 miles and this time it took about 5 minutes
to find my position, but it did find it. So that worked.

I will try another test tomorrow, further away in London, as previously there
it has not found my position without an internet connection.  I have waited 10
minutes in the past and got no position.  It just says "Looking for GPS..." at
the bottom of the screen.

I think ONE of the problems is that whilst it is 'looking for GPS' the screen
will timeout and go blank after about 30 seconds.  (It does not do this once it
has found the position and the red dot is active of course.)  So, perhaps it
would be better if the N900 was prevented from timing out and blanking the
screen whilst 'looking for GPS.'  I think when the screen goes blank the GPS
actually turns off, so I have to keep waking it up again by sliding the switch
on the side of the N900.  This probably doesn't help if it's downloading GPS
data and keeps getting interrupted???

So, I will try testing it in a location miles away from here and see if I can
get it to find my position at all without the internet.

My conclusion so far is that unless it has local GPS data downloaded already,
e.g. the almanac and/or emphemeris data, then it takes ages to download it?  It
only seems to be an issue when getting it's initial position, because once
obtained, if I am moving along on a train say, it correctly updates my position
quite well, even though the GPS signals must be weaker inside a train. So it's
just the 'getting started' that seems to be the issue with the GPS position.

Thanks.
Comment 2 Will (reporter) 2010-06-03 11:40:49 UTC
Hi,

Just done the ultimate test, in London.

I stood still in a fairly open space and fired up Ovi maps.
I kept touching the screen every 10 seconds or so to prevent it from falling
asleep and blanking the screen (and turning off the GPS receiver I assume, or
at least interrupting the GPS data download from satellite.)

Anyway, to my surprise, after just over 3 minutes, it found my position!

So, it does work, but it MUST need me to keep it awake by touching the screen
every 10 seconds whilst the "Looking for GPS..." message is displayed.

In the past when I have tried it in London, I have been walking along slowly
and not concentrating on the N900 screen, so it would have kept blanking out
and I would eventually notice and wake it up again.  I think this was the
problem as I think this made the download start over again and it never ever
got the full set of data it needed downloaded.

So, if I am correct, can the Ovi maps software application be modified to make
it keep the GPS and screen alive during the whole time the "Looking for GPS..."
message is displayed?  It keeps it alive once it has found my position and I
have pressed the red dot and it is tracking my position, so it must be easy to
make it stay alive at startup during the looking phase too.

Hope that's useful feedback.
Comment 3 Sean Young 2010-06-03 13:59:19 UTC
Same problem with Mæp. Steps reproduce:

1. Go to: Settings -> Location -> Network Positioning -> Enable (turn off)
2, Start Mæp. 
3. Never seems to find a fix.
4. After a 30 minute cycle still no fix

My mobile provider charges each day I use the internet, which I would like to
avoid just for getting a GPS fix. In addition, 3g/gprs is not always available
depending on where you are.
Comment 4 Will (reporter) 2010-06-03 23:27:45 UTC
(In reply to comment #3)

> 3. Never seems to find a fix.
> 4. After a 30 minute cycle still no fix

I did another test in another part of London, walking along this time.
A few tall buildings were nearby, but the skies were very clear.

This time Ovi maps took between 4 and 5 minutes to get a position, but it did
get a one.  It is a pain though, to have to keep touching the screen/map to
keep it alive during it's "Looking for GPS..." phase, but this method appears
to work, for me at least.
Comment 5 Andre Klapper maemo.org 2010-06-04 12:06:01 UTC
The "looking for GPS fix" situation for 10.2010.19-1 and later is described in
bug 5337 comment 139.

So you can really confirm that searching for a GPS fix stops when the screen is
dimmed? Uhm.
Comment 6 Will (reporter) 2010-06-04 13:30:26 UTC
(In reply to comment #5)
> The "looking for GPS fix" situation for 10.2010.19-1 and later is described in
> bug 5337 comment 139.
Thanks for that, that bug does sound very similar to my issue.

> So you can really confirm that searching for a GPS fix stops when the screen is
> dimmed? Uhm.
I'm pretty sure I can, yes.  I will do some more tests over the weekend, and
also will try setting the timeout to the maximum of 2 minutes to make it
easier, though often it takes more than 2 minutes to get all the data
downloaded from the GPS satellite to give me my position, it seems.

I'll report back on Monday.
Comment 7 wierdo 2010-06-04 15:03:58 UTC
I can't reproduce this with location-test-gui. I was running the gps at this
location a couple of days ago, however that should be long enough for the
almanac to become outdated.

Moreover, I tested indoors. It took approximately 2 and a half minutes to get a
lock with 4 satellites in view. Within a minute or so it was showing two. I'll
give it another shot later today when I'll be a hundred miles or so from here.

Using network assistance, it knows of 11 satellites and gets a lock with 9
within less than 15 seconds.
Comment 8 Tomasz Dominikowski 2010-06-04 15:24:54 UTC
I suggest using the Brightness Applet and turning on Keep Backlight On so you
don't have to tap the screen every time. This way you can easily test both
scenarios - with screen on and with screen off.
Comment 9 Ian Stirling 2010-06-04 15:40:08 UTC
The program at https://bugs.maemo.org/attachment.cgi?id=1839 may be of use.
It apparantly clears th GPS cache inside the modem.
It may make testing more repeatable.
Comment 10 Will (reporter) 2010-06-04 19:22:18 UTC
(In reply to comment #7)
> I can't reproduce this with location-test-gui. I was running the gps at this
> location a couple of days ago, however that should be long enough for the
> almanac to become outdated.

Where can I get location-test-gui from?

Also, almanac data can last for 100 days or more; it's the ephemeris data that
changes daily (according to wikipedia, that is) :)

Thanks
Comment 11 Will (reporter) 2010-06-06 18:43:48 UTC
Hi,

I did 2 tests, one about 5 miles from home, one about 15 miles from home. I
tried to reproduce this bug, but could not, for whatever reason.

For each test I ensured there was no internet connection, but I did leave the
network positioning box ticked on. I left my screen timeout at 30s too.

The test involved these steps:

Step 1.  Fire up Ovi Maps outdoors
Step 2.  Do NOT touch the screen other than to cancel the request to connect to
internet. So, I click on the top of the screen once. It then continues with
"Looking for GPS.."
Step 3.  Let the N900 screen go blank after 30 seconds
Step 4.  Leaving the N900 on a table, wait 2 or 3 minutes
Step 5.  Slide the slider switch to wake up the screen
Step 6.  Notice that the red icon is now on the screen and click the red icon
once

The outcome is that my position is found and correct, so it did get a GPS lock
within 3 minutes with the screen being blank.

So, I don't know why I could never get one in the past, but perhaps PR1.2 does
fix something here as I only tried once or twice with PR1.2 the other week when
it failed to get GPS lock in London.

One other thing it could be is the fact that originally I was putting it in my
pocket. after Step 1, with the screen locked. Perhaps putting it in my pocket
stops the GPS signals getting in?  Or perhaps not clicking to cancel the
request to connect to the internet makes it halt at that point and so it was
just waiting at that stage rather than continuing to get data from the
satellites direct?

I'll see how it goes now and just hope it will work offline ok when I go to
Italy next month.

It might still be that my N900 has cached data as I have not been more than 15
miles away during my tests.  I do know someone else who had this problem so
there might still be a subtle bug somewhere.

Has anyone else tested this thoroughly and encountered this bug?

Anyway, if I encounter the bug again I will describe here what happened.

Thanks
Comment 12 redex 2010-06-06 19:27:35 UTC
*** This bug has been confirmed by popular vote. ***
Comment 13 Will (reporter) 2010-06-07 10:48:29 UTC
Not sure if this helps or not, but this morning I noticed that
location-test-gui was not getting a location fix despite it working really well
when I used it at the weekend indoors.

In short, I fired up location-test-gui on a moving train.  Immediately it said
it could see 10 satellites, but none were in use.  I did not choose a Method, I
left that set at user defined.

Anyway, even after 2 minutes, although the number of satellites seen had
fluctuated from 9 to 12 (so the info was real-time and not stale), still none
of the satellites were in use.

It did say CellMo was connected, but shortly after those 2 minutes, it lost
that as it turned out I had lost my mobile cell signal completely too.

Anyway, perhaps the conditions were just too bad, i.e. no mobile cell signal,
being on a moving train, cloudy skies, and so it could not get a fix.  But then
again, it could SEE the satellites, so why could it not do anything with them?

This could be a red herring, but then again, could be the same issue that my
Ovi maps was suffering?
Comment 14 Andre Klapper maemo.org 2010-06-24 09:43:39 UTC
This looks like a duplicate of bug 7026 to me. Please see the comments over
there.

*** This bug has been marked as a duplicate of bug 7026 ***
Comment 15 Joerg Reisenweber 2012-04-15 18:48:57 UTC
> Anyway, perhaps the conditions were just too bad, i.e. no mobile cell signal,
> being on a moving train, cloudy skies, and so it could not get a fix.  But then
> again, it could SEE the satellites, so why could it not do anything with them?

sorry for late comment: 
just to clarify, the "SV in sight" usually is a calculated figure from assumed
position, time, and ephem/alm. It means "number of sats that are 'visible' and
*could* be seen". While "SV in use" are the sats that are actually detected and
thus really "seen". Since the GPS chip looks for the visible sats, it's very
important to have rather correct time setting to begin with, this helps a lot
to look for the right signals in all that noise.