Bug 10495 - (int-172076) Double-tap to zoom into text paragraph doesn't work properly
(int-172076)
: Double-tap to zoom into text paragraph doesn't work properly
Status: RESOLVED FIXED
Product: Browser
Zooming
: 5.0:(10.2010.19-1)
: All Maemo
: Unspecified normal with 7 votes (vote)
: 5.0/(20.2010.36-2)
Assigned To: unassigned
: browser-zooming-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-06-02 13:51 UTC by Dawid Lorenz
Modified: 2010-11-05 15:27 UTC (History)
5 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Dawid Lorenz (reporter) 2010-06-02 13:51:12 UTC
SOFTWARE VERSION:
PR1.2

EXACT STEPS LEADING TO PROBLEM: 
1. Open up http://www.good.is/post/how-nokia-is-dialing-up-the-future/ in
Browser
1a. Alternative example URL: http://telepolis.pl/news.php?id=18300
2. Wait until page loads completely
3. Double-tap on page column with main article

EXPECTED OUTCOME:
Zoom directly into article text.

ACTUAL OUTCOME:
Variable. Sometimes zooms OUT, sometimes zooms in only a little (so text isn't
filling whole screen), sometimes - yet quite rarely - zooms into text as
expected.

REPRODUCIBILITY:
Variable.

EXTRA SOFTWARE INSTALLED:
Adblock add-on.

OTHER COMMENTS:
This feature used to work way more reliably pre-PR1.2, after the recent update
I get into zooming trouble on daily basis.

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.3)
Gecko/20100403 Fedora/3.6.3-4.fc13 Firefox/3.6.3
Comment 1 tuukka.tolvanen nokia 2010-06-03 03:15:22 UTC
(In reply to comment #0)
> SOFTWARE VERSION:
> PR1.2
> 
> EXACT STEPS LEADING TO PROBLEM: 
> 1. Open up http://www.good.is/post/how-nokia-is-dialing-up-the-future/ in

This looks to have the same trigger as mentioned in bug 10290 comment 4, the
entire article is a single paragraph element.

> 1a. Alternative example URL: http://telepolis.pl/news.php?id=18300

This document seems to do the expected sort of thing 19/20 within the main
column; if you hit maybe somewhere e.g. right after a horizontal rule then an
outer element is found leading to zoom-out.
Comment 2 Dawid Lorenz (reporter) 2010-06-03 10:12:57 UTC
(In reply to comment #1)
> > EXACT STEPS LEADING TO PROBLEM: 
> > 1. Open up http://www.good.is/post/how-nokia-is-dialing-up-the-future/ in
> 
> This looks to have the same trigger as mentioned in bug 10290 comment 4, the
> entire article is a single paragraph element.

This page I am not sure about, as that was one-off page I visited.

> > 1a. Alternative example URL: http://telepolis.pl/news.php?id=18300
> 
> This document seems to do the expected sort of thing 19/20 within the main
> column; if you hit maybe somewhere e.g. right after a horizontal rule then an
> outer element is found leading to zoom-out.

Strange, because it's quite opposite experience to me. :-o I read articles on
telepolis.pl on daily basis and after updating to PR1.2 it got noticeably
harder to get zoom right.

Another example of website that I often read and now struggle to zoom in:
http://wiadomosci.gazeta.pl/Wiadomosci/1,80277,7967949,ONZ_potepia__Skandaliczny_atak_sil_izraelskich__Kolejny.html
Comment 3 tuukka.tolvanen nokia 2010-06-03 22:28:25 UTC
> Another example of website that I often read and now struggle to zoom in:
> http://wiadomosci.gazeta.pl/Wiadomosci/1,80277,7967949,ONZ_potepia__Skandaliczny_atak_sil_izraelskich__Kolejny.html

yeah, that one fails reliably in the main article body, same trigger as bug
10290 comment 4 here too.
Comment 4 Dawid Lorenz (reporter) 2010-06-06 04:24:38 UTC
(In reply to comment #3)
> > Another example of website that I often read and now struggle to zoom in:
> > http://wiadomosci.gazeta.pl/Wiadomosci/1,80277,7967949,ONZ_potepia__Skandaliczny_atak_sil_izraelskich__Kolejny.html
> 
> yeah, that one fails reliably in the main article body, same trigger as bug
> 10290 comment 4 here too.

Right. I have pointed out already couple of times - zooming into this pages did
work much better in pre-PR1.2-era and I don't suspect these guys have suddenly
started using <br>'s instead of full paragraphs at roughly the same time when
PR1.2 was released.

On the other hand, justifying this issue with internal html page formatting
isn't very end-user friendly, as end-user doesn't need to know what <br> and
<p> is.
Comment 5 Christian Sarrasin 2010-06-09 09:30:50 UTC
I have also noticed this behaviour since PR1.2.  Actually happens all the time
when trying to zoom in the forums in t.m.o.  Agree with previous comment: it
used to work much better before 1.2.  This is one of the nastiest PR1.2
regressions for me.


Now, the browser is one of the flagship features of the N900 (and I could add
one of the only stock apps that *used to* work to a satisfactory degree) but
this heavily hinges on things like this working in a usable way!  In other
words, this regression nearly takes away one of the N900's only selling points
from an apps perspective.  Bad!
Comment 6 Christian Sarrasin 2010-06-09 09:32:30 UTC
People, please please vote for this bug!
Comment 7 pepitoe 2010-06-09 13:32:25 UTC
*** This bug has been confirmed by popular vote. ***
Comment 8 Christian Sarrasin 2010-06-09 17:39:02 UTC
On the zooming to paragraph question, shouldn't the behaviour be to attempt to
make the full paragraph visible, unless it's too tall, in which case it just
zooms to "page width" (with the point of tapping more or less in the center of
the screen) and lets you scroll the paragraph vertically *with a readable font
size*?

My impression is that this is kind of how it used to work pre PR1.2.
Comment 9 Pekka Vanhoja 2010-06-21 13:31:14 UTC
Hi,

Please see bug 10290, comment 13.
Comment 10 Andre Klapper maemo.org 2010-06-30 17:43:59 UTC
Closing as this was resolved by bug 10290.
Comment 11 Andre Klapper maemo.org 2010-10-25 17:13:58 UTC
The problem reported here should be fixed in the update that was released today
for public: The Maemo5 update version 20.2010.36-2 (also called "PR1.3"
sometimes). Please leave a comment if the problem is not fixed for you in this
update version.
Comment 12 Dawid Lorenz (reporter) 2010-11-05 15:27:12 UTC
I can confirm double-tap-to-zoom feature has been fixed in PR1.3