Bug 10446 - Show multiple contacts for a shared number instead of the number
: Show multiple contacts for a shared number instead of the number
Status: RESOLVED FIXED
Product: Chat & Call & SMS
Call Application UI
: 5.0:(10.2010.19-1)
: All Maemo
: Unspecified enhancement (vote)
: Harmattan
Assigned To: rtcomm@maemo.org
: call-ui-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-05-31 13:45 UTC by Bjoern Olausson
Modified: 2010-05-31 17:31 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Bjoern Olausson (reporter) 2010-05-31 13:45:43 UTC
SOFTWARE VERSION:
PR1.2

EXACT STEPS LEADING TO PROBLEM: 
Add two contacts with a identical phone number 

EXPECTED OUTCOME:
When one of these contacts calls, both contacts should be displayed instead of
a number.

ACTUAL OUTCOME:
When a number is assigned to more then one contact the number instead of one of
the contacts is shown.

REPRODUCIBILITY:
always

OTHER COMMENTS:
Referring to the discussion started in another bug (#6930):

Comment #27 from Mikhail Zabaluev (Nokia)   2010-05-31 12:11:45 GMT+3 [reply]
(In reply to comment #26)
> Apparently it now fails to associate a normal number.
>
> Two contacts have this number, so instead of showing one of them, now none is
> shown, just the number.

This is a different bug, or even a feature -- see below :)

> and numbers which are assigned to multiple contacts (some show the latest,
> some the first matching, some the last).

Hmm, could there be any problems with that?
Like a case with a manager in a corporation that shall remain unnamed. He
stored the switchboard number into contacts of his several colleagues. Somehow
it is possible to call him that the switchboard number is the caller ID. Of
course it was a high-ranking manager calling him when the phone was showing the
caller as his beer buddy...



Comment #28 from Bjoern Olausson (reporter)   2010-05-31 12:49:24 GMT+3 [reply]
(In reply to comment #27)

Mhh, I remember a story, where a manager added the switchboard number into
contacts of his several colleagues. Somehow it is possible to call him that the
switchboard number is the caller ID Of course it was a high-ranking manager
calling him when the phone was showing a number he he didn't recognize while he
was in a hurry...

Since he knows his colleagues by name and he knows he added the switchboard
number to all his colleagues he would have realized that it might be something
important...

So honestly... what do you want to tell me? The Display is to small to show the
first matching contacts and "3 more matching" or, why not show as much as
possible contacts an when the display runs out of lines "and X more matching"

Nice try... but seriously



Comment #29 from Mikhail Zabaluev (Nokia)   2010-05-31 12:56:22 GMT+3 [reply]
(In reply to comment #28)
> So honestly... what do you want to tell me? The Display is to small to show the
> first matching contacts and "3 more matching" or, why not show as much as
> possible contacts an when the display runs out of lines "and X more matching"

This would be a really good way to do it. But this is a subject for another
bug.




User-Agent:       Opera/9.80 (X11; Linux x86_64; U; en) Presto/2.5.24
Version/10.53
Comment 1 Andre Klapper maemo.org 2010-05-31 17:31:50 UTC
WONTFIX for Maemo5 as per bug 6930, FIXED in Harmattan as per bug 6930.