Bug 1043 - Add priority to defined wifi connections
: Add priority to defined wifi connections
Status: RESOLVED WONTFIX
Product: Connectivity
WiFi
: 5.0/(2.2009.51-1)
: All Maemo
: Medium enhancement with 67 votes (vote)
: Harmattan
Assigned To: unassigned
: wifi-bugs
:
: enhancement-it2006
:
: 1232 4264 8444
  Show dependency tree
 
Reported: 2007-02-09 22:20 UTC by Laurent GUERBY
Modified: 2012-03-24 11:38 UTC (History)
10 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Laurent GUERBY (reporter) 2007-02-09 22:20:03 UTC
I have access to multiple wifi networks (two router at home, one FON and
another
one). I defined them but I see no way to put a priority so that my Nokia N800
prefers one over the other. If it's not there it would be a useful feature.
Comment 1 Laurent GUERBY (reporter) 2008-09-25 15:55:16 UTC
After a year and a half I would love to see this enhancement implemented.

I've recently bought an ACER Aspire One netbook (under Linux by Linpus) and the
connectivity setting dialog has a list with up and down to define priority
amongst wifi connection.
Comment 2 Neil MacLeod maemo.org 2008-12-03 20:28:11 UTC

*** This bug has been marked as a duplicate of bug 402 ***
Comment 3 Andre Klapper maemo.org 2008-12-04 12:05:42 UTC
Let's keep the votes by marking bug 402 as a dup of bug 1043.
Comment 4 Andre Klapper maemo.org 2008-12-04 12:06:00 UTC
*** Bug 402 has been marked as a duplicate of this bug. ***
Comment 5 Laurent GUERBY (reporter) 2008-12-04 12:45:33 UTC
Sorry I didn't spot #402 when creating this report (which is still much wanted
:)
Comment 6 Olivier Mengué 2009-08-11 12:44:32 UTC
Use case:

My wifi router provided by my ISP has two SSID:
- one with WPA2 and full web access, available only at home.
- one for access anywhere (using routers of other customers of the ISP
network). Requires authentication through a web form.

At home I would be able to auto-connect to the first one, not the second one.
Comment 7 Quim Gil nokia 2010-01-21 12:52:26 UTC
There are some plans in this direction for Harmattan. The first step is basic:
being able to define connections that will connect automatically. This will
allow you to define in a certain context (home, office...) which is the wlan
you want to connect automatically.

In theory you still would get in situations where you have set 2 wlans with the
instruction to connect automatically. This would still create a conflict but,
how likely that situation would be?

The priority list might still come, but requires more work and we have other
priorities at the moment.
Comment 8 Neil MacLeod maemo.org 2010-01-21 14:35:52 UTC
(In reply to comment #7)
> There are some plans in this direction for Harmattan. The first step is basic:
> being able to define connections that will connect automatically. This will
> allow you to define in a certain context (home, office...) which is the wlan
> you want to connect automatically.
> 

That's bug 1050, should this bug be a dependency of bug 1050?

> In theory you still would get in situations where you have set 2 wlans with the
> instruction to connect automatically. This would still create a conflict but,
> how likely that situation would be?
> 
> The priority list might still come, but requires more work and we have other
> priorities at the moment.
> 

For my circumstances, I would agree with your approach (not speaking for
others!)

I either want to auto-connect to a WLAN, or I don't - it would be very rare for
me to be in the vicinity of two or more WLANs that can be auto-connected.
Disabling the auto-connect capability for the WLANs I don't want to connect to
on a regular basis will effectively "deprioritise" those WLANs. It's not
perfect, but it would work well enough.
Comment 9 Quim Gil nokia 2010-01-22 10:37:56 UTC
(In reply to comment #8)
> That's bug 1050, should this bug be a dependency of bug 1050?

Ah yes, I forgot about that one yesterday. Let's keep both enhancement requests
apart since technically they are not dependent. A Bug 1050 fix is planned but
there are not firm plans to address this one yet.
Comment 10 Lucas Maneos 2010-01-22 11:49:59 UTC
(In reply to comment #8)
> I either want to auto-connect to a WLAN, or I don't - it would be very rare for
> me to be in the vicinity of two or more WLANs that can be auto-connected.

Ah, but imagine living or working within range of a hotspot provider that you
normally want to use when your own WLANs are not visible (ie at other
locations) :-)
Comment 11 Olivier Mengué 2010-01-29 01:16:30 UTC
Here is a similar concrete use case: my ISP, Free.fr, gave me an ADSL box that
provides two WLAN:
- a private WLAN for my private usage
- a semi-public WLAN (FreeWifi) that gives a limited internet access (HTTP
only, limited bandwidth) to all Free.fr customers with authentication through a
web form.

When I'm away from home my preference is to use the FreeWifi from the Free.fr
boxes in the neighborhood.
When I'm at home I want to use my private WLAN, not the limited FreeWifi.
Both have the same signal strength as they come from the same hardware.
Comment 12 First Knight 2010-05-23 15:06:57 UTC
i think all available saved connection.... include data connection...
Comment 13 First Knight 2010-05-23 18:51:19 UTC
sorry for keeping it short...

in the internet connection there are data connection that connects to network
providers internet connection and wifi connection. So I would suggest that all
of the available or saved connection in the internet connection can be
prioritized to be connected whichever comes or available first in the list... 

For example.
my mobile network data connection is known as Diginet and also the mms settings
Digimms.
wifi available or saved is for example BUG, FKKK, BULL.

Now I save connection whenever I set up and am unable to sort it according to
the priority I wanted. Currently is BUG, Digimms, Diginet, FKKK, BULL in the
said order.

I want to organise it to go in the order of priority:-
1) FKKK
2) Diginet
3) BULL
4) BUG
5) Digimms

So I am trying to say that priority for organising the available connection in
the internet connection would include the data connection available by our
network providers and wifi saved.
Comment 14 Andre Klapper maemo.org 2012-03-21 18:07:12 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia, hence resetting the ASSIGNED
status to NEW/UNCONFIRMED as nobody is working on this.

Note that very likely any feature requests for Maemo5 will not receive fixes
(WONTFIX) - I might mass-set this status in the future. There is a very small
chance for issues in open source components that contributed patches could be
included in the Maemo 5 CSSU Community updates - see http://wiki.maemo.org/CSSU
for more information.


For completeness (as Harmattan is mentioned in some reports), MeeGo 1.2
Harmattan used for the N9 and N950 is handled in
http://harmattan-bugs.nokia.com/ which has recently been closed for new bug
report entry [1].

[1]
http://www.developer.nokia.com/Community/Blogs/blog/n9-developer/2012/03/08/harmattan-bugzilla-closed-for-new-bugs
Comment 15 Andre Klapper maemo.org 2012-03-24 11:38:54 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia and it seems that there are no
plans for official updates currently, hence nobody plans to work on this
enhancement/wishlist request. 
(And in case you feel like discussing this situation: Nokia Customer Care or
http://talk.maemo.org would be the place to do so as you will not reach Nokia
officials in this community bugtracker - though all of this is really no news.)

Reflecting this status by setting RESOLVED WONTFIX for this
enhancement/wishlist request (see
https://bugs.maemo.org/page.cgi?id=fields.html#status for status explanations).

There is a small chance for issues in those Maemo components that are open
source: Contributed patches could be included and made available in the Maemo 5
Community CSSU updates. 
The Maemo CSSU project is run by a small team of volunteers; see
http://wiki.maemo.org/CSSU for more information.
So in case that you can provide a patch that fixes the reported problem, please
feel encouraged to file a request under
https://bugs.maemo.org/enter_bug.cgi?product=Maemo%205%20Community%20SSU .
Please note: The Maemo CSSU project is not related in any way to Nokia.


( Tag for mass-deleting bugmail: [cleanup20120324] )