Bug 10357 - (int-171352) Manual send & receive doesn't always retrieve emails
(int-171352)
: Manual send & receive doesn't always retrieve emails
Status: RESOLVED FIXED
Product: Email
General
: 5.0:(10.2010.19-1)
: ARM Maemo
: Unspecified normal with 8 votes (vote)
: 5.0/(20.2010.36-2)
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-05-27 19:46 UTC by Jason
Modified: 2010-10-25 17:12 UTC (History)
9 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Jason (reporter) 2010-05-27 19:46:12 UTC
SOFTWARE VERSION:
10.2010.19-1

EXACT STEPS LEADING TO PROBLEM: 
1. Go into email, it shows provider, press Send & Receive, no mails are
retrieved
2. Go into provider, go into Inbox, shows empty email list.  Press Send &
Receive, no emails are retrieved
3. Go back up into folder list, shows Inbox, etc.  Press Send & Receive, many
emails are retrieved.

EXPECTED OUTCOME:
Send & Receive from any part of the application should retrieve all emails

ACTUAL OUTCOME:
It seems manual Send & Receive only works inside the folder list

REPRODUCIBILITY:
9/10

EXTRA SOFTWARE INSTALLED:
Nothing email related

OTHER COMMENTS:
This is a POP3 inbox
Comment 1 Tim Teulings 2010-05-28 20:46:09 UTC
*** This bug has been confirmed by popular vote. ***
Comment 2 Tim Teulings 2010-05-30 10:47:42 UTC
I'm also vitim of this bug.It seems like only "Send & Receive" on the main
windows does correctly detect new messages on the server atall. However there
seems to be cases where it fails, too. I'm also not sure if notification of
emails always works in cases where emails where correctly received.

For me this is certainly close to a blocker, since email notification does not
reliably works and it is possible that I miss mails for a number of hours if I
do not explicitely and repeately poll over and over again. And even in this
cases I cannot trust the app to work correctly! I also already had some random
crashes (going back from details view to main window), but haven't yet found a
pattern.

I installed and *deinstalled* a number of applications before, like fMMS and
that tool to interupt pending connections (what was its name :-/) - just in
case they have left something ugly behind after deinstallation.
Comment 3 Max 2010-05-30 18:17:54 UTC
SOFTWARE VERSION: 10.2010.19-1 (since 2010-05-29)

For testing I have send emails every 10 minutes to my popbox. The interval for
getting email is also 10 minutes.

EXACT STEPS LEADING TO PROBLEM: 
1. I wait until I hear the "you've got mail" sound. With every notification I
open e-mail, read message, close e-mail. Untill so far so good.
2. After several times I get no sound (like 3 mails, or 30 minutes) the
notification stops. And I try to Send/Receive manually.
3. Open e-mail. Last update ± 30 minutes ago.
4. Open Inbox, waiting symbol appears. Nothing happens
5. Back to account. Message on Busy sending/receiving. But nothing happens.
6. Close e-mail. Wait a minute, open e-mail again. 
7. Stop at account. and not going to Inbox. Time is stil on 30 minutes ago.
8. Choose Send/Receive. 
9. E-mail got received.

EXPECTED OUTCOME:
At 2: No stop at automatically receiving e-mail
At 5: Directly receiving e-mail, no "hanging" of e-mail application.

ACTUAL OUTCOME:
At 9: After several restarts of e-mail application it works for some time. 

REPRODUCIBILITY:
9/10 - unclear now when or what causes this problem. This makes e-mail
notification unreliable. And I use the notification at nights, when I am
asleep.

EXTRA SOFTWARE INSTALLED:
a lot. But nothing extra for e-mail, I think. No fMMS either.

OTHER COMMENTS:
I hope this is the same problem as the original reporter. 
I don't know if Notification and Send/Receive is the same application. It seems
related.
N900 is connected through Wlan, no 3g-connection available.
e-mail from Pop3 account, like pop.website.nl

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.9)
Gecko/20100317 SUSE/2.0.4-3.2 SeaMonkey/2.0.4
Comment 4 Tim Teulings 2010-06-05 17:59:29 UTC
It looks like the problem is POP3 related as it does not show up for my IMAP
account. However having both a POP3 and IMAP account, POP3 refresh shows bug,
while IMAP does not.
Comment 5 ron 2010-06-08 00:38:40 UTC
to turn off and on the internetconnection could help sometimes, or wait when
you mannually tried to recieve the e-mail about 3 times.
Comment 6 Andre Klapper maemo.org 2010-06-29 11:59:05 UTC
Fix checked in in the codebase (for those that like to compile themselves):
http://gitorious.org/modest/modest/commit/f2dc25426f49e090f31e858f6639726febde76ec
Comment 7 Andre Klapper maemo.org 2010-06-30 16:02:06 UTC
(In reply to comment #6)
> Fix checked in in the codebase

...and
http://gitorious.org/modest/modest/commit/8b2af078ea37f89e39e43a78f57b9354d5948349
as the second part.
Comment 8 JonWW 2010-07-03 22:25:27 UTC
For anyone who does not have the fix:-
daxyp has kingly compile this and it can be manualy installed in XTerminal.
You can download it from
http://talk.maemo.org/showpost.php?p=722013&postcount=1
Also fixes bug 10435
Comment 9 Andre Klapper maemo.org 2010-07-08 14:30:22 UTC
This has been fixed in package
modest 3.4.5+0m5
which is part of the internal build version
2010.26-8
(Note: 2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 10 Andre Klapper maemo.org 2010-10-25 17:12:33 UTC
The problem reported here should be fixed in the update that was released today
for public: The Maemo5 update version 20.2010.36-2 (also called "PR1.3"
sometimes). Please leave a comment if the problem is not fixed for you in this
update version.