Bug 10340 - Fast search on the desktop - layout can not be switched
: Fast search on the desktop - layout can not be switched
Status: RESOLVED DUPLICATE of bug 2501
Product: Desktop platform
Input method framework
: 5.0:(10.2010.19-1)
: N900 Maemo
: Medium major with 2 votes (vote)
: ---
Assigned To: Joaquim Rocha
: input-method-framework-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-05-27 11:53 UTC by Sergey
Modified: 2010-05-29 00:20 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Sergey (reporter) 2010-05-27 11:53:13 UTC
SOFTWARE VERSION:
N900, Maemo 5, Version 10.2010.19-1

EXACT STEPS LEADING TO PROBLEM: 
Test 1
1. Contacts App->New Contact->switch keyboard layout to Russian-> type and Save
Russian contact name
2. Contacts App->New Contact->switch keyboard layout to Latin-> type and Save
English contact name. Do not switch layout back to Russian at this point.
3. Go to the Desktop and try to switch layout to Russian in order to lookup
Russian name. 

Test 2
1. Contacts App->New Contact->switch keyboard layout to Latin-> type and Save 
English contact name
2. Contacts App->New Contact->switch keyboard layout to Russian-> type and Save
Russian contact name. Do not switch layout back to English at this point.
3. Go to the Desktop and try to switch layout to English in order to lookup
English name. 


EXPECTED OUTCOME:

While in the Deskttp, Ctrl+Space should switch the layout to Russian or Latin
in order to perform lookup of Russian or English contact. 

ACTUAL OUTCOME:

Ctrl+Space does not work in the Desktop. The characters are translated
according to the current layout, which is not the desired one.

REPRODUCIBILITY:
Always

EXTRA SOFTWARE INSTALLED:
None

OTHER COMMENTS:
None
Comment 1 Sergey (reporter) 2010-05-27 11:56:31 UTC
This bug is related to #8390
Comment 2 Andre Klapper maemo.org 2010-05-27 13:15:31 UTC
Why does this problem block bug 8390 which is already fixed?
Comment 3 Sergey (reporter) 2010-05-27 13:33:33 UTC
The solution to #8930 does not cover scenario when we have contacts in more
than one language (for example in English and Russian). 

In order to lookup contacts in any of two languages (primary/secondary layouts)
we need ability to select the approptiate keyboard layout before entering the
search string in the Desktop.

I would suggest to consider reopening #8930 or merging this #10340 with #8930
as they both relate to the same issue.
Comment 4 Andre Klapper maemo.org 2010-05-29 00:20:29 UTC
Bug 8390 fixed this case when using Settings > Text input > Hardware Layout.
I'd say it's unrelated.

What you are facing though sounds like bug 2501. :)

*** This bug has been marked as a duplicate of bug 2501 ***