Bug 10322 - (int-171901) RDS tag (using FM-Transmitter) only shows "Nokia" on car radio (worked in PR1.1.1)
(int-171901)
: RDS tag (using FM-Transmitter) only shows "Nokia" on car radio (worked in PR1...
Status: RESOLVED INVALID
Product: Multimedia
FM Transmitter
: 5.0:(10.2010.19-1)
: N900 Maemo
: Low normal (vote)
: ---
Assigned To: unassigned
: fmtx-bugs
:
:
:
: 7353
  Show dependency tree
 
Reported: 2010-05-26 21:53 UTC by michael.y.guan
Modified: 2010-06-24 14:26 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description michael.y.guan (reporter) 2010-05-26 21:53:36 UTC
SOFTWARE VERSION: PR 1.2 10.2010.19-1
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 

1. Open Media Player and play any song you like. 
2. Turn On FM-Transmitter
3. Tune your RDS-capable radio (i.e. your car radio) to the N900's frequency

EXPECTED OUTCOME:

The RDS-capable car radio shows at least the song title as the N900's station
name. PR 1.1.1 used to be able to show Song Title, Album and Artist. 

According to Andre Klapper in this post below, PR 1.2 is supposed to transmit
the title of the song.

https://bugs.maemo.org/show_bug.cgi?id=7353

Notice that other people experienced this bug too.
(http://talk.maemo.org/showthread.php?t=52797)
ACTUAL OUTCOME:

The RDS-capable car radio just shows "Nokia", just like before the PR 1.1
update. No song information is transmitted.

REPRODUCIBILITY:

always

EXTRA SOFTWARE INSTALLED:

fm-boost
Simple FMTX desktop widget

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2.3)
Gecko/20100401 Firefox/3.6.3
Comment 1 Kai Hult 2010-05-27 13:53:23 UTC
N900 support RDS-PS and RDS-text. If radio doesn't support RDS-text then Nokia
is show on display.

There is problems with some station names which are over 8 char long which is
maximum size what RDS-PS can display. For that reason station RDS-text is which
shows the station name.
Comment 2 Bartosz Taudul 2010-05-31 23:38:13 UTC
Confirming.

(In reply to comment #1)
> (...)
While this may be true, the bottom line is that this feature worked before
PR1.2 and now it doesn't.
Comment 3 Arif Toker 2010-06-01 18:18:06 UTC
I can confirm this bug being present in PR1.2 final too, while it worked fine
in PR1.1.1.
Comment 4 Chad Diederichs 2010-06-02 20:24:56 UTC
(In reply to comment #2)
> Confirming.
> 
> (In reply to comment #1)
> > (...)
> While this may be true, the bottom line is that this feature worked before
> PR1.2 and now it doesn't.
> 


It's not a bug, it's just conforming to the industry standard for RDS text
transmission.   It still works.   It's not really the Maemo software's fault
that your particular radio only supports RDS Title display and not RDS Text
display.  Most new car radios support this by either automatically displaying
the RDS Title and then the RDS Text, or by having a RDS Text button that can be
manually toggled.
Comment 5 Andre Klapper maemo.org 2010-06-24 14:26:33 UTC
"In PR1.1, Media player used PS field to show the RDS data. Then we got a bug
report because we were violating RDS specification, RadioText field should have
been used instead. There was long discussion which one should be used, because
there are not many car radios in world that supports RadioText. Final decision
was to follow specification even in many car radios the rds data is not going
to be shown anymore."