Bug 10310 - (int-164592) can't write a lower case letter after a dot even if you'd do it with shift
(int-164592)
: can't write a lower case letter after a dot even if you'd do it with shift
Status: RESOLVED FIXED
Product: Desktop platform
Input method framework
: 5.0:(10.2010.19-1)
: N900 Maemo
: High major with 30 votes (vote)
: 5.0/(20.2010.36-2)
Assigned To: Joaquim Rocha
: input-method-framework-bugs
:
:
:
: int-172077
  Show dependency tree
 
Reported: 2010-05-26 17:34 UTC by Miika Arponen
Modified: 2010-11-05 15:34 UTC (History)
11 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Miika Arponen (reporter) 2010-05-26 17:34:15 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. write a dot for example in an SMS
2. write some letter after it with shift on

EXPECTED OUTCOME: lower case letter

ACTUAL OUTCOME: upper case letter

REPRODUCIBILITY: always 
(always, less than 1/10, 5/10, 9/10)

EXTRA SOFTWARE INSTALLED: nothing concerning input methods

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US)
AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.1.249.1064 Safari/532.5
Comment 1 Bartosz Taudul 2010-05-26 17:44:44 UTC
Confirming. Note that you must place a space between the dot and the letter and
you must use physical keyboard, not the on-screen one.
Comment 2 fileshifter 2010-05-27 15:55:43 UTC
Confirming. This is overly annoying. Same thing at the beginning of a text
input btw, not just after dots.
Comment 3 Bartosz Taudul 2010-05-28 19:17:24 UTC
*** Bug 10391 has been marked as a duplicate of this bug. ***
Comment 4 Andre Klapper maemo.org 2010-05-28 20:33:39 UTC
*** Bug 10273 has been marked as a duplicate of this bug. ***
Comment 5 Bartosz Taudul 2010-06-01 00:21:46 UTC
*** Bug 10432 has been marked as a duplicate of this bug. ***
Comment 6 Andre Klapper maemo.org 2010-06-16 18:19:14 UTC
*** Bug 10697 has been marked as a duplicate of this bug. ***
Comment 7 Andre Klapper maemo.org 2010-06-17 13:46:01 UTC
This has been fixed in package
hildon-input-method-framework 1:2.1.61-1+0m5
which is part of the internal build version
2010.24-2
(Note: 2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 8 Andre Klapper maemo.org 2010-06-20 14:04:38 UTC
*** Bug 10724 has been marked as a duplicate of this bug. ***
Comment 9 Neil MacLeod maemo.org 2010-07-08 23:35:21 UTC
*** Bug 10898 has been marked as a duplicate of this bug. ***
Comment 10 Andre Klapper maemo.org 2010-10-25 17:13:41 UTC
The problem reported here should be fixed in the update that was released today
for public: The Maemo5 update version 20.2010.36-2 (also called "PR1.3"
sometimes). Please leave a comment if the problem is not fixed for you in this
update version.
Comment 11 Dawid Lorenz 2010-11-05 15:34:54 UTC
Confirmed as fixed.