Bug 10294 - (int-171318) Email desktop widget does not display mails from Nokia Messaging accounts
(int-171318)
: Email desktop widget does not display mails from Nokia Messaging accounts
Status: RESOLVED WONTFIX
Product: Desktop Widgets
Email Widget
: 5.0:(10.2010.19-1)
: N900 Maemo
: Unspecified normal with 32 votes (vote)
: ---
Assigned To: unassigned
: mail-applet-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-05-26 09:49 UTC by Scifi
Modified: 2010-11-21 19:39 UTC (History)
14 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Scifi (reporter) 2010-05-26 09:49:17 UTC
SOFTWARE VERSION:
10.2010.19-1.002

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Configure Email on N900 with Nokia Messaging
2. Add Email widget to desktop

EXPECTED OUTCOME:
Email widget on desktop should display emails from the accounts configured with
Nokia Messaging. The number of new/unread emails should be displayed in the
title bar of the widget.

ACTUAL OUTCOME:
Email widget displays a message "(Tap to see messages)". The title bar displays
the number 0 indicating 0 emails.

REPRODUCIBILITY:
Always

EXTRA SOFTWARE INSTALLED:
Not Applicable

OTHER COMMENTS:
Tapping on the widget does open Nokia Messaging, but the widget does not
display any emails which makes it useless.

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3)
Gecko/20100401 Firefox/3.6.3 ( .NET CLR 3.5.30729)
Comment 1 Scifi (reporter) 2010-05-26 09:50:30 UTC
The Component for this bug should be "Email" but Email is not available in the
list.
Comment 2 Juliane Scheider 2010-05-26 10:15:02 UTC
*** This bug has been confirmed by popular vote. ***
Comment 3 bugelrex 2010-05-28 01:27:14 UTC
Can the fix for this be released as a 'application' download instead of waiting
for the next (if there is going to be a next one) huge firmware release?
Comment 4 blue13x 2010-05-28 04:19:37 UTC
Im also getting this bug. Nokia Messaging is Nokia's MAIN email service and it
should work with widget....would be usefull.
Comment 5 Andre Klapper maemo.org 2010-05-28 14:05:45 UTC
(In reply to comment #3)
> Can the fix for this be released as a 'application' download instead of waiting
> for the next (if there is going to be a next one) huge firmware release?

There is no fix yet. Plus such things are up to Nokia's release management and
hence are off-topic for maemo.org Bugzilla which is for users and developers.
Comment 6 Andre Klapper maemo.org 2010-05-28 19:09:04 UTC
*** Bug 10315 has been marked as a duplicate of this bug. ***
Comment 7 Andre Klapper maemo.org 2010-06-18 13:22:32 UTC
Forwarding Nokia's WONTFIX decision:

"Email home applet must not display email subjects, this is specified in the
internal User Interface specification that is not planned to be changed. Here
is the quotation:
"Messages received in Nokia Messaging accounts, if any, are not displayed in
the applet. Only a Nokia Messaging Header row is displayed, showing the total
amount of new messages for all Nokia Messaging accounts. Tapping on the header
row opens the Nokia Messaging accounts list. The row is always displayed last
in the list."

As far as I understand this requirement was defined due to legal restrictions
for Nokia Messaging Service accounts."
Comment 8 Nick Cremelie 2010-06-18 13:42:11 UTC
This bug is actually twofold: the message headers are not displayed AND the
total number of new messages is not indicated properly. Per Nokia's
specification, it is designed behavior not to display the headers. However, the
specification also states that the "total amount of new messages for all Nokia
Messaging accounts" should be shown. This is not the case, the number of new
messages is always displayed as 0 even when there are effectively new messages
waiting. So there is still an issue as the applet is not behaving according to
spec. Therefore I propose to reopen this issue.
Comment 9 Neil MacLeod maemo.org 2010-06-18 13:46:08 UTC
It should have taken all of 5 seconds for the creator of the internal comment
to perform a basic test and realise the widget isn't working, and it would have
saved all the effort writing a comment that has resulted in this bug being
erroneously closed wontfix.

Doesn't anyone test this stuff before blowing off a valid bug with a pointless
quote from the spec?
Comment 10 Scifi (reporter) 2010-06-18 22:47:05 UTC
(In reply to comment #8)
> This bug is actually twofold: the message headers are not displayed AND the
> total number of new messages is not indicated properly. Per Nokia's
> specification, it is designed behavior not to display the headers. However, the
> specification also states that the "total amount of new messages for all Nokia
> Messaging accounts" should be shown. This is not the case, the number of new
> messages is always displayed as 0 even when there are effectively new messages
> waiting. So there is still an issue as the applet is not behaving according to
> spec. Therefore I propose to reopen this issue.
> 

Agreed. I have done a quick test today and I can confirm that Nokia Messaging
header row still displays 0 even though there are multiple new/unread emails in
Nokia Messaging accounts. This bug should be reopened.

@Andre - I can understand legal requirements to not display message header for
Nokia Messaging accounts. But did Nokia developers confirm that total message
count is working "as expected"?
Comment 11 Scifi (reporter) 2010-06-22 04:38:52 UTC
@Andre - What input is required from me (or anyone impacted by this bug) to
reopen this bug?
Comment 12 Andre Klapper maemo.org 2010-06-22 15:32:59 UTC
(In reply to comment #10)
> But did Nokia developers confirm that total message count is working "as 
> expected"?

No, as this was not the topic that this report is about.
If it does not work, please file a separate bug report.
Comment 13 Lance Colton 2010-06-22 18:44:32 UTC
(In reply to comment #7)
> Forwarding Nokia's WONTFIX decision:
> 
> "Email home applet must not display email subjects, this is specified in the
> internal User Interface specification that is not planned to be changed. Here
> is the quotation:
> "Messages received in Nokia Messaging accounts, if any, are not displayed in
> the applet. Only a Nokia Messaging Header row is displayed, showing the total
> amount of new messages for all Nokia Messaging accounts. Tapping on the header
> row opens the Nokia Messaging accounts list. The row is always displayed last
> in the list."
> 
> As far as I understand this requirement was defined due to legal restrictions
> for Nokia Messaging Service accounts."
> 

Hey wait, my E71 does this. It shows the subjects of the last 4 or 5 emails.
I'd think you must be wrong about it being a legal restriction. Can you please
double check what's going on here?
Comment 14 Andre Klapper maemo.org 2010-07-19 11:14:37 UTC
*** Bug 10948 has been marked as a duplicate of this bug. ***
Comment 15 Uxi 2010-08-13 20:46:43 UTC
Nokia Messaging widget on my N97 also shows the sender address and subject.
Comment 16 Andre Klapper maemo.org 2010-08-13 21:01:00 UTC
N97 is a completely different codebase and *technically* speaking not an
argument here.  Marketing aspects aren't handled in this Bugzilla. :)
Comment 17 Uxi 2010-08-13 21:04:53 UTC
Sure it's a different code base, but the argument wasn't technical, it was
claimed to be legal.  Like Lance posted with the E71, the N97 widget also shows
header information so the legal argument seems spurious
Comment 18 Neil MacLeod maemo.org 2010-08-13 21:12:27 UTC
You have to admit Andre, the argument put forward in comment #7 looks to be
more of an error/bug in the UI specification (and consequently the widget
becomes useless/pointless for Nokia Messaging users).

The N85 showed message subjects on it's home screen when I used it with Nokia
Messaging, which was effectively what the widget is designed to do.

Once again it appears a bug has been erroneously closed due to ineffective
communication between end users and internal developers who do nothing but
quote from a spec without engaging their brain and looking around them (for
instance, at other Nokia products that do happen to work in a sane way or as
the end users expect them to).

I would suggest this bug is re-opened, not that I'm expecting it to be fixed.
Comment 19 Andre Klapper maemo.org 2010-08-13 21:26:41 UTC
Sorry for my comment 16, I didn't have the context here in mind when writing.
I've pinged again asking for elaborating on the "legal arguments".
Comment 20 Rajil Saraswat 2010-08-30 17:54:05 UTC
(In reply to comment #19)
> Sorry for my comment 16, I didn't have the context here in mind when writing.
> I've pinged again asking for elaborating on the "legal arguments".
> 

Any update on this?
Comment 21 Andre Klapper maemo.org 2010-08-30 18:00:04 UTC
Thanks for the reminder!

Quim: As I don't get answers internally, can you please find out what exactly
the "legal restrictions" are in this case that block fixing this?
Comment 22 Neil MacLeod maemo.org 2010-09-01 02:25:25 UTC
A video[1] of the latest Nokia Messaging client clearly shows a Nokia Messaging
based email in the home screen widget with what appears to be the beginning of
an email subject...

If there is a legal restriction relating to Nokia Messaging and widgets then
someone should have a quick word with Davis Fields (and maybe suggest he irons
his shirts before doing videos...) :)

Perhaps contacting Davis would be a more expedient way to progress this
impasse? It's ridiculous that this bug should be held up for so long due to
what appears to be a basic misunderstanding within Nokia - it typifies the
problems that Nokia has with Bugzilla and "communicating" in general, just
reach out to someone in the Nokia Messaging team for crying out loud.

1. http://www.youtube.com/watch?v=ogUvnB5CCUI at 0:25
Comment 23 Andre Klapper maemo.org 2010-09-01 14:06:25 UTC
(Reopning for the time being)
Comment 24 Quim Gil nokia 2010-09-02 20:12:22 UTC
According to the developers, testing with the upcoming update the number of
new/unread emails displayed correctly.

About not displaying email subjects, at this point of Fremantle we are not
going to change the UI specs, sorry.
Comment 25 Andre Klapper maemo.org 2010-10-18 21:46:44 UTC
"Tested this scenario with internal software version that will become the next
public update and confirming that number of new/unread emails is now displayed
correctly. 
About not displaying email subjects: This can't be changed in Fremantle
anymore."
Comment 26 Andre Klapper maemo.org 2010-10-25 17:30:57 UTC
So 50% are FIXED in 20.2010.36-2 which was released today for public.
The other 50% are WONTFIX for Maemo5 and in the subject line, hence closing as
such.
Comment 27 roberth 2010-11-21 19:13:10 UTC
it is a very horrible email bug compared to other devices using nokia
messaging...no way to set default account (when sending an email) no idea which
email has a new message(s) must scroll through all...please fix the widget to
be somewhat like symbian....thank you
Comment 28 Andre Klapper maemo.org 2010-11-21 19:39:05 UTC
Please avoid "me too!" comments that create bugmail! Click "Vote for this bug"
instead. If you want to talk to Nokia, contact Nokia Customer Care.
bugs.maemo.org is not the place for such comments. Thanks.