Bug 10242 - control codes not working with N900's phone application
: control codes not working with N900's phone application
Status: RESOLVED DUPLICATE of bug 5357
Product: Chat & Call & SMS
Call Application UI
: 5.0/(3.2010.02-8)
: N900 Maemo
: Unspecified major (vote)
: ---
Assigned To: rtcomm@maemo.org
: call-ui-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-05-22 23:56 UTC by Rainer Dorsch
Modified: 2010-05-23 16:12 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Rainer Dorsch (reporter) 2010-05-22 23:56:37 UTC
SOFTWARE VERSION:
(Settings > General > About product)

see above

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. At least in Germany the telecommunication network operators all certain
control coded to be input by the keyboard, e.g. a common code is *101# for
requesting the current balance of the prepaid card. Every even very cheap phone
I had in my hands supports that. The N900 not. When I start the phone
application
2. I open the dialpad
3. I enter *101# and then dial

There are many control codes for many different functions, another example is
enabling and disabling the mailbox often works via control code.

EXPECTED OUTCOME:

The phone should "dial" the number and display the result (balance in this
example).

ACTUAL OUTCOME:

I get "wrong number" (translated back to English), the N900 does not dial.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
yes, but not relevant for phone application.

OTHER COMMENTS:


User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.5; Linux) KHTML/3.5.10
(like Gecko) (Debian)
Comment 1 Andre Klapper maemo.org 2010-05-23 16:12:52 UTC
Hi Rainer,
this particular issue has already been reported in our bug tracking system, but
please feel free to report any further bugs you find.

Will be fixed in the next public update (PR1.2).
Please do not comment on bug 5357.

*** This bug has been marked as a duplicate of bug 5357 ***