Bug 10227 - Batlevel uses extremely high amount of power as normally installed.
: Batlevel uses extremely high amount of power as normally installed.
Status: UNCONFIRMED
Product: Batlevel
General
: unspecified
: All Maemo
: High blocker (vote)
: ---
Assigned To: krk969
: general
:
:
:
:
  Show dependency tree
 
Reported: 2010-05-21 13:11 UTC by Ian Stirling
Modified: 2010-05-21 13:11 UTC (History)
0 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Ian Stirling (reporter) 2010-05-21 13:11:20 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Install batlevel
2. Start batlevel
3. Go to a desktop where it's not visible.
4. Top

EXPECTED OUTCOME:
Should be ~idle.
ACTUAL OUTCOME:
It's really not.

REPRODUCIBILITY:
Always.

EXTRA SOFTWARE INSTALLED:
Quite a lot.
OTHER COMMENTS:

Over a 10 second period.

strace -c -p  1794
Process 1794 attached - interrupt to quit
^CProcess 1794 detached
% time     seconds  usecs/call     calls    errors syscall
------ ----------- ----------- --------- --------- ----------------
 85.34    0.007812          31       252           poll
  7.68    0.000703           3       249           stat64
  3.99    0.000365           1       249           gettimeofday
  2.99    0.000274           0      1000           clock_gettime
  0.00    0.000000           0         1           restart_syscall
  0.00    0.000000           0       750           ioctl
------ ----------- ----------- --------- --------- ----------------
100.00    0.009154                  2501           total

Top shows it using around 1% of CPU.
Most recent version, not changed settings.
When I look at settings, it says 10s update interval.

This frequent polling increases powerusage when idle some 20* - from around 150
hours standby to around 20.

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.3)
Gecko/20100401 Firefox/3.6.3