Bug 10152 - Mail for Exchange, certificate problem
: Mail for Exchange, certificate problem
Status: RESOLVED DUPLICATE of bug 6582
Product: Email
General
: 5.0/(3.2010.02-8)
: N900 Maemo
: Unspecified normal (vote)
: ---
Assigned To: unassigned
: modest-bugs
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2010-05-10 23:45 UTC by Tuomas
Modified: 2010-05-23 18:24 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Tuomas (reporter) 2010-05-10 23:45:23 UTC
SOFTWARE VERSION:
Maemo-5 3.2010.02-8

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Setup Mail for Exchange account
2. Start first synchronization
3. Initializing synchronization fails, connection error to Exchange server
reported

EXPECTED OUTCOME:


ACTUAL OUTCOME:
could not set up and syncronize emails to exchange server

REPRODUCIBILITY:
always

OTHER COMMENTS:
Other mobile device users say that they need to confirm the certificate the
synchronization server is using. 

From syslog:
-clip-
May  6 13:58:13 Nokia-N900-51-1 maemo-launcher[1494]: invoking
'/usr/bin/browser.launch' 
May  6 13:58:13 Nokia-N900-51-1 maemo-launcher[1494]: opening of
/usr/bin/browser.launch took 122192 usec 
May  6 13:58:15 Nokia-N900-51-1 browser[1494]: GLIB CRITICAL ** default -
browser_engine_is_alive: assertion `self->web' failed
May  6 13:58:15 Nokia-N900-51-1 browser[1494]: Create fork, return :1495,
prev:0
May  6 13:58:16 Nokia-N900-51-1 maemo-launcher[1501]: invoking
'/usr/bin/controlpanel.launch' 
May  6 13:58:16 Nokia-N900-51-1 maemo-launcher[1501]: opening of
/usr/bin/controlpanel.launch took 49438 usec 
May  6 13:58:17 Nokia-N900-51-1 controlpanel[1501]: GLIB WARNING ** default -
An error occured when reading application state
May  6 13:58:17 Nokia-N900-51-1 maemo-launcher[1505]: invoking
'/usr/bin/mediaplayer.launch' 
May  6 13:58:18 Nokia-N900-51-1 maemo-launcher[1505]: opening of
/usr/bin/mediaplayer.launch took 397095 usec 
May  6 13:58:18 Nokia-N900-51-1 browserd[1495]: GLIB DEBUG ConIc -
con_ic_connection_send_event(0x41180, Elisa Internet, GPRS, 0)
May  6 13:58:18 Nokia-N900-51-1 browserd[1495]: GLIB DEBUG default -
connection_cb(0x41180, Elisa Internet, GPRS, 0, 0) count -1
May  6 13:58:18 Nokia-N900-51-1 browserd[1495]: GLIB DEBUG default -
connection_cb(0x41180, Elisa Internet, GPRS, 0, 0) connected
May  6 13:58:19 Nokia-N900-51-1 browserd[1495]: NPP_GetMIMEDescription
:FUNCTION
May  6 13:58:19 Nokia-N900-51-1 browserd[1495]: NPP_GetValue :FUNCTION
May  6 13:58:19 Nokia-N900-51-1 browserd[1495]: NPP_GetValue :FUNCTION
May  6 13:58:20 Nokia-N900-51-1 browserd[1495]: NPP_GetMIMEDescription
:FUNCTION
May  6 13:58:20 Nokia-N900-51-1 browserd[1495]: NPP_GetValue :FUNCTION
May  6 13:58:20 Nokia-N900-51-1 browserd[1495]: NPP_GetValue :FUNCTION
May  6 13:58:28 Nokia-N900-51-1 maemo-launcher[1513]: invoking
'/usr/bin/image-viewer.launch' 
May  6 13:58:29 Nokia-N900-51-1 maemo-launcher[1513]: opening of
/usr/bin/image-viewer.launch took 261108 usec 
May  6 13:58:29 Nokia-N900-51-1 maemo-launcher[1516]: invoking
'/usr/bin/Calendar.launch' 
May  6 13:58:29 Nokia-N900-51-1 maemo-launcher[1516]: opening of
/usr/bin/Calendar.launch took 66681 usec 
May  6 13:58:30 Nokia-N900-51-1 maemo-launcher[1520]: invoking
'/usr/bin/modest.launch' 
May  6 13:58:31 Nokia-N900-51-1 maemo-launcher[1520]: opening of
/usr/bin/modest.launch took 396179 usec 
May  6 13:58:32 Nokia-N900-51-1 [1501]: activesync: AS-COMMON-UTILS Version:
libas-common-utils (0.0.2-27+0m5) unstable; urgency=low
May  6 13:58:32 Nokia-N900-51-1 maemo-launcher[1523]: invoking
'/usr/bin/worldclock.launch' 
May  6 13:58:32 Nokia-N900-51-1 maemo-launcher[1523]: opening of
/usr/bin/worldclock.launch took 38788 usec 
May  6 13:58:33 Nokia-N900-51-1 [1520]: activesync: AS-COMMON-UTILS Version:
libas-common-utils (0.0.2-27+0m5) unstable; urgency=low
May  6 13:58:34 Nokia-N900-51-1 [1520]: GLIB MESSAGE default - Hello!
modest-nokiamessaging-plugin has been loaded
May  6 13:58:34 Nokia-N900-51-1 [1520]: GLIB MESSAGE default -
CIMSDbusServer::InitDbus acquired connection to dbus
May  6 13:58:34 Nokia-N900-51-1 [1520]: GLIB MESSAGE default -
CIMSDbusServer::InitDbus dbus_bus_request_name succeeded
May  6 13:58:34 Nokia-N900-51-1 [1520]: GLIB MESSAGE default -
CIMSDbusServer::InitDbus dbus_bus_add_match matches=: 2
May  6 13:58:34 Nokia-N900-51-1 [1520]: GLIB MESSAGE default -
CIMSDbusServer::InitDbus complete
May  6 13:58:34 Nokia-N900-51-1 [1520]: GLIB MESSAGE default - Loaded!
May  6 13:58:34 Nokia-N900-51-1 systemui-tklock[974]: Method call received
from: :1.39, iface: com.nokia.system_ui.request, method: alarm_close
May  6 13:58:35 Nokia-N900-51-1 [1520]: GLIB MESSAGE default - In
CPluginDbusEndSync::Handle()
May  6 13:58:35 Nokia-N900-51-1 [1520]: GLIB DEBUG ConIc -
con_ic_connection_send_event(0xf8580, Elisa Internet, GPRS, 0)
May  6 13:58:35 Nokia-N900-51-1 [1520]: GLIB MESSAGE default - In
CPluginDbusEndSync::Handle()
May  6 13:58:36 Nokia-N900-51-1 intellisyncd[1526]: GLIB MESSAGE default -
getProcessID(/usr/bin/intellisyncd) :Found. id = 1526 
May  6 13:58:36 Nokia-N900-51-1 intellisyncd[1526]: GLIB MESSAGE default - 1
instances of /usr/bin/intellisyncd running
May  6 13:58:36 Nokia-N900-51-1 intellisyncd[1526]: GLIB MESSAGE default - FW:
05/06 13:58:36.630^IStart IMS
May  6 13:58:37 Nokia-N900-51-1 intellisyncd[1526]: GLIB MESSAGE default - FW:
05/06 13:58:37.429^ILoading user & server defaults
May  6 13:58:37 Nokia-N900-51-1 intellisyncd[1526]: GLIB MESSAGE default - FW:
05/06 13:58:37.431^Isettings - has user & server
May  6 13:58:37 Nokia-N900-51-1 intellisyncd[1526]: GLIB MESSAGE default - FW:
05/06 13:58:37.510^ILoading user & server defaults DONE
May  6 13:58:38 Nokia-N900-51-1 activesync[1541]: AS-COMMON-UTILS Version:
libas-common-utils (0.0.2-27+0m5) unstable; urgency=low
May  6 13:58:44 Nokia-N900-51-1 [1520]: GLIB MESSAGE default -
CPluginDbusServer::ReceiveCommand ODSAbort' ^IKey: 4, Value: 6933  call
RemoteReceiver from DBus Server
May  6 13:58:44 Nokia-N900-51-1 [1520]: GLIB MESSAGE default -
CModestIntellisyncUITranslator::ReceiveCommand 
May  6 13:58:44 Nokia-N900-51-1 [1520]: GLIB MESSAGE default -
CModestIntellisyncUITranslator::ReceiveCommand Abort 
May  6 13:58:44 Nokia-N900-51-1 [1520]: GLIB MESSAGE default - DBUS Function
Handled (success): Started
May  6 13:58:44 Nokia-N900-51-1 [1520]: GLIB MESSAGE default - Handle hibernate
May  6 13:58:44 Nokia-N900-51-1 [1520]: GLIB MESSAGE default - DBUS Function
Handled (success): Hibernating
May  6 13:58:44 Nokia-N900-51-1 [1520]: GLIB MESSAGE default - In
CPluginDbusEndSync::Handle()
May  6 13:58:46 Nokia-N900-51-1 activesync[1541]: AsConfigReader: unable to
read string value of parameter 4 in account ActiveSyncAccount1. Error 5
May  6 13:58:46 Nokia-N900-51-1 dbus[718]: WARNING: match destination=':1.187'
added by :1.187 (pid=1541, uid=29999) who owns services:
May  6 13:58:46 Nokia-N900-51-1 dbus[718]:  :1.187
May  6 13:58:46 Nokia-N900-51-1 activesync[1541]: AsConfigReader: unable to
read string value of parameter 0 in account ActiveSyncAccount1. Error 5
May  6 13:58:46 Nokia-N900-51-1 activesync[1541]: CurlConnectionManager: cannot
get CfgConnExchangeServer
May  6 13:58:46 Nokia-N900-51-1 activesync[1541]: AsConfigReader: unable to
read string value of parameter 5 in account ActiveSyncAccount1. Error 5
May  6 13:58:46 Nokia-N900-51-1 activesync[1541]: CurlConnectionManager: cannot
get CfgCredUsername
May  6 13:58:46 Nokia-N900-51-1 activesync[1541]: AsConfigReader: unable to
read string value of parameter 6 in account ActiveSyncAccount1. Error 5
May  6 13:58:46 Nokia-N900-51-1 activesync[1541]: CurlConnectionManager: cannot
get CfgCredEncryptedPassword
May  6 13:58:46 Nokia-N900-51-1 activesync[1541]: AsConfigReader: unable to
read string value of parameter 5 in account ActiveSyncAccount1. Error 5
May  6 13:58:46 Nokia-N900-51-1 activesync[1541]: SyncScheduler: cannot get
CfgCredUsername
May  6 13:58:46 Nokia-N900-51-1 activesync[1541]: AsConfigReader: unable to
read string value of parameter 0 in account ActiveSyncAccount1. Error 5
May  6 13:58:46 Nokia-N900-51-1 activesync[1541]: CurlConnectionManager: cannot
get CfgConnExchangeServer
May  6 13:58:46 Nokia-N900-51-1 activesync[1541]: SyncScheduler: Cancel all
actions
May  6 13:58:46 Nokia-N900-51-1 activesync[1541]: ASDAEMON Version: 'as-daemon
(0.0.2-28+0m5) unstable; urgency=low' starting
May  6 13:58:46 Nokia-N900-51-1 dbus[920]: WARNING: match destination=':1.114'
added by :1.114 (pid=1541, uid=29999) who owns services:
May  6 13:58:46 Nokia-N900-51-1 dbus[920]:  :1.114
May  6 13:58:46 Nokia-N900-51-1 activesync[1541]: GLIB DEBUG ConIc -
con_ic_connection_send_event(0x18e010, Elisa Internet, GPRS, 0)
May  6 13:58:46 Nokia-N900-51-1 activesync[1541]: ICListener: IAP 'Elisa
Internet' with bearer 'GPRS': connected; count 1
May  6 13:58:46 Nokia-N900-51-1 activesync[1541]:
StoreProxyImpl::getContactVersion not ready to get version, folderId=
May  6 13:58:46 Nokia-N900-51-1 last message repeated 3 times
May  6 13:58:47 Nokia-N900-51-1 [1520]: GLIB DEBUG gtkhtml - When auto-panning
is deactivate, no selection is allowed 
May  6 13:58:50 Nokia-N900-51-1 [1520]: GLIB WARNING ** Gtk - SaveToDraftsMenu:
missing action ActionsSaveToDrafts
May  6 13:59:21 Nokia-N900-51-1 activesync[1541]: CurlConnectionManager: cURL
errorcode = 51
May  6 13:59:21 Nokia-N900-51-1 activesync[1541]: CurlConnectionManager: cURL
errorcode = 6
May  6 13:59:30 Nokia-N900-51-1 activesync[1541]: AS-LIB: Version:
libas-protocol (0.0.2-28+0m5) unstable; urgency=low
May  6 13:59:34 Nokia-N900-51-1 activesync[1541]: AS-LIB: Created factory for
version 12.1
May  6 13:59:49 Nokia-N900-51-1 activesync[1541]: AS-COMMON-UTILS Version:
libas-common-utils (0.0.2-27+0m5) unstable; urgency=low
May  6 13:59:49 Nokia-N900-51-1 activesync[1541]: SyncScheduler: Cancel all
actions
May  6 13:59:50 Nokia-N900-51-1 activesync[1541]: AS-LIB: Version:
libas-protocol (0.0.2-28+0m5) unstable; urgency=low
May  6 13:59:50 Nokia-N900-51-1 activesync[1541]: AS-LIB: Created factory for
version 12.1
May  6 13:59:53 Nokia-N900-51-1 activesync[1541]: AS-LIB: Folder
fc2a7129a8878a428be0c18b454be44f-5b9a3 of type 6 is not created because it is
not supported
May  6 13:59:53 Nokia-N900-51-1 activesync[1541]: AS-LIB: Folder
fc2a7129a8878a428be0c18b454be44f-590dd of type 10 is not created because it is
not supported
May  6 13:59:53 Nokia-N900-51-1 activesync[1541]: AS-LIB: Folder
fc2a7129a8878a428be0c18b454be44f-590dc of type 11 is not created because it is
not supported
May  6 13:59:55 Nokia-N900-51-1 activesync[1541]: AS-LIB: Retrieving sync keys
failed with status 12. Abort retrieving estimations
May  6 13:59:55 Nokia-N900-51-1 activesync[1541]: ActionFullSync: ItemEstimate
failed with status 1012. Abort.
May  6 13:59:56 Nokia-N900-51-1 [1501]: GLIB DEBUG hildon-1 -
ca_context_play_full Success 
May  6 13:59:58 Nokia-N900-51-1 ke_recv[1302]: session_sig_handler:860:
NotificationClosed for 1
May  6 13:59:58 Nokia-N900-51-1 ke_recv[1302]: notification_closed:814: unknown
dialog id: 1
May  6 14:00:48 Nokia-N900-51-1 iphbd: client with socket 11 disappeared
-clip-

At least I noticed cURL errorcode 51 (CURLE_PEER_FAILED_VERIFICATION), don't
know if this is really the problem. I also tried after installing the
certificate used in the sync server (GlobalSign Root CA but different
fingerprint than on the one that N900 already has).
Comment 1 Andre Klapper maemo.org 2010-05-11 16:45:07 UTC
Hi,

can you please provide *exact* steps to reproduce, step by step, click by
click?
For example your steps do not even mention a certificate while it's suddnely
mentioned later on in the "other comments" section.
This makes it very hard to reproduce.
Comment 2 Tuomas (reporter) 2010-05-12 12:07:24 UTC
More detailed steps leading to problem:
1. Insert company certificate by clicking the certificate and selecting server,
wlan and email (the certificate can be seen in certificate list "varmenteiden
hallinta" in finnish). At first setup attempt I didn't do this step.
2. Install sysklogd and start the service, like in
http://talk.maemo.org/showthread.php?t=51584
3. Go to settings -> Mail for Exchange
4. Tap next on the welcome screen
5. Insert email, username, password and domain and tap next
6. Insert server name (like mail.mailsync.com), use port 443 and secure
connection, tap next
7. Leave synchronization content preferences as default, tap next
8. Tap next again
9. First synchronization screen opens, initializing synchronization starts
10. After a short while, error message "Errorn in communication with Exchange
server" appears
11. Messages appear in syslog as reported in the bug report.


Hope this brings more details to the bug. If needed, I can send more details
about the server itself (won't post those info on a public site).
Comment 3 Tuomas (reporter) 2010-05-23 18:24:53 UTC

*** This bug has been marked as a duplicate of bug 6582 ***