Bug 1013 - flasher not available for N8x0 and Linux/PowerPC
: flasher not available for N8x0 and Linux/PowerPC
Status: RESOLVED DUPLICATE of bug 1100
Product: Flasher
Linux
: 5.0-beta
: PPC Linux
: Low enhancement with 3 votes (vote)
: ---
Assigned To: Quim Gil
: flasher-linux-bugs
:
:
:
: 270 603
  Show dependency tree
 
Reported: 2007-02-03 11:08 UTC by David Woodhouse
Modified: 2009-08-27 10:04 UTC (History)
5 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description David Woodhouse (reporter) 2007-02-03 11:08:21 UTC
Please build the flasher tool for Linux/PPC
Comment 1 digVer 2007-12-14 18:38:48 UTC
At this point It looks like the only way to flash the N800 (or N810?) is to
have an Intel based computer.  Why the neglect of anything else?  I've easily
compiled 0xFFFF on my powerbook.  What is needed to get flasher-3.0 built for a
powerpc?
Comment 2 David Woodhouse (reporter) 2007-12-14 18:55:20 UTC
I've successfully used 0xFFFF on Fedora/PowerPC with N800.
Comment 3 Craig Miller 2007-12-17 23:03:05 UTC
Please see my comment #9 in Bug 603.

If 0xFFFF works with flashing the n800, is there a how to, or addtional
information (more than just the home page).

It would be _nice_ if Nokia would recompile their Flasher for LinuxPPC. The
current flasher states that the image is broken (yet it flashes fine on a i386
machine).
Comment 4 Andre Klapper maemo.org 2008-06-23 14:45:52 UTC
http://tablets-dev.nokia.com/d3.php
flasher 3 is available for PPC for the 770, but not for the N800.
Comment 5 Andre Klapper maemo.org 2008-06-23 15:37:31 UTC
also see bug 1100 - very similar.
Comment 6 Quim Gil nokia 2008-10-31 22:55:52 UTC
Another possibility is to open the Linux flasher source code and development,
allowing third parties to contribute and maintain the versions that Nokia is
not providing officially.
Comment 7 Andre Klapper maemo.org 2008-11-26 17:47:19 UTC
In fact it's not a bug but an enhancement request to support more platforms. ->
Changing severity.
Comment 8 Frantisek Dufka maemo.org 2008-11-27 16:11:15 UTC
(In reply to comment #6)
> Another possibility is to open the Linux flasher source code and development,
> allowing third parties to contribute and maintain the versions that Nokia is
> not providing officially.
> 
Yes definitely. Otherwise we could create several other bugs with same "flasher
not available for X" template like this bug or bug #1013. For me X=Microsoft
Windows. The update wizard for Windows doesn't count as real flasher. You
cannot set r&d mode or flash kernel with it.

Also http://www.nopcode.org/0xFFFF/ would definitely profit from opening
flasher code or at least from opening FIASCO image specification. Current code
is based on reverse engineering and some parts are based on guesswork.

Having flasher code (including flash image creation) open is also prerequisite
of http://wiki.maemo.org/Objective:Maemo_variants so we can create modified
firmware images.
Comment 9 Andre Klapper maemo.org 2009-06-30 18:02:49 UTC
According to http://lists.maemo.org/pipermail/maemo-users/2009-June/013886.html
Flasher 3.5 (for Diablo and Fremantle) does not support this yet -> bumping
version.
Comment 10 Jarmo Tikka nokia 2009-08-27 09:57:56 UTC
Closing this as dublicate and continuing discussion in Bug 1100 (which will be
closed when final PPC version of flasher-3.5 will be released.

*** This bug has been marked as a duplicate of bug 110 ***
Comment 11 Andre Klapper maemo.org 2009-08-27 10:04:57 UTC
(correcting bug number)

*** This bug has been marked as a duplicate of bug 1100 ***