Bug 10108 - hyperlinks in email program terminates on &
: hyperlinks in email program terminates on &
Status: RESOLVED FIXED
Product: Email
General
: 5.0/(3.2010.02-8)
: N900 Maemo
: Unspecified normal (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-05-05 17:25 UTC by Robert Piasek
Modified: 2010-05-05 19:29 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Robert Piasek (reporter) 2010-05-05 17:25:56 UTC
When you receive an email with & in it, hyperlink terminates on & symbol

example:
www.example.com/?dest=assd&ada=2

expected result:
link properly underscored and opened in browser once clicked

actual result:
only www.example.com/?dest=assd is underscored and opened in the browser.
remaining part &ada=2 is displayed, but not underscored and ignored once
clicked

SOFTWARE VERSION:
N900 running 3.2010.02-8

REPRODUCIBILITY:
always


User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.3)
Gecko/20100408 Gentoo Firefox/3.6.3
Comment 1 Andre Klapper maemo.org 2010-05-05 19:29:57 UTC
Hi Robert, thanks for reporting this!

I tried this with an internal newer build by forwarding the bugmail that was
created for this entry to my GMail account on the N900, and the complete URL
was underlined and the complete URL opened in the browser.

Looks like this will be fixed by the next public update.