Bug 10089 - (int-174525) Cannot create Flickr sharing account: "Internal error. Application 'Settings' closed."
(int-174525)
: Cannot create Flickr sharing account: "Internal error. Application 'Settings'...
Status: NEW
Product: Sharing
General
: 5.0:(10.2010.19-1)
: N900 Maemo
: Unspecified major with 2 votes (vote)
: ---
Assigned To: unassigned
: sharing-general-bugs
:
: crash
:
:
  Show dependency tree
 
Reported: 2010-05-03 16:31 UTC by Julio Biason
Modified: 2010-07-10 12:16 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Julio Biason (reporter) 2010-05-03 16:31:06 UTC
SOFTWARE VERSION:
3.2010.02-8.002

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Open Settings
2. Go to "Sharing accounts"
3. Click new
4. Select "Flickr"
5. Chose "Use existing account"

EXPECTED OUTCOME:
Not sure, probably some dialog asking for username/password.

ACTUAL OUTCOME:
Got a message "Internal error. Application 'Settings' closed."

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
Some stuff from the maemo repositories, not any other sharing accounts.

OTHER COMMENTS:
I tried once using 3G instead of WiFi (as mentioned in Talk.Maemo.Org). It
seems it should open a browser pointing to Yahoo! pages to allow the
application to use my Flickr status, but the browser never pops up. I also have
Firefox (from Ovi Store) installed, which could explain this (but Firefox is
*not8 my default web browser.)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.3)
Gecko/20100401 Firefox/3.6.3
Comment 1 Julio Biason (reporter) 2010-05-03 16:32:33 UTC
(Oh, I tried to reopen #8058, but Bugzilla said I didn't had the proper
permissions for it.)
Comment 2 Andre Klapper maemo.org 2010-05-03 17:01:13 UTC
Thanks for reporting this!

(In reply to comment #1)
> I tried to reopen #8058

Bug 8058 is not about a crash and hence looks different...

Can you please install Crash Reporter from the SDK Tools repository in order to
send coredumps directly to Nokia?
See http://wiki.maemo.org/Extras-testing#Tools_for_testers for a how-to.
If you are offered to add a comment for sending the coredump file, please
mention this bug number (like "see bugs.maemo.org bug number xxxx").
Also, a filename will be displayed after uploading the coredump. Please add the
name of that file here in the bug report.


Also, any chance to try whether this also happens without Firefox?
Comment 3 Julio Biason (reporter) 2010-05-03 18:21:04 UTC
A quick test after uninstalling Firefox still makes it crash. I think we can
rule that out ;)

I'm going to install Crash Reporter in a sec and post the results.
Comment 4 Julio Biason (reporter) 2010-05-03 18:28:31 UTC
Unable to install 'Crash Reporter'.
Some application packages required for
the installation are missing.

Details ->

Application packages missing
  libhildon1 (>= 2.2.5)
  libhildonfm2 (>= 1:2.28.12+0m5)
  libosso1 (>= 2.29)
  libpixman-1-0 (>= 0.15.16)
Comment 5 Julio Biason (reporter) 2010-05-03 19:32:55 UTC
Just tried to call "controlpanel" from a terminal. Got a bunch of error
messages (not sure if they are helpful in locating the problem):

sharing-accountstore.c 516 sharing_account_store_add_account Last added id
exists: 11
process 6330: arguments to dbus_bus_request_name() were incorrect, asserting
"_dbus_check_is_valid_bus_name (name)" failed in file dbus-bus.c line 1070
This is normally a bug in some applicatino using the D-Bus library.
process 6330: arguments to dbus_bus_request_name() were incorrect, asserting
"_dbus_check_is_valid_bus_name (name)" failed in file dbus-bus.c line 1070
This is normally a bug in some applicatino using the D-Bus library.
**
ERROR:sharing-http.c:665:sharing_http_parse_response_buffer: assertion failed:
(retcode != 0)
Aborted
Comment 6 bigbrovar 2010-05-04 08:42:54 UTC
I am also affected by this bug. Searching for a solution brought me to this bug
report. I would like to add that it seem to be a bug with pixelpipe pluggin for
the n900 because i get the same error with twitter, flickr and youtube plugin
for pixelpipes
Comment 7 Julio Biason (reporter) 2010-05-10 16:44:04 UTC
Weird thing: This weekend I installed the Twitpic sharing package and, out of
nowhere, the Flickr sharing is working with wireless networks (including
registering and posting.)

My guess is that there is a missing dependency which is added to the Twitpic
package, making both work without a problem.
Comment 8 Andre Klapper maemo.org 2010-06-07 16:10:16 UTC
Is this still an issue in 10.2010.19-1 for you?
And can anybody confirm comment 7?
Comment 9 Julio Biason (reporter) 2010-06-14 16:19:46 UTC
Sorry about the long delay.

Well, the problem is *back* after 1.2. Not only that, but sharing-manager is
crashing every time I try to send something to my already set up Flickr
account. Twitpic is now impossible to set up since it crashes every time.

Uploaded controlpanel-F3FF-6-3827.rcore.lzo using the crash reporter.
Comment 10 Julio Biason (reporter) 2010-06-14 16:22:19 UTC
Just to be sure, I removed my Flickr accuont I trined to create it again. Same
crash as initial report.

Uploaded controlpanel-F3FF-6-3967.rcore.lzo as result.
Comment 11 Andre Klapper maemo.org 2010-06-29 16:33:57 UTC
(In reply to comment #0)
> REPRODUCIBILITY:
> always

Does this really happen *always* in 10.2010.19-1?
If so, how often did you try?
Comment 12 Julio Biason (reporter) 2010-06-29 22:30:55 UTC
(In reply to comment #11)
> Does this really happen *always* in 10.2010.19-1?
> If so, how often did you try?

Tried a couple of times with the previous version, at least twice with
10.2010-19.

Tried again just now, just to get the crash again. Sending
controlpanel-F3FF-6-17463.rcore.lzo as result.

If you want, I can send you a core every day.
Comment 13 mg 2010-07-10 12:16:49 UTC
Same here. Can`t use any sozial sharing currently ;(
See: http://talk.maemo.org/showthread.php?p=746959#post746959