Bug 10061 - After uninstall the Chinese language packages, the system function menu will become function code name instead of Menu name in English.
: After uninstall the Chinese language packages, the system function menu will ...
Status: RESOLVED DUPLICATE of bug 7256
Product: Desktop platform
Internationalization
: 5.0/(3.2010.02-8)
: N900 Maemo
: Unspecified major (vote)
: ---
Assigned To: Mikko Nurmi
: i18n-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-04-28 18:15 UTC by Hsiao-Chung Chen
Modified: 2010-05-09 04:31 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Hsiao-Chung Chen (reporter) 2010-04-28 18:15:07 UTC
SOFTWARE VERSION: 3.2010.02-8
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Install Traditional Chinese locale file from App. Manager, actual location
is here:
http://repository.maemo.org/extras-devel/pool/fremantle/free/n/n900-locales-extras/n900-locales-extras-zhtw_20100414-r1349_all.deb
2. go to "setup" "locale", switch the locale to Chinese (Taiwan Region)
3. Reboot then the UI will turn to Trad. Chinese.
4. Go to app. manager to uninstall the Chinese locale file.
5. Immediately after the removal, whole UI menu become funcation call name and
become extremely hard to reconize.
6. You can solve this problem by trying to reset the locale to English then
reboot the device. 

EXPECTED OUTCOME:
If can't find the MO file, the system should by default display English.

ACTUAL OUTCOME:
The system will display function code name and is difficult to read.

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)
Always
EXTRA SOFTWARE INSTALLED:
n900-locales-extras-zhtw
OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-TW; rv:1.9.2.3)
Gecko/20100401 Firefox/3.6.3 GTB6 (.NET CLR 3.5.30729)
Comment 1 Andre Klapper maemo.org 2010-04-28 21:11:29 UTC
Hi Chen,
this is not really a bug. Let me try to explain:
All user visible and translatable strings by default are cryptic technical IDs
and receive a translation to a human language. Once you set a language the
translated strings for this language will be used. Hence if you remove the
files/package that includes the translated strings for the language that you
currently use, the system will use the untranslated strings.
Comment 2 Andre Klapper maemo.org 2010-04-30 15:01:07 UTC
Actually this problem would be fixed by fixing bug 7256, hence marking as a
duplicate.
Comment 3 Andre Klapper maemo.org 2010-04-30 15:01:18 UTC

*** This bug has been marked as a duplicate of bug 7256 ***
Comment 4 Hsiao-Chung Chen (reporter) 2010-05-09 04:31:15 UTC
Hi, Thanks for the reply.

Considering the behavior, it would be nicer if can't find the specific
language, a "default" one will be used instead of untranslated stream. That
will be focusing on overall user experience.

I can agree with you this may not consider to be a bug, but it is still indeed
an annoying "design fraud" to me.

Thanks a lot for your explaination.


(In reply to comment #1)
> Hi Chen,
> this is not really a bug. Let me try to explain:
> All user visible and translatable strings by default are cryptic technical IDs
> and receive a translation to a human language. Once you set a language the
> translated strings for this language will be used. Hence if you remove the
> files/package that includes the translated strings for the language that you
> currently use, the system will use the untranslated strings.
>