Bug 100 - Left handed mode
: Left handed mode
Status: RESOLVED WONTFIX
Product: UI Specification
General
: 5.0/(1.2009.42-11)
: All All
: Unspecified enhancement with 7 votes (vote)
: ---
Assigned To: Quim Gil
: misdirected-nokia-bugs
:
: enhancement-it2005
:
:
  Show dependency tree
 
Reported: 2005-10-04 01:50 UTC by no name
Modified: 2009-11-18 18:28 UTC (History)
5 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description no name (reporter) 2005-10-04 01:50:34 UTC
The device is designed for right handed people such that the user can
simultaneously use the navigation buttons with their left hand while holding the
device and use the stylus with their right hand.

From photographs of the device it appears that similar functionality can be
provided for left handed users by rotating what is displayed on the screen 180
degrees and using the device 'upside-down'. That is the user holds the device in
his/her free hand (right hand for left handed person) with the stylus in their
writing hand (left for left handed person).

Although the placement of the navigation buttons means that the left-handed
person will not be using the device exactly as if it were designed for a
left-handed person (instead of a right handed person) it seems to be an
excellent compromise.

Please move this bug if it is not in the appropriate section.
Comment 1 no name (reporter) 2005-10-04 01:51:40 UTC
*** Bug 99 has been marked as a duplicate of this bug. ***
Comment 2 Ferenc Szekely maemo.org 2005-10-06 00:22:28 UTC
moving
Comment 3 Ferenc Szekely maemo.org 2005-10-06 00:24:00 UTC
Carlos, perhaps you could comment on this.
Comment 4 Eero Tamminen nokia 2005-10-06 14:09:52 UTC
Kdrive X server on which Maemo X server is based, provides the RandR extension
for rotating the screen. I think this is not supported by the Maemo Xomap X
server, but it would easy to enable.  Then rotation the screen could be achieved
with the standard 'xrandr' utility.

This will have a few drawbacks though, as all display updates go then through so
called "shadow framebuffer":
- More memory is spent for this
- It slows down screen updates (significantly I think)

Only performance-wise viable way to provide this feature would be to have HW
support for display rotation.  I don't think N770 has HW support for that?
Comment 5 Jorma Virkkunen nokia 2005-10-26 13:50:15 UTC
Moving to Nokia 770 product.
Comment 6 Jorma Virkkunen nokia 2005-11-01 12:23:48 UTC
Reassigning.
Comment 7 alessandro pasotti 2006-03-28 10:02:26 UTC
I would vote for this bug, of course I'm one of the 1/5 left-handed people and
I
would add a few considerations:

1 - screen rotation is a must, and if it's slower it could be disabled for
video
playback (when watching videos you normally don't use the keyboard)
2 - vertical scrollbar is also not useable since left-handed cover both display
and scrollbar with my hand while scrolling
Comment 8 Maemo QA (deprecated) 2006-04-11 14:46:04 UTC
Claiming ownership. Bug has been reported to upstream maintainer.
Comment 9 Maemo QA (deprecated) 2006-05-23 10:37:03 UTC
Feature request has been forwarded to upstream maintainer.
Comment 10 Quim Gil nokia 2007-04-27 09:55:10 UTC
Hi, picking this feature since it's the oldest we have still open.

- Rotating hardware is not a solid option, really. From a maemo perspective we
can't predict the hardware features and setup of the tablets in the future, and
what could be thought for the 770 might be impossible in future products.

- Mirroring UI elements to have them in the opposite side of the screen is
doable, and the community doesn't even need us to develop a theme for
left-handed users. 

We don't have currently any plans to develop such theme ourselves. Instead, we
are working on UI improvements that make the difference between left&right hand
less relevant, but it might take a while until these improvements are completed
and released. If you are looking for a specific solution for the 770 a theme is
the fastest way to go.

So it looks like this feature request is a wontfix from our side, even if the
community has tools to fix it and we are working on nid term plans that will
solve most of this issue.

I'm CCing Roope, core UI designer and also left-handed. As you may guess he has
thought a lot about this.
Comment 11 Roope Rainisto nokia 2007-04-27 10:20:38 UTC
Hi. Yes. I also wrote about that briefly on the UI team blog (at
http://maemointeraction.wordpress.com/2007/04/13/hello-and-good-morning/#comments
- not about screen rotation, but placing scroll bars on the left side...) 

Screen rotation as such wouldn't clear the problem of the left hand obscuring
the screen while scrolling. As I commented on the blog, I don't think that the
fix is as trivial as moving the scroll bars on the left side - the placement of
the scroll bars has already affected the design in other terms, and reversing
their position without changing the overall design also wouldn't be really optimal. 

As Gil also comments, any design that we produce shouldn't be tied to the
assumption that the hardware would share the same characteristics in the future.
In a platform mode the UI design should work with many differing form factors.
And yes, there are ways to make the design more ambidextrous, and we will be
also looking into that in the future.
Comment 12 Frantisek Dufka maemo.org 2007-04-27 11:26:15 UTC
Rotating display is not proper solution but good workaround for both devices
currently available. With current devices you simply can't use buttons and pen
at the same time if you are left-handed. So it is not only about theme and
scrollbars but also about hardware buttons. Proposed theme solution does not
solve problem with hw buttons at all.

I take the talk about future hardware as a hint that perhaps N800 was really the
last device with buttons suited only for right handed people. Please, please add
hardware buttons also to right side and make the device symmetric. This will
help both lefties and gamers. Also consider control panel applet that could
switch button actions so leftie can at least reconfigure button sides.
Comment 13 Quim Gil nokia 2007-05-05 10:39:29 UTC
Let's conclude that we don't have plans to support officially a configuration
specially designed for left-handed users. The window rotation feature belongs
somewhere else and there have been discussions about it, not related wit our
issue here. If it happens will be not just for this reason, and it is out of my
scope now to tell if it's going to happen and when.

About the use of hardware buttons not being optimal even if a theme for
left-handed users is achieved by the community. Well, I agree. But I can't
forget that myself (right-handed user) barely use those buttons and I consider
mysef a happy tablet user.  :)  So it is not a critical issue like you can't
perform a decent use. 

Only with stilus or thumbs you are done for most cases. Dragging using the
scrollbar can be an issue since your left hand is in the middle of the screen,
but then again you can scroll by dragging any point of the screen (which users
like me do as well all the time since anyway is most times easier than
controlling scroll from the scrollbar.

About future plans, all I can say is that Roope and others are active in this
issue and push the left-handed agenda whenever there is an opportunity. Having
hand-agnostic interfaces is probably the most optimal solution anyway, but
let's see what <em>the future</em> brings.  :)

For all these reasons I will close this ancient feature request as wontfix,
although hopefully the issue it self will be fixed in future releases.
Comment 14 Frantisek Dufka maemo.org 2007-05-05 14:41:44 UTC
(In reply to comment #13)

> About the use of hardware buttons not being optimal even if a theme for
> left-handed users is achieved by the community. Well, I agree. But I can't
> forget that myself (right-handed user) barely use those buttons and I consider
> mysef a happy tablet user.  :)  So it is not a critical issue like you can't
> perform a decent use. 

Well that depends on usage. Even on desktop some people prefer mouse and some
use keyboard shortcuts. If we are talking about personal and subjective issues
here I'd like to point out that I am left-handed user and use HW keys a lot and
keys on left side do not make me happy at all :-)

One issue why people (like you) use buttons less is that currently support for
keys is not very good in many default applications so this is a bit chicken and
egg problem - browser goes to next link on page instead of page down (luckily
it can be customized via editing input.ini), pdf viewer cannot go to next page
while zoomed etc. Both already reported in bugzilla, see e.g #244 #665 #1138
#1063 .

I hope that this underestimating of hw buttons (seen also more times in mailing
list in mails from @nokia.com) does not mean that my suggestion to make device
symmetric will be solved by removing keys completely :-)

Anyway, let's hope it will improve in future.
Comment 15 R E Broadley 2007-07-24 15:53:07 UTC
I am right handed, but I would much rather use my N800 upside-down. I find it
so much more ergonomic with the bulge at the base rather than the top.

It would also be quite nice to use it in a portrait position, but I appreciate
that this would require much more work to redesign the GUI layout.
Comment 16 Andrew Flegg maemo.org 2008-04-20 12:08:02 UTC
*** Bug 3106 has been marked as a duplicate of this bug. ***
Comment 17 Ryan Abel maemo.org 2008-05-31 06:42:30 UTC
*** Bug 3206 has been marked as a duplicate of this bug. ***