Bug 9926

Summary: No more search results loads new page
Product: [Maemo Official Applications] Browser Reporter: Markus <markuspublic>
Component: User interfaceAssignee: unassigned <nobody>
Status: VERIFIED FIXED QA Contact: browser-bugs
Severity: normal    
Priority: Unspecified CC: andre_klapper, john.maemo
Version: 5.0/(3.2010.02-8)   
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: N900   
OS: Maemo   

Description Markus (reporter) 2010-04-14 15:57:18 UTC
SOFTWARE VERSION:
3.2010.02-8

EXACT STEPS LEADING TO PROBLEM: 
1. Open the internet browser
2. Go to http://en.wikipedia.org/wiki/Maemo and wait for the page to complete
loading
3. Press CTRL-F to open the search window
4. Type "microb browser" (without quotation marks)
5. Press enter - wait for 1st hit to be highlighted
6. Press enter - wait for 2nd hit to be highlighted
7. Press enter to search for a 3rd hit. (There is no 3rd hit.)

EXPECTED OUTCOME:
A message "search completed" is shown and the 2nd hit is still highlighted.

ACTUAL OUTCOME:
A message "search completed" is shown and the Wikipedia front page
(en.wikipedia.org) is loaded.

REPRODUCIBILITY:
Always

EXTRA SOFTWARE INSTALLED:
Extensions:
- Maemo GeoLocation 1.1.3
- Single sign on for Ovi by Nokia 1.0.4-3
- wmlbrowser 0.7.20"
Plugins:
- Atlas Plugin 2.0.35.6+0m5 for Mozilla
- Default plug-in [sic]
- Mediaplayer media plug-in
- Nokia MessageBus Plugin
- Shockwave Flash 9.0 r246

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.9)
Gecko/20100315 Firefox/3.5.9 (.NET CLR 3.5.30729)
Comment 1 Andre Klapper maemo.org 2010-04-14 17:02:03 UTC
Hi Markus, thanks for reporting this!

I tried this in a newer internal non-public release both in fullscreen mode and
in normal mode (with the location bar still displayed) in both cases I could
not reproduce it.
A test/confirmation by a second user is highly welcome.
Comment 2 John Veness 2010-04-19 22:23:36 UTC
Confirming for 5.0/(3.2010.02-8), exactly as reported.

Additional software I have installed: 3G/2G/Dual Mode Selection Applet, Conboy,
gPodder, grsync, headphoned, leafpad, OpenSSH client and server, Panucci,
rootsh, SeriesFinale.
Comment 3 Andre Klapper maemo.org 2010-04-20 15:55:12 UTC
I just flashed a device back to version 3.2010.02-8 and I can also confirm
this.
Looks like this issue has been fixed in the meantime and the fix will be
included in the next public update (PR1.2).

To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 4 Markus (reporter) 2010-05-30 22:03:40 UTC
cannot reproduce the problem after updating to PR1.2. Setting bug as verified.
Thanks.