Bug 991

Summary: Long videos halt after 13-20 minutes
Product: [Maemo Official Applications] Media player Reporter: Daniel Gentleman <thoughtfix>
Component: GeneralAssignee: Maemo QA (deprecated) <qa>
Status: CLOSED FIXED QA Contact: media-player-bugs
Severity: major    
Priority: Medium CC: andrew, bmidgley, bugzilla770, haavi, samtygier, tuukka.tolvanen
Version: unspecified   
Target Milestone: ---   
Hardware: N800   
OS: Maemo   
URL: http://www.internettablettalk.com/forums/showthread.php?p=32156

Description Daniel Gentleman (reporter) 2007-01-29 07:53:27 UTC
Videos playing in the N800 media player halt anywhere between 13 to 20 minutes
consistently but unpredictable as to when in the file it happens. Identical
files played back without halting on the Nokia 770 - only on the N800 do they halt.

Videos were created with Media Converter 1.21
Tested output:
High Quality (352x208) 3/4 FPS
Optimize for 770 screen
Enhance Color
Audio Gain

Other settings were tested with similar results.
Comment 1 Andrew Flegg maemo.org 2007-01-29 11:14:25 UTC
The same happens with other converted videos not done using "Media Converter"
(but still mencoder under the covers).

More details:

Audio: 128kbps MP3 44.1kHz
Video: 400kbps

`top' shows CPU still largely idle whilst the video is frozen. Symptoms include
the video slowing down to a near halt, halting and then toggling fullscreen
off/on restarts the video in 50% of cases. Other times the video needs to be
stopped and restarted, or the entire device rebooted.

Raising priority to "major" as it's disruptive enough to make watching TV
recordings on the N800 impractical - which is pitched as a major use case.
Comment 2 Levi Bard 2007-02-10 06:35:00 UTC
For us, it happens as early as 60 seconds into the file.  We're using
full-length movies transcoded specifically for the 770: 
RIFF (little-endian) data, AVI, 320 x 192, ~15 fps, video: DivX 4, audio: MPEG-1
Layer 3 (mono, 24000 Hz)
200kbps video
Comment 3 Paul Brook 2007-02-14 00:45:01 UTC
I also see this problem. Seeking within the video (using the scroller or arrow
buttons to skip forwards/backwards within a track) freezes the player ~50% of
the time. ie. clicking on the skip forwards button half a dozen times is pretty
much guaranteed to trigger the bug.

I also get similar failures when seeking in mplayer. When the error occurs I get:

GLIB WARINGING *** Entered wait_buffer in error

This appears to be coming from the dsp gstreamer pluging.
I can't investigate further because the gst-plugins-dsp is not avaiable.
Comment 4 Paul Brook 2007-02-14 00:47:53 UTC
I mean up to date source is not avaiable for the gst-plugins-dsp plugin, and
the
old source packages are useless because they build-depend on packages/header
files that are not available.
Comment 5 Jonny Rodin 2007-03-09 15:29:31 UTC
(In reply to comment #0)
> Videos playing in the N800 media player halt anywhere between 13 to 20 minutes
> consistently but unpredictable as to when in the file it happens. I

I've found it happens anywhere between a few seconds and 10 minutes from the
start of play.
Comment 6 Laurent GUERBY 2007-04-13 01:09:36 UTC
Since I've played in loop a 1h30 video for more than 4 hours total I think this
is fixed with IT2007.10.

Could someone else confirm?
Comment 7 Levi Bard 2007-04-13 01:19:09 UTC
(In reply to comment #6)
> Since I've played in loop a 1h30 video for more than 4 hours total I think this
> is fixed with IT2007.10.
> 
> Could someone else confirm?

Still happens to me with the few videos I tried before switching back to mplayer.
Comment 8 Johan Lindqvist 2007-04-13 08:49:25 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > Since I've played in loop a 1h30 video for more than 4 hours total I think 
this
> > is fixed with IT2007.10.
> > 
> > Could someone else confirm?
> Still happens to me with the few videos I tried before switching back to 
mplayer.
For me movies converted with Media Converter 1.31 now works after the OS update
Comment 9 Hanno Zulla 2007-04-20 13:09:41 UTC
I watch 2 hour movies on my N800 and it works fine with the current OS release.
Comment 10 Neil MacLeod maemo.org 2007-07-08 05:30:41 UTC
I'm guessing this should be marked as RESOLVED/FIXED and CLOSED, unless it's a
regression in 4.2007.26-8?
Comment 11 Jake Kunnari 2007-07-09 10:34:58 UTC
(In reply to comment #9)
> I watch 2 hour movies on my N800 and it works fine with the current OS release.

Hi Hanno, could you try to watch same video with latest IT OS 2007. Thank you.
Comment 12 Daniel Gentleman (reporter) 2007-07-09 20:25:07 UTC
I have been unable to duplicate this on the latest firmware.
I vote for a "close" on this one.
Comment 13 Jake Kunnari 2007-07-10 11:31:53 UTC
Status changed to Fixed
Comment 14 Jake Kunnari 2007-07-10 11:33:25 UTC
And now to Closed. If problem still occurs please reopen bug with details.