Bug 9688 (int-162784)

Summary: GL textures may get corrupted on upload
Product: [Maemo Official Platform] Core Reporter: Martin Storsjö <martin>
Component: generalAssignee: unassigned <nobody>
Status: VERIFIED FIXED QA Contact: core-general-bugs
Severity: normal    
Priority: Unspecified CC: andre_klapper, martin
Version: 5.0/(3.2010.02-8)   
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: N900   
OS: Maemo   

Description Martin Storsjö (reporter) 2010-03-24 12:40:38 UTC
When uploading GL textures from within Qt, the textures may get small
corruptions (small rectangular blocks containing garbage). This was reported to
Qt at http://bugreports.qt.nokia.com/browse/QTBUG-9301, where it was determined
to probably be a GL driver bug.

The N900 is running Maemo 5, PR 1.1.1, 3.2010.02-8.

To trigger the problems, compile either of the sample programs attached to the
Qt bug report, also available at these URLs:
http://albin.abo.fi/~mstorsjo/qt-gltex-bug.tar.gz
http://albin.abo.fi/~mstorsjo/qt-graphicsview-bug2.tar.gz

and run them. The former uploads a new texture (with a uniform color) and
paints it to the screen repeatedly. Every now and then (quite often), the
texture contains miscolored rectangular blocks.

The latter implicitly uploads texture from within Qt UI classes, leading to
similar corruption in texts - not all the time, but every now and then.

REPRODUCIBILITY:
The qt-gltex-bug example shows errors almost all the time (can be noticed
within a second). The qt-graphicsview-bug2 example shows corrupted text a few
times within 10 seconds.

EXTRA SOFTWARE INSTALLED:
These tests have been done with Qt 4.6.2 installed from extras-devel, but both
examples also show similar issues when compiled with Qt 4.5.3 that belongs to
the platform.
Comment 1 Martin Storsjö (reporter) 2010-03-27 21:46:48 UTC
The same issue is also reproduced with a simple example not using Qt, only
straight Xlib:

http://albin.abo.fi/~mstorsjo/simplegl-tex.cpp

The issue is only visible as long as the window isn't fullscreen, so perhaps
the compositing is interfering in some way?
Comment 2 Andre Klapper maemo.org 2010-04-01 17:32:41 UTC
Internal comment:
"The bug is reproducible on old RX-51_2009SE_2.2009.49-3 but I cannot reproduce
it on recent internal images. Based on that I'm resolving the bug as already
FIXED."

Will be included in the next public update.
Comment 3 Martin Storsjö (reporter) 2010-05-27 16:17:52 UTC
Verified that this seems to be fixed in PR 1.2, 10.2010.19-1.