Bug 9270 (int-158504)

Summary: Device unlockable if it get locked when being in portrait mode
Product: [Maemo Official Platform] System software Reporter: David Sommerseth <dazo>
Component: Device lockAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: device-lock-bugs
Severity: major    
Priority: Unspecified CC: andre_klapper, maemo
Version: 5.0/(3.2010.02-8)   
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: N900   
OS: Maemo   
Bug Depends on: 8454    
Bug Blocks:    

Description David Sommerseth (reporter) 2010-02-25 15:34:36 UTC
SOFTWARE VERSION:  Maemo5 3.2010.02-8

EXACT STEPS LEADING TO PROBLEM: 
Had a phone call, the phone app was in portrait mode when the N900 was "put
aside" on the desk.  After 1 hour, the automatic device lock kicked in.  When
trying to unlock device it was impossible, because a disabled "Done" button was
covering the "9" digit on the keypad which I needed for my unlock code.

To reproduce:
1. Set the automatic device lock to 5 minutes
2. Start the phone app and do a phone call.
3. Hang up and lay the phone down without flipping back to landscape mode.
4. Wait for at least 5 minutes
5. Access the phone again and (hopefully) it "forgot" to switch to landscape
mode.


EXPECTED OUTCOME:
All keypad digits should be available by always switching to landscape mode

ACTUAL OUTCOME:
Device unlock happens in portrait mode and a few keypad digits are covered and
unavailable by the "Done" button

REPRODUCIBILITY:
Seldom :(
Comment 1 Andre Klapper maemo.org 2010-02-25 17:41:39 UTC
Hi David, thanks for reporting this!
Comment 2 Lucas Maneos 2010-03-17 01:05:16 UTC
Hopefully the device won't get stuck in portrait mode at the end of a call
anymore, re-testing once PR1.2 has been released welcome.
Comment 3 totalworlddomination 2010-04-09 00:35:32 UTC
Not sure if it's an unrelated bug or if it relates to this and maybe a mix with
#8910, but ...

It seems that having the device in the browser in full screen and letting the
device time out itself into the secure locks mode results some times (always?
Not sure!) in the keypad not being visible at all except for the title... no
numbers, no "Done" button, nothing!

But you can still try to guess where the buttons are and get a success /
failure at entering your code.
Comment 4 Andre Klapper maemo.org 2010-05-02 22:28:01 UTC
According to internal testing and comments this seems to be FIXED in later
internal builds.
Comment 5 Andre Klapper maemo.org 2010-05-02 22:28:51 UTC
(Note to myself: Tested on 2010.16-8)
Comment 6 Andre Klapper maemo.org 2010-05-19 17:21:52 UTC
It's a bit unclear, but this should most probably be FIXED in PR1.2 (the next
public update).
Retesting once it is available for public highly welcome.
Comment 7 Andre Klapper maemo.org 2010-05-28 21:32:30 UTC
This week Nokia released the Maemo5 update version 10.2010.19-1 for public
(also called "PR1.2").
If you have some time we kindly ask you to test again if the problem reported
here still happens in this new version - just leave a comment (and feel free to
update the "Version" field to the new version if it's still a problem).