Bug 8920

Summary: MicroB loses first keystroke
Product: [Maemo Official Applications] Browser Reporter: Michele Michielin <michele.michielin>
Component: MicroB engineAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: microb-bugs
Severity: normal    
Priority: Unspecified CC: andre_klapper, mail
Version: 5.0/(2.2009.51-1)   
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: All   
OS: Maemo   

Description Michele Michielin (reporter) 2010-02-08 13:22:40 UTC
SOFTWARE VERSION:
2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Open Web Browser from application menĂ¹ (the "grid")
2. Open the fisical keyboard
3. Type www.google.it in the address bar (followed by enter on the fisical
keyboard)
4. Wait for the website lo load completely
5. After a few second MicroB goes automatically into fullscreen mode
5. Type anything you want (for example the word "mother")

EXPECTED OUTCOME:
The word "mother" is shown into google search bar

ACTUAL OUTCOME:
The word "other" is shown into google search bar (the first letter is missing)

REPRODUCIBILITY:
Always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7)
Gecko/20091221 Firefox/3.5.7
Comment 1 Vladimir Oka 2010-02-08 15:35:54 UTC
Confirming. 

Behaviour exactly as reported. 

Happens also in non-full-screen mode.
Comment 2 Andre Klapper maemo.org 2010-02-09 00:34:05 UTC
Thanks for reporting this.

Missing step:
"Settings > Open (initially) in full screen" must be enabled.

I can reproduce this in 2.2009.51-1.
I cannot reproduce this anymore in the internal version 2010.05-4 - everything
is correct.
(Note: 2010 is the year, and the number after is the week.)

A future public update will include the fix. (This is not always already the
next public update.)

To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 3 Andre Klapper maemo.org 2010-03-15 20:52:03 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).