Bug 8683

Summary: Browser crashes when browsing some websites
Product: [Maemo Official Applications] Browser Reporter: Harish Koka <harish.k>
Component: MicroB engineAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: microb-bugs
Severity: major    
Priority: Medium CC: andre_klapper, tuukka.tolvanen
Version: 5.0/(2.2009.51-1)Keywords: crash
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: N900   
OS: Maemo   

Description Harish Koka (reporter) 2010-01-30 06:40:43 UTC
SOFTWARE VERSION:
2.2009.51-1

Device connected internet via WLAN or GPRS

EXACT STEPS LEADING TO PROBLEM: 
1. Launch browser and open url http://ragalahari.com/actors/starzone/ntr8.aspx
   or goto website http://ragalahari.com/index.asp and open any Photo Gallery
2. After the page loads, Tap on any image to enlarge it.
3. When the image enlarges, Tap on next and browse through few images.

EXPECTED OUTCOME:
The browser should not crash.

ACTUAL OUTCOME:
Browser crashed and core-dump is collected.

REPRODUCIBILITY:
2/10 times.

EXTRA SOFTWARE INSTALLED:
No

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.17)
Gecko/2009122116 Firefox/3.0.17 (.NET CLR 3.5.30729)
Comment 1 Harish Koka (reporter) 2010-01-30 07:11:05 UTC
The core-dump is around 14.5MB and bugzilla accepts only up to 2500KB for
attachments. Andre, Please help in uploading this core-dump.
Comment 2 tuukka.tolvanen nokia 2010-01-30 19:02:31 UTC
not reproducible (0/10) with current future browser bits circa 2010.05-1.
started at http://ragalahari.com/actors/starzone/ntr8.aspx , tapped on first
thumbnail, tapped on next (which appears to be the right-hand side half of the
enlarged picture) through five or so images.
Comment 3 timeless 2010-01-30 19:39:38 UTC
crash-reporter is available in the repositories, it has a way to send reports
to nokia, just include the bug number in your comment....
Comment 4 Andre Klapper maemo.org 2010-02-01 18:48:58 UTC
I cannot reproduce this either here, running internal version 2010.05-2.
I assume that this has been fixed since 2.2009.51-1 and hence closing, however
as requested by timeless: Please install Crash Reporter from the SDK Tools
repository and send coredumps directly.
See http://wiki.maemo.org/Extras-testing#Tools_for_testers for a how-to.
Comment 5 Andre Klapper maemo.org 2010-03-15 20:51:58 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).