Bug 8671 (int-166774)

Summary: Deletion of messages should move first those items to "Deleted Items" folder
Product: [Maemo Official Platform] Synchronization Reporter: Saturn <chris_saturn>
Component: Mail for ExchangeAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: activesync-bugs
Severity: normal    
Priority: Unspecified CC: andre_klapper, chris_saturn, itambrose, tri, vitaly.repin
Version: 5.0/(3.2010.02-8)   
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: N900   
OS: Maemo   

Description Saturn (reporter) 2010-01-29 23:27:57 UTC
SOFTWARE VERSION:
2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 

1. Configure a Mail for Exchange account  
2. Synchronise account and open the E-mail application  
3. Choose the new account and go to Inbox (or any other folder; doesn't really
make a difference)
4. Open a mail that you don't want anymore
5. Press the trash icon to delete message

EXPECTED OUTCOME:

Message has been moved to "Deleted Items" folder.

ACTUAL OUTCOME:

Message has disappeared completely.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
N/A

OTHER COMMENTS:

Accidental loss of data (mails) can easily happen (especially with a small
touch-screen). Usually in mail applications the deleted items are still kept
unless explicitly the user chooses from options to delete them immediately.
Comment 1 Andre Klapper maemo.org 2010-02-01 18:45:05 UTC
Hi, does this work correctly with direct, non-MfE email accounts? Because if
so, it is a Synchronization/MfE issue instead of an email issue...
Comment 2 Vitaly Repin 2010-02-13 20:14:08 UTC
Hmmm.  In fact it appears in "Deleted items" for MfE account.  But after sync.

Could you check the following:

1) Delete the message from your MfE account
2) Sync with server
3) Open "Deleted Items" folder in MS Outlook or through web interface

The message which has been deleted shall appear in the "Deleted items" folder.

What does not work is synchronization of "Deleted items" folder with your N900.
The reason was the fix for the previously reported bug - "every time I delete
the email it syncs back with my phone.  I don't want to pay for this traffic."

Do you really want to see "Deleted items" folder in the device?
Comment 3 Saturn (reporter) 2010-02-19 02:23:35 UTC
(In reply to comment #2)
> Hmmm.  In fact it appears in "Deleted items" for MfE account.  But after sync.
> 
> Could you check the following:
> 
> 1) Delete the message from your MfE account
> 2) Sync with server
> 3) Open "Deleted Items" folder in MS Outlook or through web interface
> 
> The message which has been deleted shall appear in the "Deleted items" folder.
> 
> What does not work is synchronization of "Deleted items" folder with your N900.
> The reason was the fix for the previously reported bug - "every time I delete
> the email it syncs back with my phone.  I don't want to pay for this traffic."
> 
> Do you really want to see "Deleted items" folder in the device?
> 

Thanks for the explanation. It makes sense to keep it like that.

Maybe its something with my setup, I should have mentioned I'm using also the
M4Efolders application, but the messages don't appear after synchronisation in
the "Deleted Items" when seen from MS Outlook or the web interface.

Actually, our IT provides also a way to view recently deleted mails in a
separate web interface and the deleted mails from MfE don't appear there
either. 

Probably next week (don't have much time right now) I will delete completely my
profile and re-create it to check if that solves the problem. 
If you need me to provide any specific logs (for ex. one of the ways the wiki
mentions) please let me know.
Comment 4 Andre Klapper maemo.org 2010-03-04 16:47:50 UTC
(In reply to comment #3)
> Probably next week (don't have much time right now) I will delete completely my
> profile and re-create it to check if that solves the problem. 

Results welcome. :-)
Comment 5 Venomrush 2010-03-05 03:52:35 UTC
I have MfE account and whenever I delete something from Inbox on the N900 it
gets deleted straight off rather than going to the already available Deleted
Items folder.
Comment 6 Venomrush 2010-03-05 03:52:59 UTC
*** This bug has been confirmed by popular vote. ***
Comment 7 Saturn (reporter) 2010-03-06 04:16:16 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > Probably next week (don't have much time right now) I will delete completely my
> > profile and re-create it to check if that solves the problem. 
> 
> Results welcome. :-)
> 

No change after re-creation of account.

Step done:
1. Delete mail account - no other mail account set.
2. Deleted calendar
3. reboot
4. Created new account with "Mail for Exchange" setting
5. Set synchronise mails 1 month back
6. Set synchronise all calendar entries
7. Set delete all at first synchronisation
8. Synchronised

Went to inbox selected a message and deleted.
Syncronised manually 
Went to PC and opened Oulook - synchronised all
Message was deleted from both devices and nowhere to be found.
Comment 8 Saturn (reporter) 2010-03-06 04:18:12 UTC
Should note that Exchange server version is 2003.
Comment 9 Ian Ambrose 2010-04-03 03:04:28 UTC
Happens to me too, and am on MS 2003 Exchange.

Deleted items from N900 are neither in the server's Inbox, Deleted Items folder
nor Deleted Items>Action>Recover Deleted Messages.

This does not happen on my E90 using the same account (and no, no conflicts
using at the same time - use E90 on completely separate occassions).

Agree they should at least go into Deleted Items folder on Server.

Mind you, the same happens with Gmail IMAP, which again, doesn't happen on the
Nokia E90, but part of a separate bug as this is for MfE.
Comment 10 Andre Klapper maemo.org 2010-05-03 14:55:11 UTC
This still happens in 3.2010.02-8 I assume?
Comment 11 Saturn (reporter) 2010-05-06 22:00:12 UTC
(In reply to comment #10)
> This still happens in 3.2010.02-8 I assume?
> 

Yes, it does.

Some more info I recently understood:
If in Outlook 2007 one goes to "Tools" > "Recover Deleted items..." it is
possible to see & recover the message deleted using modest.
Comment 12 Ian Ambrose 2010-05-07 00:39:57 UTC
(In reply to comment #11)
> (In reply to comment #10)
> > This still happens in 3.2010.02-8 I assume?
> > 
> 
> Yes, it does.
> 
> Some more info I recently understood:
> If in Outlook 2007 one goes to "Tools" > "Recover Deleted items..." it is
> possible to see & recover the message deleted using modest. 
> 

This is not the case for me using a 2003 exchange account. tried several times.
emails do not go into either active deleted folder or 'can be recovered' folder
Comment 13 Andre Klapper maemo.org 2010-05-12 15:47:15 UTC
This has been fixed in package
libas-protocol 0.1.0-2+0m5
which is part of the internal build version
10.2010.05-13
(Note: 2009/2010 is the year, and the number after is the week.)

The next public update will include the fix.

To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/