Bug 8528

Summary: XSHAPE render bug with corners of pointer-hover context-menus
Product: [Maemo Official Platform] System software Reporter: Darryl L. Miles <darryl-mailinglists>
Component: generalAssignee: unassigned <nobody>
Status: RESOLVED DUPLICATE QA Contact: system-software-general-bugs
Severity: minor    
Priority: Unspecified CC: andre_klapper
Version: 5.0/(2.2009.51-1)Keywords: moreinfo
Target Milestone: ---   
Hardware: All   
OS: Maemo   

Description Darryl L. Miles (reporter) 2010-01-25 21:43:48 UTC
SOFTWARE VERSION: 55.1

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Load up application such as MicroB or Conversations or Email
2. Find a page in the application where you can hold down the pointer stick on
the screen for a couple of seconds.
3. A context menu appears.  In MicroB this context menu might have on it, "Open
in New Window", "Add address", "Save page as".

Take a real close look at the corner of this popup menu (when the background
has been blured).  You will see they should be rounded off (with some alpha
channel/XSHAPE extension, the corner piece can a random colour, well not
completely random its a related colour).

EXPECTED OUTCOME:
Nicely rounded corners with blurred background behind.

ACTUAL OUTCOME:
Rendered as square with random colour where blurred background should be.

REPRODUCIBILITY:
always
Comment 1 Andre Klapper maemo.org 2010-01-26 12:42:38 UTC
(In reply to comment #0)
> SOFTWARE VERSION: 55.1

That's not a valid version, except that you're in week 55 of the year. ;-)

Where d the rounded off corners work in Maemo5?
Comment 2 Darryl L. Miles (reporter) 2010-01-26 15:09:29 UTC
Sorry I meant 51-1 (I was tired when I wrote it).

Sorry I don't fully understand your last question line.
Comment 3 Andre Klapper maemo.org 2010-01-28 00:22:12 UTC
The question is: Where exactly can I see the rounded corners in the Maemo5 User
Interface that you compare to? :)
Comment 4 Darryl L. Miles (reporter) 2010-01-28 12:39:25 UTC
Compare ?  To repeat the procedure to demonstrate.

1.Fire up MicroB
2.Browse to http://www.google.co.uk/
3.On the white space of the page (in the void) hold down the pen against the
screen for a few seconds.
4.The page (which becomes a background) will now blur, and a menu will appear.
5.Examine the corners of this menu closely, you will see that the menu edge
highlight has been drawn (but the actual corners of the dialog should have been
cut off via alpha-channel and not seen, but they still protrude to make the
square window).

If you do the above enough times you can see the color of the protruding part
can actually change randomly (usually some colour from another part of the
application).

The fact the edge highlight outline is drawn (rounded) indicates the intended
edge of the window.  If it was intending to be square then the highlight would
have been along the square edge.


Other parts of the N900 UI that have rounded corners style:
 * Load up an application such as XChat (from testing/devel repos) this
application has a few menu items so the full Menu Bar is created.  Use this
menu bar and examine the style of the "XChat >", "View >", "Server >", ...
menu, this is a correctly rendered menu, the background is blurred, the corners
are correctly removed with alpha-channel.  NOTE: THIS EXAMINE EXHIBITS THIS BUG
AS WELL BUT DUE TO THE LACK OF LIGHT CONTRAST BEHIND (unlike the google.co.uk
page) IT CAN BE DIFFICULT TO SEE.
 * The bottom right hand toggle button for toggling fullscreen and
menu/bottom-bar.
 * Click the "Add Bookmark" function (in MicroB), the buttons that appear have
rounded style.



Unfortunately a screenshot can not be taken since the Pen Down menu (which
might be a right-click menu for desktop) performs a keyboard grab (on the X11
server) so the usual Ctrl-Shirt-P to screen shot does not work during a
keyboard grab.
Comment 5 Andre Klapper maemo.org 2010-02-16 16:01:41 UTC
Hmm, my original question was "Where does a **context menu** have a **correct**
displaying?" :)

Anyway, this is the same as bug 5716, hence marking as a duplicate.

*** This bug has been marked as a duplicate of bug 5716 ***
Comment 6 Darryl L. Miles (reporter) 2010-02-16 18:48:20 UTC
bug #5716 has been marked as RESOLVED/FIXED on 2009-12-28.

However the bug exists at the date of filing this bug report.  So either that
older bug needs to be reopened or this in an incorrect duplicate ?

Please advise which it is.


I'm sorry I do not understand your "original question" part.
Comment 7 Andre Klapper maemo.org 2010-02-16 19:17:05 UTC
(In reply to comment #6)
> bug #5716 has been marked as RESOLVED/FIXED on 2009-12-28.

Please see comment 7 of that report.