Bug 8454 (int-157800)

Summary: Placing a call in portrait mode gets desktop stuck in portrait mode upon exit.
Product: [Maemo Official Applications] Chat & Call & SMS Reporter: twoboxen
Component: Call Application UIAssignee: rtcomm <rtcomm>
Status: RESOLVED FIXED QA Contact: call-ui-bugs
Severity: major    
Priority: Unspecified CC: andre_klapper, chemist, jon.hedemann, m, maemo, mb, nix900
Version: 5.0/(3.2010.02-8)   
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: N900   
OS: Maemo   
URL: http://talk.maemo.org/showthread.php?p=488520
Bug Depends on:    
Bug Blocks: 9270    

Description twoboxen (reporter) 2010-01-24 05:04:26 UTC
SOFTWARE VERSION:
(Settings > General > About product)
Version: 2.2009.51-1.002

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Place an outbound call in portrait orientation.
2. End call.
3. Close phone application while still in portrait orientation.

EXPECTED OUTCOME:
The normal landscape-oriented desktop.

ACTUAL OUTCOME:
A messed up portrait-oriented desktop.

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)
always

EXTRA SOFTWARE INSTALLED:


OTHER COMMENTS:
Here is forum link with other users having the same issue.
http://talk.maemo.org/showthread.php?p=488520

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US;
rv:1.9.2) Gecko/20100115 Firefox/3.6
Comment 1 Lucas Maneos 2010-01-24 13:50:52 UTC
(In reply to comment #0)
> REPRODUCIBILITY:
> always

Couldn't reproduce even once after 5 attempts.  Extra software installed?

(Note to self: sounds related to bug 5353).
Comment 2 Eric Stammers 2010-01-25 13:27:59 UTC
*** This bug has been confirmed by popular vote. ***
Comment 3 Thomas Perl 2010-02-09 16:10:34 UTC
I can confirm this bug. After placing a call from the contacts list with the
phone application in portrait mode, and ending the call, the task switcher
appears in portrait mode. Open applications (right now when this bug happened):
MæPad, gPodder, Contacts.

As a workaround, I lock the screen, then press the power button and swipe to
unlock, after which the "3D flip" animation appears and switches to landscape
mode.
Comment 4 mb 2010-02-09 16:28:20 UTC
I had the same thing like Thomas and the same workaround.

It is gone now. Somehow I have the feeling it has to to with the refelect theme
I had installed. but thats a very wild guess and I don't feel like trying to
reproduce it because its a royal pain in the neck.

Regards Markus
Comment 5 Andre Klapper maemo.org 2010-02-13 02:26:21 UTC
Can somebody provide a screenshot? (Please remove the displayed number if
possible, for privacy reasons)
Comment 6 Rüdiger Schiller 2010-02-13 19:06:30 UTC
screenshots to be found
http://talk.maemo.org/showthread.php?t=43049
Comment 7 nix900 2010-02-22 08:53:30 UTC
I still have this problem after upgrading to latest firmware 3.2008.02-8. I am
wondering if bug 9158 should be marked as a duplicate of this bug though it is
filed for the latest firmware update.
Comment 8 Andre Klapper maemo.org 2010-02-22 13:56:00 UTC
*** Bug 9158 has been marked as a duplicate of this bug. ***
Comment 9 micha_1983 2010-02-22 14:37:06 UTC
I know this is quite offtopic, but why do I get mails regarding this bug? I am
not subscribed to it.
Comment 10 Andre Klapper maemo.org 2010-02-22 14:38:45 UTC
(In reply to comment #9)
> I know this is quite offtopic, but why do I get mails regarding this bug? I am
> not subscribed to it.

Explained at the bottom of every bugmail you receive...
For future discussion please feel free to send me a private email. Thanks.
Comment 11 Andre Klapper maemo.org 2010-02-23 22:40:04 UTC
This issue should be fixed in the next public update.

To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 12 Andre Klapper maemo.org 2010-03-15 20:52:28 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).