Bug 8390 (int-143334)

Summary: Fast search on the desktop doesn't work with cyrillic (Русский) layout
Product: [Maemo Official Platform] Desktop platform Reporter: Serge Matveev <serge>
Component: Input method frameworkAssignee: Joaquim Rocha <jrocha>
Status: RESOLVED FIXED QA Contact: input-method-framework-bugs
Severity: major    
Priority: Unspecified CC: andre_klapper, Comrade_Anton, e.moshkov, kavalczuk, pdainbox, serge, sl1202, zmey_jr
Version: 5.0/(2.2009.51-1)   
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: All   
OS: Maemo   

Description Serge Matveev (reporter) 2010-01-22 11:23:00 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
If I start typing symbols on the hardware keyboard in the main view (fast
contact search), the first symbol always will be in english.

1. I have cyrillic layout switched on
2. Open hardvare keyboard
3. Press any letter several times

In the search field you can see first _english_ letter and the rest - cyrillic.
In the 'contacts' application fast search works fine, but not on the desktop.

EXPECTED OUTCOME:
The search must start in the current keyboard layout. 

ACTUAL OUTCOME:
The quick search is mostly unusable in the non latin keyboard languages.
Obviuos, in Russia I have moat of my contacts in russian.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US) AppleWebKit/532.8
(KHTML, like Gecko) Chrome/4.0.295.0 Safari/532.8
Comment 1 Andre Klapper maemo.org 2010-01-22 13:59:06 UTC
Thanks for reporting this. I can confirm this.
Fix is on the way.

1. Settings > Text Input > Hardware keyboard layout = Русский
2. Save
3. Close Settings
4. Start Contact Search by entering a character using the hardware keyboard
Comment 2 Andre Klapper maemo.org 2010-01-23 19:35:21 UTC
*** Bug 8060 has been marked as a duplicate of this bug. ***
Comment 3 Andre Klapper maemo.org 2010-01-23 19:38:10 UTC
*** Bug 8071 has been marked as a duplicate of this bug. ***
Comment 4 pdainbox 2010-01-27 10:08:47 UTC
>Thanks for reporting this. I can confirm this.
>Fix is on the way.

>1. Settings > Text Input > Hardware keyboard layout = Русский
>2. Save
>3. Close Settings
>4. Start Contact Search by entering a character using the hardware keyboard

It helps once. After some work time with my device this setting resets to
English layout back. Now I can't remember what activity I have done. But I have
to go to change this setting regulary.
Comment 5 Serge Matveev (reporter) 2010-01-27 11:37:18 UTC
"Settings > Text Input > Hardware keyboard layout = Русский" is always on for
me (and another russian users) by default, but it don't solve this problem. I
changed this to english and back to "русский", but still no effect. I use _all_
settings on my n900 as "русский" (because of Russia) - maybe this fact has
important

This bug persists since initial release of n900 firmare (pre PR 1.1) and I
don't know why nobody reported it already. This is 'well known' bug for the
russian n900 users :-(
Comment 6 Sergey 2010-01-28 21:49:18 UTC
I fully support the reporter. This is the major issue as it makes the whole
idea of contact lookup in Russian language not working. 

The first character that is looked up us always latin character, regardless of
the "hardware keyboard layout" setting and Ctrl+space switch. That is really
annoying as the user has to use backspace to delete this first latin character,
and then type it once more to get required Russian character.
Comment 7 Andre Klapper maemo.org 2010-02-02 13:38:45 UTC
This has been fixed in package
hildon-desktop 1:2.2.129-1+0m5
which is part of the internal build version
2010.04-11
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 8 Andre Klapper maemo.org 2010-02-23 20:39:13 UTC
*** Bug 9241 has been marked as a duplicate of this bug. ***
Comment 9 Andre Klapper maemo.org 2010-03-15 20:54:23 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 10 DitZ 2010-10-01 11:22:58 UTC
This problem still actual in PR1.2!
First symbols in fast search are in English, other are in Russian...
Comment 11 Eric 2011-02-02 22:32:44 UTC
Same in 20.2010.36-2 :(
Didn't work correctly since I bought it with 1.2 software.