Bug 8373 (int-154149)

Summary: N900 no longer accepting updates from Outlook 2007
Product: [Maemo Official Platform] Synchronization Reporter: Brad Grigor <bag>
Component: PC SuiteAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: maesync-bugs
Severity: normal    
Priority: Medium CC: andre_klapper, tri
Version: 5.0/(2.2009.51-1)   
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: N900   
OS: Maemo   

Description Brad Grigor (reporter) 2010-01-21 20:42:52 UTC
SOFTWARE VERSION:
(Settings > General > About product)
N900, Maemo 5, 2.2009.51-1.002
On the PC:
- Nokia PC Suite 7.1.40.1
- Outlook 2007
- Windows 7

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Install and configure Nokia PC Suite on PC (Windows 7).
2. Connect N900 via USB in PC Suite mode.
2. Perform initial synchronization to populate the N900 with Contacts,
Calendar, Tasks and Notes from Outlook 2007.
3. The, perform routine synchronizations. Synchronization settings are:
- General: What to Synchronize: Calendar/To-do Items; Contact Items; Notes
Items
- Calendar/To-do options: From 6 Month(s) in the past to 1 Year(s) in the
future; Do not synchronize completed To-do items is Checked.
- Microsoft Outlook options: Profile=Outlook, standard folders.
- Advance Settings:


EXPECTED OUTCOME:

ACTUAL OUTCOME:

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
1. Issue also occurs with Bluetooth synchronization.

2. This was first noticed on firmware 1.2009.42-11 that shipped with my
particular N900. I called Nokia N900 Tech Support and was advised that
synchronization with Outlook on a PC is not supported on the N900 and that this
would be corrected in a firmware update this year (2010). I decided to wait to
see if PR1.1 corrected the problem, but the fix wasn't there. The implication
is the problem is with the N900 software, not the Nokia PC Suite sofware.
Hence, this bug report.

User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1;
Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729;
Media Center PC 6.0; OfficeLiveConnector.1.4; OfficeLivePatch.1.3; Tablet PC
2.0)
Comment 1 Brad Grigor (reporter) 2010-01-21 20:51:30 UTC
SORRY-This got submitted before I finished completing the original form. Here
is the rest of it....

The PC Suite synchronization Advanced Settings are:
- Automatic Synchronization tab: Do not sync automatically; Launch Nokia PC
Sync automatically is Checked.
- Conflict Resolution: Microsoft Office
- Direction: Update in both directions
- Sync Profile: nothing entered

EXPECTED OUTCOME:
Routine synchronization should send updates from Outlook 2007 to the N900 and
vice versa.

ACTUAL OUTCOME:
After the initial population of data from Outlook 2007 to the N900, and after a
few (but unknown number of) synchronizations, it is noticed that updates in
Outlook are NOT appearing on the N900. Updates are moving only one way, i.e.
from the N900 to Outlook.

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)
Always.

NOTE: I have 3513 Contacts and several hundred Calendar, Tasks and Notes
records. Other users are not reporting sync problems but perhaps they have much
smaller databases.

EXTRA SOFTWARE INSTALLED:
A large number of apps have been installed on the N900, but nothing that is
involved in syncing the Contacts, Calendar, Tasks or Notes.
Comment 2 Andre Klapper maemo.org 2010-01-22 14:17:15 UTC
Thanks for the perfect report!
Comment 3 Venomrush 2010-03-24 00:58:04 UTC
Any updates from internal comments if this has been fixed for PR1.2?
Bug has been idle for 2 months..
Comment 4 Andre Klapper maemo.org 2010-04-16 16:28:48 UTC
Internally this cannot be reproduced in the internal builds that will become
the next public update, with PC suite version : 7.1.46.1, Outlook 2003.

Everything working as expected.

After the next public update has been released please reopen this report if it
is reproducible again.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/