Bug 8310 (int-153861)

Summary: Image Viewer shows only black screen
Product: [Maemo Official Applications] Images and Camera Reporter: Martin Grimme <martin.grimme>
Component: Image viewerAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: image-viewer-bugs
Severity: normal    
Priority: Unspecified CC: andre_klapper, harish.k
Version: 5.0/(2.2009.51-1)   
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: All   
OS: Maemo   

Description Martin Grimme (reporter) 2010-01-20 14:17:20 UTC
SOFTWARE VERSION:
PR 1.1

EXACT STEPS LEADING TO PROBLEM: 
1. click on an image in the image viewer
2. enter fullscreen mode
3. screen is only black and no image is visible until you zoom in

EXPECTED OUTCOME:
image instead of black screen

ACTUAL OUTCOME:
the image viewer always shows a black screen when in fullscreen with
zoom-to-fit (i.e. immediately after going fullscreen without zooming in)

REPRODUCIBILITY:
always, even after rebooting, happens since I'm on PR 1.1 (OTA update).

EXTRA SOFTWARE INSTALLED:
i will provide this list later if needed. bunch of stuff from OVI, maemo.org,
extras-testing. no extras-devel stuff
Comment 1 Andre Klapper maemo.org 2010-01-20 19:25:16 UTC
Hi,
so the picture is shown before going fullscreen.
When you go into fullscreen to get that black screen, does tapping on it again
show the picture again?
(Note to myself: int-128947, int-126306, int-126219)
Comment 2 Martin Grimme (reporter) 2010-01-20 20:29:42 UTC
Yes, tapping while in fullscreen mode returns back to windowed mode, where the
image is displayed. It's only fullscreen that's affected and only when not
zoomed in.
Comment 3 Andre Klapper maemo.org 2010-02-09 19:49:52 UTC
Two Nokia testers tried to reproduce this with the current internal versions
and were unsuccessful. Hence closing as FIXED.

A future public update will include the fix. (This is not always already the
next public update.)

To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 4 Andre Klapper maemo.org 2010-02-09 21:34:37 UTC
*** Bug 8908 has been marked as a duplicate of this bug. ***
Comment 5 Andre Klapper maemo.org 2010-03-15 20:54:35 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).