Bug 8252 (int-153862)

Summary: Browser addressbar refreshes/blanks shortly after new window opens
Product: [Maemo Official Applications] Browser Reporter: Jeffery MacEachern <j.maceachern+maemo>
Component: User interfaceAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: browser-bugs
Severity: minor    
Priority: Unspecified CC: andre_klapper
Version: 5.0/(2.2009.51-1)   
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: All   
OS: Maemo   

Description Jeffery MacEachern (reporter) 2010-01-19 04:10:16 UTC
EXACT STEPS LEADING TO PROBLEM: 
1. Open a browser window to an arbitrary website.
2. Use Ctrl+N to open a new window
3. As soon as the UI loads (addressbar focused), try to quickly enter a URL
from the hardware keyboard (no idea if it occurs with OSK, but probably not,
due to timing)

EXPECTED OUTCOME:
The address is entered as you type, and persists.

ACTUAL OUTCOME:
The first few characters appear (I can get about three at my typing speed),
then the blue progress bar flashes, and the addressbar blanks.  He result is
that tring to quickly open maemo.org in a new window actually attempts to open
something like "mo.org".
This does not occur if you wait a moment after opening the new window, e.g.
after the "refresh".
REPRODUCIBILITY:
always
EXTRA SOFTWARE INSTALLED:
Nothing browser-related, although for what it's worth, installing Adblock does
not change the behaviour.
OTHER COMMENTS:
This may be the result of something that isn't a bug per se, but I feel it's a
usability issue.
User-Agent:       Mozilla/5.0 (X11; U; Linux armv7l; en-US; rv:1.9.2a1pre)
Gecko/20091127 Firefox/3.5 Maemo Browser 1.5.6 RX-51 N900
Comment 1 Ryan Abel maemo.org 2010-01-19 08:26:50 UTC
*** Bug 8251 has been marked as a duplicate of this bug. ***
Comment 2 Ryan Abel maemo.org 2010-01-19 08:30:00 UTC
Yeah, I can see this one here. You have to start typing as soon as you hit
Ctrl-n. Fairly irritating.
Comment 3 Andre Klapper maemo.org 2010-01-28 15:05:43 UTC
This cannot be reproduced internally with 2010.03-8 / 2010.03-10.
Marking as FIXED already.
A future update will include the fix.
Comment 4 Andre Klapper maemo.org 2010-03-15 20:51:49 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).