Bug 8129 (int-157047)

Summary: Cannot play podcast m4v-file due to issue with qtdemux
Product: [Maemo Official Applications] Media player Reporter: Paul van Tilburg <paul>
Component: GeneralAssignee: unassigned <nobody>
Status: RESOLVED DUPLICATE QA Contact: media-player-bugs
Severity: normal    
Priority: Unspecified CC: andre_klapper, maemo
Version: 5.0/(3.2010.02-8)   
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: All   
OS: Maemo   

Description Paul van Tilburg (reporter) 2010-01-16 21:04:36 UTC
SOFTWARE VERSION:
2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
1. Download an (enhanced) iTunes podcast file that contains video.
   For example: http://www.mennodejong.com/?feed=podcast
2. Try to play it with the Media Player.

EXPECTED OUTCOME:
The Media Player plays the file and shows the video.

ACTUAL OUTCOME:
The Media Player seems to open the file but doesn't start playing.
When you hit the Play button, it seems to start playing since it spawns a
window, but this self-closes immediately.  The user is left without feedback.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
gPodder (to subscribe to & download the podcast, but this can also be done on a
desktop of course)

OTHER COMMENTS:
The problem is twofold:
(1) There is no feedback that (or even why) the file cannot be played, instead
the Media Player lets the user struggle. (This should probably be a separate
bug against the Media Player, but I want to be able to refer to this one.)
(2) If I play it from the commandline using: gst-launch playbin 
uri="file://$PWD/$SOME_FILE", I get the following error:

Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
ERROR: from element
/GstPlayBin:playbin0/GstDecodeBin2:decodebin20/GstQTDemux:qtdemux0: GStreamer
encountered a general stream error.
Additional debug info:
qtdemux.c(2645): gst_qtdemux_loop ():
/GstPlayBin:playbin0/GstDecodeBin2:decodebin20/GstQTDemux:qtdemux0:
streaming stopped, reason not-negotiated
ERROR: pipeline doesn't want to preroll.

However, when I replace playbin by playbin2, it works fine!

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US) AppleWebKit/532.8
(KHTML, like Gecko) Chrome/4.0.299.0 Safari/532.8
Comment 1 Andre Klapper maemo.org 2010-01-18 15:15:54 UTC
Hi,

(In reply to comment #0)
> EXACT STEPS LEADING TO PROBLEM: 
> 1. Download an (enhanced) iTunes podcast file that contains video.
>    For example: http://www.mennodejong.com/?feed=podcast

I can only see m4a links on that page.
Please provide an exact link. Also this is missing exact steps (do you save to
disk? do you open with media player?).
Comment 2 Paul van Tilburg (reporter) 2010-01-18 17:22:49 UTC
(In reply to comment #1)
> I can only see m4a links on that page.

Yes, I am sorry.  I just realised that I download them and rename them to .m4v
(since they contain video/stream of pictures) because I wanted to help tracker
since the .m4a extension is in fact lying.
I actually also tried not to rename them, because I'm happy if it just plays
the audio of the podcast and not show the video at all, but then Media Player
does give an error: Unknown audio codec.  This is also weird, because again,
with playbin2 I _can_ play it.  However, this seems to be a different
matter/bug.

> Please provide an exact link. 
An example (I mirrored the file): 
http://intuition.luon.net/intuitionpodcast/Menno%20de%20Jong%20-%20Intuition%20Podcast%20025.m4a
(renamed to .m4v optionally)

> Also this is missing exact steps (do you save to disk? do you open with media player?).

Indeed, I meant downloading "to disk" (where else could I download it to?), as
far as the thing in n900 can be called a disk.  And step 2 already mentions
opening using the Media Player?
Comment 3 Andre Klapper maemo.org 2010-02-02 23:09:42 UTC
Hi Paul, can you update your "steps to reproduce" (as a numbered list) again as
per your last comment, if this is still an issue?
Comment 4 Paul van Tilburg (reporter) 2010-02-02 23:30:43 UTC
(Updated) EXACT STEPS LEADING TO PROBLEM:
1. Start the browser
2. Go to
http://intuition.luon.net/intuitionpodcast/Menno%20de%20Jong%20-%20Intuition%20Podcast%20025.m4a
3. Choose "Save to Disk"
4. Open the Media Player
5. Go to Music > Intuition Podcast (in Albums mode)
6. Select "Menno de Jong - Intuition Podcast" to try to play it.

This bug report seems strongly related to
https://bugs.maemo.org/show_bug.cgi?id=6640#c1 where also playbin2 seems to
help.
Comment 5 Andre Klapper maemo.org 2010-02-22 19:08:38 UTC
According to internal Nokia testing this cannot be reproduced anymore in newer
internal builds, tested with the example in bug 6640.
Hence this is very likely fixed for the next release.
Comment 6 Andre Klapper maemo.org 2010-03-15 20:55:02 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 7 Andre Klapper maemo.org 2010-04-23 22:03:41 UTC
*** Bug 6640 has been marked as a duplicate of this bug. ***
Comment 8 Andre Klapper maemo.org 2010-04-23 22:05:07 UTC
Correction: Same issue as bug 6640 which is NOT fixed yet.

*** This bug has been marked as a duplicate of bug 6640 ***