Bug 8104 (int-154167)

Summary: Browser portrait mode makes it stop working after a while
Product: [Maemo Official Applications] Browser Reporter: Marc Deop <damnshock>
Component: Interaction modesAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: browser-interaction-modes-bugs
Severity: minor    
Priority: Low CC: andre_klapper, gazza_75, tuukka.tolvanen
Version: 5.0/(2.2009.51-1)Keywords: moreinfo
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: N900   
OS: Maemo   

Description Marc Deop (reporter) 2010-01-16 02:46:19 UTC
SOFTWARE VERSION:
PR 1.1
EXACT STEPS LEADING TO PROBLEM: 
1. Turning on portrait mode on the browser
2. Playing around a bit, surfing the web turning portrait/landscape a few times
in different websites
3. The browser just shows white pages whenever I try to load a page. The
"progress bar"( I mean the little line below the location field) just goes back
and forward again and again

EXPECTED OUTCOME: To keep working ;)

ACTUAL OUTCOME: Browser stops working

REPRODUCIBILITY:
7/10  (probably depends on how much you change between portrait/landscape

EXTRA SOFTWARE INSTALLED: some apps from the ovi store and plenty of apps from
extra repository

EXTRA COMMENTS:

Turning the portrait mode off seems to solve the problem and the browser starts
working again
Comment 1 tuukka.tolvanen nokia 2010-01-16 04:40:21 UTC
could be related to int-152973 though portrait isn't implicated there
Comment 2 Gary 2010-01-16 14:47:25 UTC
Same issue as before really. General us of the ctrl shift and o trick, before
the browser shut down and now refuses to launch.
Comment 3 Andre Klapper maemo.org 2010-02-01 12:25:05 UTC
"I'm not able to reproduce it on any latest image internally. Are there any
reliable steps for this issue?"
Comment 4 Marc Deop (reporter) 2010-02-01 17:17:28 UTC
(In reply to comment #3)
> "I'm not able to reproduce it on any latest image internally. Are there any
> reliable steps for this issue?"
> 

I can't seem to find the steps to make this happen :S

Although I can assure you it happens sometimes. I'll look further into it to
see if I can find something usefull.
Comment 5 Marc Deop (reporter) 2010-02-04 19:28:17 UTC
Well, after testing it for a few days... I can't find a way to reproduce it.
Although I must say it just happened once more in this last week.

Should we close the bug report?
Comment 6 Andre Klapper maemo.org 2010-02-09 19:14:38 UTC
This cannot be reproduce internally in current internal versions 2010.04-*,
plus a similar bug is marked as FIXED.

A future public update include the fix. (This is not always already the next
public update.)

To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 7 Andre Klapper maemo.org 2010-03-15 20:51:46 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).