Bug 8035 (int-155424)

Summary: Selecting song in media player doesn't cause song to play
Product: [Maemo Official Applications] Media player Reporter: Blaizzen <ziggfreed>
Component: GeneralAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: media-player-bugs
Severity: normal    
Priority: Unspecified CC: andre_klapper
Version: 5.0/(2.2009.51-1)   
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: All   
OS: Maemo   
Attachments: M3U file with described error

Description Blaizzen (reporter) 2010-01-15 09:42:53 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
1. Open the media player
2. Open a playlist or album by selecting one of its songs (this opens the full
list on the right next to the image of the record and the selected song plays)
3. Select another song from this list

EXPECTED OUTCOME:
To play the new song you selected

ACTUAL OUTCOME:
It does not play the song

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
Many, but none I would think could affect the media player

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.7)
Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)
Comment 1 Andre Klapper maemo.org 2010-01-15 19:07:29 UTC
Thanks for reporting!

(In reply to comment #0)
> EXACT STEPS LEADING TO PROBLEM: 
> 1. Open the media player
> 2. Open a playlist or album by selecting one of its songs (this opens the full
> list on the right next to the image of the record and the selected song plays)
> 3. Select another song from this list

These steps are a bit vague - at least I cannot reproduce as I don't get that
list on the right displayed only for a second.
Can you please provide an exact click by click how-to?

Also, what kind of songs are these about (format)?
The files are stored locally on the N900, I assume?
Comment 2 Blaizzen (reporter) 2010-01-16 07:06:03 UTC
Hi.

I forgot to mention this has occurred only on the new Firmware upgrade (so
version 2.2009.51-1.002) as far as I'm aware as i didn't notice it in the
previous version.

I Uploaded a folder of music (containing MP3 songs) on to the phone's memory
under "Nokia N900/Audio Clips/". Inside the folder was a M3U file with the
songs (so it only lists filenames without a path since the m3u file is in the
same folder as the songs).

1. Open the Media player
2. Select Music
3. In the menu at the top, select "Playlists", default was "Albums" from
memory.
4. Scroll down to "Imported"
5. Select the playlist you uploaded (as explained above)
6. The list of all the songs in the playlist comes up. Select a song from the
list
7. The previously mentioned list comes up with the record image on the left and
the full list on the right. If this stays only for one second then reverts to
the song progress bar and song information, pressing the record will go back to
the list.
8. Select another song from this list (the one with the record to the left)


While retesting this bug, it seems to have been resolved by itself as i can no
longer reproduce it. The only possible reason could be I restarted the phone a
few times while testing another bug. Sorry for that.
Comment 3 Blaizzen (reporter) 2010-01-16 09:31:46 UTC
Hello again... seems it still occurs from time to time. So I'm going to reopen
the bug and change it to 

REPRODUCIBILITY:
1/10


Extra info: Seems when the error occurs, if you press the same song again, it
will begin playing.
Comment 4 Andre Klapper maemo.org 2010-02-03 13:22:47 UTC
Hi, internal testing would like to have the Playlist file (M3U file).
Can you provide it please? If you don't want to see it in public, feel free to
send it by email to me (and mention this bug number)
Comment 5 Blaizzen (reporter) 2010-02-04 11:51:45 UTC
Created an attachment (id=2210) [details]
M3U file with described error

One of the M3U files that have caused the bug.
Comment 6 Andre Klapper maemo.org 2010-02-10 15:27:18 UTC
This was tested internally with a newer version with your playlist and could
not be reproduced.
Hence this has been most probably fixed in the meantime.

A future public update will include the fix. (This is not always already the
next public update.)

To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 7 Andre Klapper maemo.org 2010-03-15 20:54:59 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).