Bug 8011 (int-151641)

Summary: Changing volume without unlocking the phone no longer works
Product: [Maemo Official Platform] Multimedia Reporter: mpredotka
Component: Multimedia frameworkAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: multimedia-framework-bugs
Severity: normal    
Priority: Low CC: alexatkin, andree, andre_klapper, anidel, bandora, collin, eduperez, gdsotirov, martin, tri, ugomatic, urho.konttori
Version: 5.0/(2.2009.51-1)   
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: N900   
OS: Maemo   
Bug Depends on:    
Bug Blocks: 8012    

Description mpredotka (reporter) 2010-01-15 00:02:05 UTC
SOFTWARE VERSION:
2.2009.51-1.203.2

EXACT STEPS LEADING TO PROBLEM: 
1. Play some music. 
2. Lock the phone
3. Press the power button
4. Press the volume key

EXPECTED OUTCOME:
Ability to change volume.

ACTUAL OUTCOME:
Nothing happens.

REPRODUCIBILITY:
always

OTHER COMMENTS:
Option to change volume without unlocking the phone was great. Specially if
there are no keys on the headset to do that. I could change volume without
taking the phone out of my pocket. After firmware update this is gone and
changing volume requires more unnecessary steps. 
I hope it is not intentional and it's just a bug.

Sorry if it's wrong place for this bug report.
Comment 1 omeriko9 2010-01-15 00:10:17 UTC
*** This bug has been confirmed by popular vote. ***
Comment 2 Alex Atkin UK 2010-01-17 21:25:26 UTC
I was disappointed the N900 does not let you change the volume WHILE locked in
the first place, like my iPod does.  It should at least have the option to turn
that function on for people who aren't likely to knock the buttons
accidentally.

Good job I adjust it using the slider to unlock, if I had gotten used to using
the power button to have that suddenly not work either I would be really
pissed.

Its just too hard to adjust the volume on the N900 period, with the rocker
being turned off for zoom functionality, which should be available by gestures
in ALL apps that need zoom.
Comment 3 Venomrush 2010-01-18 08:18:56 UTC
In my opinion, it's already difficult enough to accidentally tap on the volume
keys while device is in the pocket, as both require a pretty mild strong force
to press down.

So, those keys should work without the need to unlock the device.
Comment 4 Andre Klapper maemo.org 2010-01-18 16:25:32 UTC
Confirming.
Comment 5 Andre Klapper maemo.org 2010-01-21 20:12:13 UTC
*** Bug 6487 has been marked as a duplicate of this bug. ***
Comment 6 Andre Klapper maemo.org 2010-01-21 20:15:09 UTC
I can definitely confirm that changing the volume when having the "Unlock
slider screen" shown worked in 41-10 and that it does not work in 51-1 anymore.

The old behaviour was changed due to some power consumption issues.
Comment 7 Andrej Krutak 2010-01-21 20:21:03 UTC
I'd love to know (no sarcasm here :) ), what power-consumption issue could be
caused by enabling 2 keys for 5 seconds...

anyho, if at least a documented option for reenabling this (quite useful)
feature, e.g. using gconf, was introduced in following release - I think that
it would make a lot of people happier...
Comment 8 Fadi Farah 2010-02-06 12:08:09 UTC
I also think that there should be an option to turn this on and off...
Comment 9 ugo 2010-02-06 13:52:10 UTC
I confirm that in the spirit of openness and customization of Maemo, it would
make sense to give users the option to choose
Comment 10 Andre Klapper maemo.org 2010-02-08 17:06:03 UTC
Feel free to post a ticket in http://maemo.org/community/brainstorm/ about a UI
option for this.
Comment 11 Andre Klapper maemo.org 2010-02-10 15:24:10 UTC
A fix is currently being worked on.
Comment 12 mpredotka (reporter) 2010-02-10 16:27:43 UTC
I know it'll generate mails to everyone subscribed to this bug, but I want to
say BIG THANK YOU!
Comment 13 Urho Konttori 2010-02-20 23:03:56 UTC
Afaik, we are going to integrate the fixes to pr1.2 on monday.
Comment 14 Andre Klapper maemo.org 2010-02-23 22:30:08 UTC
This has been fixed in package
mafw-gst-renderer 0.2.2010.07-2+0m5
which is part of the internal build version
10.2010.08-5
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 15 Aniello Del Sorbo 2010-06-02 01:58:48 UTC
I'd like to comment on this as this is still not verified.

Indeed the rocker keys' event get handled now, but in a weird (may be buggy?)
way.

If you lock the screen and the foremost application is handling the rocker
keys' event to handle zoom in/out (like Xournal or the MicroB browser), then
they will zoom in/out accordingly even though the lock screen is displayed and
the volume is NOT set.

This is different from the original behavior where the rocker keys' events
changed the volume in the lock screen, no matter what was running beneath it.

Aniello
Comment 16 Aniello Del Sorbo 2010-06-02 02:03:13 UTC
Did more test,

it actually works differently.

If I leave the Media Player running, it'll get the volume events and the volume
is going up/down as expected.
If an application like Xournal or Microb is the foremost app, it won't get the
events and the Media Player still gets it.
As expected again.

However, if the Media Player is not running, then the foremost application gets
the event.
I assume this is a feature rather than a bug and I'd mark this as VERIFIED.
Comment 17 Edu Perez 2010-06-24 22:55:43 UTC
> If I leave the Media Player running, it'll get the volume events and the volume
> is going up/down as expected.

For me this is a problem because I don't use the internal Media Player. And if
I'm using any other player the vlume is no changed. I think it should be
changed for all applications, not just for the built-in Media Player.

Is there any option to make the volume work with other applications?
Comment 18 mpredotka (reporter) 2010-06-25 00:28:52 UTC
(In reply to comment #17)

> 
> For me this is a problem because I don't use the internal Media Player. And if
> I'm using any other player the vlume is no changed. I think it should be
> changed for all applications, not just for the built-in Media Player.
> 
> Is there any option to make the volume work with other applications?
> 

It works with Panucci and RadioFM for me.
Comment 19 ugo 2010-06-25 02:10:13 UTC
> Is there any option to make the volume work with other applications?

> It works with Panucci and RadioFM for me.


It doesn't work for KMplayer for me
Comment 20 Andre Klapper maemo.org 2010-06-25 10:52:05 UTC
(In reply to comment #19)
> It doesn't work for KMplayer for me

Maybe KMplayer does not react to the keypress received?

Doesn't sound like Nokia's issue at all to me currently...
Comment 21 ugo 2010-06-25 12:40:47 UTC
(In reply to comment #20)
> (In reply to comment #19)
> > It doesn't work for KMplayer for me
> 
> Maybe KMplayer does not react to the keypress received?
> 
> Doesn't sound like Nokia's issue at all to me currently...
> 

You're probably right - I will check with KMplayer's developer, but it's
strange that when the screen is not locked, KMplayer reacts correctly to the
keypress, but with the screen locked it doesn't.
Comment 22 Edu Perez 2010-06-28 20:09:22 UTC
(In reply to comment #19)
> > Is there any option to make the volume work with other applications?
> 
> > It works with Panucci and RadioFM for me.
> 
> 
> It doesn't work for KMplayer for me
> 

I have tried with KMPlayer, Fm Radio, Panucci and Symfonie. None of them work.

I am locking the device with the switch next to the earphone plug. Maybe it has
a different behaviour if you leave it to lock with time.

I also tried the following:
- open the internal media player
- open panucci
- play anything with the internal media player
- pause
- switch to panucci, play anything
- lock the device
The volume does change... for some time (something like 1 minute). After that,
it stops responding to the key presses.

Now, if it works with panucci for you, there is something different... I'm
using version 10.2010.19-1.002. I will reflash it (I have installed just too
many things) and test again.
Comment 23 Edu Perez 2010-07-07 18:17:10 UTC
(In reply to comment #22)
> (In reply to comment #19)

......

Just reflashed with version 10.2010.19-1 and still getting the same behaviour.

Anyone has any ideias why this is not working for me and is working for others?
Comment 24 Andre Klapper maemo.org 2010-07-19 12:47:53 UTC
Probably 3rd party software...?
Comment 25 ugo 2010-07-19 15:58:55 UTC
(In reply to comment #24)
> Probably 3rd party software...?
> 

I confirm that the newest version of KMplayer in extras-devel is the first able
to use the volume key when locked. So, it is a third party software problem
Comment 26 Edu Perez 2010-07-19 16:48:27 UTC
Now I understand that, when the device is locked, you have to FIRST press the
power button (that brings the unlock screen) and then use the volume keys. This
worked with the players I use (symfonie and panucci).

When you say that KMplayer works, it means you can change volume WITHOUT first
going to the unlock screen?
Comment 27 ugo 2010-07-19 16:59:16 UTC
(In reply to comment #26)
> Now I understand that, when the device is locked, you have to FIRST press the
> power button (that brings the unlock screen) and then use the volume keys. This
> worked with the players I use (symfonie and panucci).
> 
> When you say that KMplayer works, it means you can change volume WITHOUT first
> going to the unlock screen?
> 

Yes, with Panucci at the moment you need to press the power button first. So
this is a problem with Panucci.
With KMplayer, you don't. - But this only works with the version in extra-devel