Bug 7996 (int-153268)

Summary: Media player's desktop widget displays wrong metadata of internet radios
Product: [Maemo Official Applications] Desktop Widgets Reporter: Bartosz Taudul <wolf.pld>
Component: Media playerAssignee: unassigned <nobody>
Status: VERIFIED FIXED QA Contact: mediaplayer-applet-bugs
Severity: normal    
Priority: Low CC: andre_klapper, tri
Version: 5.0/(2.2009.51-1)   
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: N900   
OS: Maemo   
Bug Depends on: 7995    
Bug Blocks:    
Attachments: Illustration of issue

Description Bartosz Taudul (reporter) 2010-01-14 20:29:17 UTC
SOFTWARE VERSION:
2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
1. Install OGG support package.
2. Add media player desktop widget to the desktop.
3. Start media player.
4. Add the following radio: http://relay.radio.ethz.ch:8000/kohina.ogg
5. Add the following radio: mms://stream.polskieradio.pl/program3
6. Start playing first stream.
7. Go to desktop, notice what desktop widget is displaying.
8. Start playing second stream.
9. Go to desktop, notice what desktop widget is displaying.

EXPECTED OUTCOME:
Only the data from currently playing stream are displayed.

ACTUAL OUTCOME:
One line is from first stream, next one is from the second stream.

REPRODUCIBILITY:
always

OTHER COMMENTS:
Related to bug 7995?
Comment 1 Bartosz Taudul (reporter) 2010-01-14 20:32:41 UTC
Created an attachment (id=1978) [details]
Illustration of issue

If the issue visible on the image is not obvious, look carefully at the two
stream URLs and compare with what the widget is displaying.
Comment 2 Andre Klapper maemo.org 2010-01-14 20:56:57 UTC
Trying to isolate the problem, this also happens with two MP3s streams (no ogg
involved)?
Comment 3 Bartosz Taudul (reporter) 2010-01-14 21:04:38 UTC
When the first stream is http://bezkitu.com/sluchaj.m3u, the issue is still
valid.

Note that the second stream is probably not MP3 (but some Nokia-supported MS
codec).
Comment 4 Venomrush 2010-03-24 00:49:16 UTC
Changing dependency as it seems related to Bug 7995 (fixed in PR1.2)
From comment 2 in bug 7995, it does not seem to be ogg specific.

Required verifying in PR1.2