Bug 7995 (int-173238)

Summary: Internet radio (ogg) stream metadata not displayed
Product: [Maemo Official Applications] Media player Reporter: Bartosz Taudul <wolf.pld>
Component: GeneralAssignee: unassigned <nobody>
Status: UNCONFIRMED QA Contact: media-player-bugs
Severity: normal    
Priority: Unspecified CC: andre_klapper
Version: 5.0:(10.2010.19-1)   
Target Milestone: ---   
Hardware: N900   
OS: Maemo   
Bug Depends on:    
Bug Blocks: 7996    
Attachments: Composite of media player application and widget

Description Bartosz Taudul (reporter) 2010-01-14 20:19:47 UTC
SOFTWARE VERSION:
2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
0. Install OGG Vorbis support package.
1. Start media player.
2. Add the following internet radio: http://relay.radio.ethz.ch:8000/kohina.ogg
3. Start playback.

EXPECTED OUTCOME:
Stream metadata, like currently playing track title is displayed by media
player.

ACTUAL OUTCOME:
"(unknown artist) / (unknown track)" is displayed instead.

REPRODUCIBILITY:
always

OTHER COMMENTS:
1. This bug should happen on mp3 streams also.
2. Correct track title/artist is blinked when the track changes, but is
instantly replaced by "unknown/unknown".
3. At the same time the media played desktop widget displays correct(?) artist
and title (it's not "unknown/unknown", but bug 7453 may apply here).
4. For additional confirmation the radio stream can be opened in foobar2000,
which correctly displays stream metadata.
Comment 1 Bartosz Taudul (reporter) 2010-01-14 21:08:05 UTC
http://bezkitu.com/sluchaj.m3u seems to be working correctly.
mms://stream.polskieradio.pl/program3 shows "unknown/unknown", but there are
metadata displayed (wrongly, see bug 7996) by the desktop widget.
Comment 2 Andre Klapper maemo.org 2010-01-15 18:36:51 UTC
Testing with ogg-support and 2010.02-7:

Does not seem to be ogg specific, at least
http://dradio.ic.llnwd.net/stream/dradio_dlf_m_a.ogg displays "Deutschlandradio
/ (['" in the Media Player.

(In reply to comment #0)
> 2. Add the following internet radio: http://relay.radio.ethz.ch:8000/kohina.ogg
> 3. Start playback.

Yay. Media Player crashed once after doing this (uploaded
mediaplayer-ECE9-11-2346.rcore.lzo), music continued playing though.

After the crash Media Player displays the information correctly, also after
restaring (tried several times).
So I assume that this has been fixed in the meantime.
Comment 3 Andre Klapper maemo.org 2010-03-15 20:54:58 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 4 Bartosz Taudul (reporter) 2010-05-25 22:26:52 UTC
Not fixed in PR1.2.
Comment 5 Bartosz Taudul (reporter) 2010-05-25 22:29:04 UTC
Created an attachment (id=2740) [details]
Composite of media player application and widget

Media player application displays garbage instead of correct text.

Additionaly, there were cases when media player application displayed nothing
in the second line, but the widget was displaying correct data.