Bug 793

Summary: lock screen should have 'if lost' info (e.g. display owner contact info)
Product: [Maemo Official Platform] System software Reporter: Rune Eriksson <rune.eriksson>
Component: Device lockAssignee: unassigned <nobody>
Status: RESOLVED WONTFIX QA Contact: device-lock-bugs
Severity: enhancement    
Priority: High CC: andre_klapper, ikm19, martin, mikapi, quim.gil, roope.rainisto, rupert.schlick, S.G.Pickering, trippin1
Version: 5.0/(1.2009.42-11)Keywords: enhancement-it2006, ITOS2007HE-garage
Target Milestone: Harmattan   
Hardware: All   
OS: Maemo   

Description Rune Eriksson (reporter) 2006-10-03 18:21:25 UTC
With PalmOS the lock screen doubled as a owner info space.
That would help lots of lost 770's find their owner.
Comment 1 Maemo QA (deprecated) 2006-10-17 14:30:39 UTC
Will be handled as an enhancement request. Thanks!
Comment 3 Quim Gil nokia 2008-12-01 08:25:53 UTC
*** Bug 3891 has been marked as a duplicate of this bug. ***
Comment 4 Quim Gil nokia 2009-01-08 16:24:07 UTC
Just an update: this feature is being considered for Harmattan. No commitment
yet.

Feedback welcome to nurture this feature request: information to be shown, user
preferences, behavior...
Comment 5 Rupert Schlick 2009-01-11 17:44:57 UTC
(In reply to comment #4)
> Just an update: this feature is being considered for Harmattan. No commitment
> yet.
> 
> Feedback welcome to nurture this feature request: information to be shown, user
> preferences, behavior...
> 
1. Information to be shown:
1.1. Content:
1.1.a) Free text with at least line breaks as formatting/layout
This allows the user to disclose information about himself at will, e.g. only
owner name, contact information or just a URL of a lost goods information site.
1.1.b) (optional/later/depending on other features) Owner information from
system setup/communication software
Communication software sometimes has a concept of "own address information" -
this could be used, with the advantage of address changes automatically
propagated (although its's hard to forget the change in the config if you see
the wrong data regularly - but minor changes migth be overlooked or ignored
because it is what it always used to be)
NewtOS had/has a concept of "owner data" which was used by several other
applications, also for registrating shareware and the like. If something like
that is introduced for maemo in the future, it should be also possible to use
it here.
1.1.c) Dynamic data
What I personally miss the most is a clock on the lock screen (I see no point
in carrying around a watch when there are that many other devices in reach
perfectly fit to show the same information). But there could be also other
dynamic information to show, e.g. current battery status.
I'm unsure of the actual implementation, but it seems to me, that the code to
show the lock device screen during boot up is not necessarily the same as for
the one shown when locking the already booted device. At least it may be
impossible to cleanly access the dynamic information for the one shown during
boot. If the dynamic part is implemented at all, in my opinion it would be
perfectly valid to only show it on the already booted device, not during boot.
1.2. Layout:
1.2.1 Positioning:
There is plenty of unused screen real estate at the moment, but the central
positioning of the dialog divides it into unusable chunks. It should be moved
to one side. Since there are right and left handed users, the side should be
configurable (see 2. Preferences). For finger usage, the buttons could be even
larger (especially higher) - maybe the dialog can be stretched in height to
fill the hole screen.
1.2.2 Graphical Design:
I see the following possibilities for graphical design and typesetting:
a. plain text, if possible reusing font information from the current theme
(default text font or extending the themes). The text should be left aligned
(or, perhaps, have configurable horizontal alignment) and vertically centered.
A setable background image would be nice. By the way, is the lock screen dialog
themeable?
b. html (subset at least reduced to statically renderable content - no
blinking, no animated gifs, no movie or flash content) - the html input could
be rendered one time when changing the prefs and then stored as a bitmap
directly displayable. This allows also setting a background image and
additionally different fonts and inline positioning of dynamic content.
c. bitmap image
Gives the most freedom on design, but most problems with perferences.

2. Preferences:
There is a configuration entry for lock device which should be expanded, if
necessary grouped into tabbed panels:
- Text (for 1.1.a)), if further formatting e.g. in HTML or as image is
supported, this would need an internal or external WYSIWYG editor to be usable.
- For unformatted text: Background image file selector + checkbox for using
background image
- Transparent keypad checkbox/percentage selector (eye candy option)
- (for 1.1.b)) Selector for program from which to take the owner information.
One selection is text. Possibly selector which owner data fields to show.
- (for 1.1.c)) 
--- Check box and order (similar to toolbar applets) for all available dynamic 
    displays (clock, battery status, ??)
--- Show dynamic data on bottom/top
- position keypad left/right
Comment 6 Andre Klapper maemo.org 2009-10-13 19:45:27 UTC
*** Bug 5370 has been marked as a duplicate of this bug. ***
Comment 7 Faheem Pervez maemo.org 2009-11-02 19:57:09 UTC
For the N800 and N810, http://talk.maemo.org/showthread.php?t=33359 may be of
interest.
Comment 8 Imtiyaz Maredia 2009-12-05 22:56:22 UTC
wish it also had upcoming appointment info..too
Comment 9 Andre Klapper maemo.org 2012-03-21 18:07:17 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia, hence resetting the ASSIGNED
status to NEW/UNCONFIRMED as nobody is working on this.

Note that very likely any feature requests for Maemo5 will not receive fixes
(WONTFIX) - I might mass-set this status in the future. There is a very small
chance for issues in open source components that contributed patches could be
included in the Maemo 5 CSSU Community updates - see http://wiki.maemo.org/CSSU
for more information.


For completeness (as Harmattan is mentioned in some reports), MeeGo 1.2
Harmattan used for the N9 and N950 is handled in
http://harmattan-bugs.nokia.com/ which has recently been closed for new bug
report entry [1].

[1]
http://www.developer.nokia.com/Community/Blogs/blog/n9-developer/2012/03/08/harmattan-bugzilla-closed-for-new-bugs
Comment 10 Andre Klapper maemo.org 2012-03-24 11:40:51 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia and it seems that there are no
plans for official updates currently, hence nobody plans to work on this
enhancement/wishlist request. 
(And in case you feel like discussing this situation: Nokia Customer Care or
http://talk.maemo.org would be the place to do so as you will not reach Nokia
officials in this community bugtracker - though all of this is really no news.)

Reflecting this status by setting RESOLVED WONTFIX for this
enhancement/wishlist request (see
https://bugs.maemo.org/page.cgi?id=fields.html#status for status explanations).

There is a small chance for issues in those Maemo components that are open
source: Contributed patches could be included and made available in the Maemo 5
Community CSSU updates. 
The Maemo CSSU project is run by a small team of volunteers; see
http://wiki.maemo.org/CSSU for more information.
So in case that you can provide a patch that fixes the reported problem, please
feel encouraged to file a request under
https://bugs.maemo.org/enter_bug.cgi?product=Maemo%205%20Community%20SSU .
Please note: The Maemo CSSU project is not related in any way to Nokia.


( Tag for mass-deleting bugmail: [cleanup20120324] )