Bug 7908

Summary: Only one "From" email address allowed per account
Product: [Maemo Official Applications] Email Reporter: Paul <maemo>
Component: GeneralAssignee: unassigned <nobody>
Status: RESOLVED DUPLICATE QA Contact: modest-bugs
Severity: enhancement    
Priority: Low CC: andre_klapper, maemo
Version: 5.0/(1.2009.44-1)   
Target Milestone: ---   
Hardware: N900   
OS: Maemo   

Description Paul (reporter) 2010-01-13 15:19:47 UTC
SOFTWARE VERSION:
(Settings > General > About product)

44-1.002

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Create new imap account in modest
2. Define "from address"
3. No ability to define other "from" addresses

EXPECTED OUTCOME:

For many email systems/users there is the ability to use many from addresses
even with a single account.  Even gmail supports "plus" addressing.  Domain
owners may have multiple addresses for personal use, business use, for specific
suppliers (see my email address for example).  Note that outgoing emails are
not necessarily (in fact not even technically) bound to an incoming account -
unless chosens to.

So the expected outcome would be to define a number of email addresses that can
be used as "from addresses" for a single SMTP server.

Under diablo, this was "fudgeable" by creating a dummy account that had fake
email settings for incoming, but real settings for outgoing (smtp server +
credentials + email address), then you could just select the outgoing address
when creating an email.  Clumsy but it worked.

Fremantle modest seems pretty keen to ensure that any incoming email account is
valid, and so will error constantly if a fake incoming account is used.

One way to approach this would be to define a contact as "me", and within that
contact, define all the email addresses required.  Then this would be used as a
dropdown for the "From" field.

The ideal (particularly in my case and for gmail users) the from field would
editable to whatever the user wanted.

The ultra-ideal would be that modest would use the "To:" field when replying to
emails as the "From:" field, as per the Virtual Identity plugin for
Thunderbird.

ACTUAL OUTCOME:

Always.

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.7)
Gecko/20100112 Gentoo Firefox/3.5.7
Comment 1 Andre Klapper maemo.org 2010-01-13 17:04:06 UTC
Thanks for reporting this.
Setting Severity to Enhancement and correcting Version field.
Comment 2 Andre Klapper maemo.org 2010-01-13 17:05:09 UTC
This might be a duplicate of bug 6424.
Comment 3 Lucas Maneos 2010-01-14 02:29:22 UTC
(In reply to comment #2)
> This might be a duplicate of bug 6424.

Yes, both (and also bug 3409) deal with the same fundamental problem: an email
account can have messages addressed to more than one email address delivered to
it, but it's not possible to generate replies with the appropriate From:
address with modest.

I think we should keep the discussion in one place (but please don't MOVE to
brainstorm).
Comment 4 Paul (reporter) 2010-01-14 08:37:24 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > This might be a duplicate of bug 6424.
> 
> Yes

Actually, 6424 is more of a bug than an enhancement - at least a 'philosophy of
modest' bug.  Modest defines an account as an incoming server, an outgoing
server, and associated credentials.  The accounts are atomic.  Yet, if one
account receives an email, modest will reply using a different (default)
account rather than the original.  There aren't many conceivable use cases
where this behaviour would be desired.

, both (and also bug 3409) deal with the same fundamental problem: an email
> account can have messages addressed to more than one email address delivered to
> it, but it's not possible to generate replies with the appropriate From:
> address with modest.
> 
> I think we should keep the discussion in one place (but please don't MOVE to
> brainstorm).
> 

Yes 3409 is the same as this bug, I didn't find it in my original search.

The suggestion of a "send only" account would be great - and seemingly
straightforward.
Comment 5 Andre Klapper maemo.org 2010-01-14 14:09:16 UTC
Okay, marking as duplicate of bug 3409.

(In reply to comment #3)
> I think we should keep the discussion in one place (but please don't MOVE to
> brainstorm).

Haha, that scared/frustrated already with Brainstorm? :-P

*** This bug has been marked as a duplicate of bug 3409 ***