Bug 7893 (int-135204)

Summary: Alarm clock does not wake me up when battery has died.
Product: [Maemo Official Platform] System software Reporter: RSalomaa
Component: dsmeAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: dsme-bugs
Severity: normal    
Priority: Medium CC: andrea, andre_klapper, bugs
Version: 5.0/(1.2009.44-1)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: N900   
OS: Maemo   

Description RSalomaa (reporter) 2010-01-13 12:24:38 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. 
2. 
3. 

EXPECTED OUTCOME: Even if the battery is dead I expect the N900 to wake me up
if I have set up an alarm.

ACTUAL OUTCOME:

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10) ??

EXTRA SOFTWARE INSTALLED: -

OTHER COMMENTS: .

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_4_11; fi-fi)
AppleWebKit/531.21.8 (KHTML, like Gecko) Version/4.0.4 Safari/531.21.10
Comment 1 Andre Klapper maemo.org 2010-01-13 13:46:06 UTC
Thanks for reporting this.
For future reference, please always use the bug template properly.

This has been fixed in packages
bme 0.8.50+0m5
dsme 0.60.38+0m5
which are part of the internal build version
2.2009.45-7
(Note: 2009 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 2 Andre Klapper maemo.org 2010-01-14 12:25:58 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 3 Andre Klapper maemo.org 2010-01-14 22:33:26 UTC
Gnarf... :-)
I ran into exactly this issue with the internal version 2010.02-5 this morning
- battery off, no alarm. After connecting the device to the laptop to recharge
via USB around 10:30h without switching the N900 on, after some time the alarm
started, showing 9:20 as the time.
I listened to some music before going to sleep so I had a 3,5mm audio jack
plugged in, but I definitely stopped the Media Player before I went to sleep. I
was in online mode and connected to my wifi, but no apps running and no IM
accounts in online mode or something.

So this does NOT seem to be fixed. -> reopening.
Comment 4 pepitoe 2010-02-02 16:07:19 UTC
*** This bug has been confirmed by popular vote. ***
Comment 5 Andre Klapper maemo.org 2010-09-08 13:33:47 UTC
Seems to work for me currently.
If this is still a problem please file a new bug report. Thanks!