Bug 7756

Summary: Downloading embedded images in HTML Painfully Slow and uses all of the device's performance
Product: [Maemo Official Applications] Email Reporter: Guy Salazar <guy.salazar>
Component: GeneralAssignee: unassigned <nobody>
Status: RESOLVED DUPLICATE QA Contact: modest-bugs
Severity: normal    
Priority: Medium Keywords: performance
Version: 5.0/(2.2009.51-1)   
Target Milestone: ---   
Hardware: N900   
OS: Maemo   
Attachments: commercial html email including tons of pictures

Description Guy Salazar (reporter) 2010-01-07 20:21:54 UTC
SOFTWARE VERSION:
(Settings > General > About product) 1.2009.42-11.002

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Get an e-mail, like a newsletter from Newegg.com or something.
2. Select to view the e-mail.
3. Click on the "download images" button on the bottom of the screen (just
right of the trash can"

EXPECTED OUTCOME:  Images embedded in message download quickly.

ACTUAL OUTCOME:  Images take forever to download and display (3x-5x slower than
the ACTUAL WEBPAGE that, for example, e-mail message refers to!

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)

EXTRA SOFTWARE INSTALLED:Transmission, Recoreder, Gonvert, FM Radio, Petrovich,
Zoutube, Hermes, WPCreator, eCoach

OTHER COMMENTS:  This issue is present whether using T-mobile's 3G/3.5G or even
over wifi and within touching distance of my N wireless router that has a
12Mbps DSL connection.  Interestingly, web pages, even large ones like Engadget
load several times Faster in the web browser than images that are embedded in
an e-mail message.  

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US)
AppleWebKit/532.0 (KHTML, like Gecko) Chrome/3.0.195.38 Safari/532.0
Comment 1 Uwe Kaminski 2010-01-11 10:25:03 UTC
I can confirm that.

The message is shown while modest downloads the images. You can see how the
images are rendered line by line and during this process the device is very
irresponsible.

I'll attach an example message to this bug.
Comment 2 Uwe Kaminski 2010-01-11 10:26:10 UTC
Created an attachment (id=1958) [details]
commercial html email including tons of pictures
Comment 3 Andre Klapper maemo.org 2010-01-11 15:04:40 UTC
Thanks for reporting this.
This particular problem has already been reported into our bug tracking system,
but please feel free to report any further bugs you find. Also feel encouraged
to vote for the original bug report if interested.

*** This bug has been marked as a duplicate of bug 6279 ***