Bug 7742

Summary: Apps depending on libqt4-phonon won't install on 2.2009.51-1
Product: [Extras] Qt Reporter: Andrew Flegg <andrew>
Component: PackagesAssignee: Antonio Aloisio <Antonio.Aloisio>
Status: RESOLVED FIXED QA Contact: general-bugs
Severity: major    
Priority: High CC: Antonio.Aloisio, famusc, S.G.Pickering
Version: 4.5-Fremantle   
Target Milestone: ---   
Hardware: All   
OS: Maemo   
Attachments: Terminal output showing libqt4-core, -phonon versions

Description Andrew Flegg (reporter) maemo.org 2010-01-07 14:20:41 UTC
SOFTWARE VERSION:
2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
1. Add the Extras-testing repository through the Application Manager
(http://wiki.maemo.org/Extras-testing)
2. Try to install Utilities > TickStill

EXPECTED OUTCOME:
Package installs.

ACTUAL OUTCOME:
Package fails to install. This is because it depends on libqt4-core and
libqt4-phonon. Of the former, only 4.5.3~git20090723-0maemo6+0m5 is available;
however the latter has a fixed dependency on 4.5.3~git20090723-0maemo4+0m5.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
available on request

OTHER COMMENTS:
Will attach a full log of `apt-get install' and `apt-cache policy'

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.1.6)
Gecko/20091215 Ubuntu/9.10 (karmic) Firefox/3.5.6
Comment 1 Andrew Flegg (reporter) maemo.org 2010-01-07 14:21:38 UTC
Created an attachment (id=1947) [details]
Terminal output showing libqt4-core, -phonon versions
Comment 2 Simon Pickering maemo.org 2010-01-10 12:39:32 UTC
Confirmed and raising the priority and severity (to something reasonable I
hope, perhaps should be higher still) as this is a major issue for those of us
trying to develop, test and/or use Qt apps (especially as we can't flash back
to an older image version now).
Comment 3 Antonio Aloisio 2010-01-11 09:41:34 UTC
Hi,
4.5.3~git20090723-0maemo6+0m5 packages are missing from the application
repositories. I don't know if is it possible adding now Qt maemo6+0m5 without
breaking compatibility with PR 1.0.
I'll contact Marcell for this issue.
Comment 4 Antonio Aloisio 2010-01-11 12:15:03 UTC
I asked to Marcell and new Qt packages are in an external repository:
downloads.maemo.nokia.com. Problem is that it's password protected.
I don't know if you have credential to access to those pkgs.

New Qt packages will be in Application repository only when PR 1.1 will be out.
(In reply to comment #3)
> Hi,
> 4.5.3~git20090723-0maemo6+0m5 packages are missing from the application
> repositories. I don't know if is it possible adding now Qt maemo6+0m5 without
> breaking compatibility with PR 1.0.
> I'll contact Marcell for this issue.
>
Comment 5 Andrew Flegg (reporter) maemo.org 2010-01-11 12:34:17 UTC
(In reply to comment #4)
> I asked to Marcell and new Qt packages are in an external repository:
> downloads.maemo.nokia.com. Problem is that it's password protected.

What repo exactly? I have the following lines in
/etc/apt/sources.list.d/hildon-application-manager.list

From PR1.1/Ovi:
deb https://downloads.maemo.nokia.com/fremantle/ssu/apps/ ./
deb https://downloads.maemo.nokia.com/fremantle/ssu/mr0 ./
deb https://downloads.maemo.nokia.com/fremantle/ssu/ovi/ ./

And, from PR1.0:
deb https://downloads.maemo.nokia.com/fremantle/apps/ ./

> New Qt packages will be in Application repository only when PR 1.1 will be
> out.

Given PR1.1 has its own "apps" repository (from what I can tell above), can't
they be pushed there now? Otherwise a lot of Qt software can't be tested on
PR1.1.
Comment 6 Antonio Aloisio 2010-01-11 12:57:26 UTC
Hi Andrew,
in according to Marcell the repository is the following one:
https://downloads.maemo.nokia.com/unreleased/fremantle1.1/apps ./

Antonio

(In reply to comment #5)
> (In reply to comment #4)
> > I asked to Marcell and new Qt packages are in an external repository:
> > downloads.maemo.nokia.com. Problem is that it's password protected.
> 
> What repo exactly? I have the following lines in
> /etc/apt/sources.list.d/hildon-application-manager.list
> 
> From PR1.1/Ovi:
> deb https://downloads.maemo.nokia.com/fremantle/ssu/apps/ ./
> deb https://downloads.maemo.nokia.com/fremantle/ssu/mr0 ./
> deb https://downloads.maemo.nokia.com/fremantle/ssu/ovi/ ./
> 
> And, from PR1.0:
> deb https://downloads.maemo.nokia.com/fremantle/apps/ ./
> 
> > New Qt packages will be in Application repository only when PR 1.1 will be
> > out.
> 
> Given PR1.1 has its own "apps" repository (from what I can tell above), can't
> they be pushed there now? Otherwise a lot of Qt software can't be tested on
> PR1.1.
>
Comment 7 Andrew Flegg (reporter) maemo.org 2010-01-14 14:49:29 UTC
Now that 2.2009.51-1 is PR1.1 and in general availability, has a matching
libqt4-phonon been released?

The situation is sub-optimal as it seems a version of Qt which matches PR1.1
can't be made available at the same time as one for PR1.0; this means one group
of people (the upgraded) or another (the unupgraded) will be in a poor
position. apt is designed to handle mulitple versions; why isn't this is a
solution here?
Comment 8 Antonio Aloisio 2010-01-19 16:57:02 UTC
Qt 4.5 packages install fine in PR 1.1