Bug 7568 (int-150606)

Summary: Sites in history overview that were loaded in portrait mode appear distorted
Product: [Maemo Official Applications] Browser Reporter: Ryan Abel <rabelg5>
Component: User interfaceAssignee: unassigned <nobody>
Status: VERIFIED FIXED QA Contact: browser-bugs
Severity: minor    
Priority: Low CC: andre_klapper, wolf.pld
Version: 5.0/(2.2009.51-1)   
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: All   
OS: Maemo   
Attachments: Screenshot showing the stretched preview image

Description Ryan Abel (reporter) maemo.org 2010-01-02 03:26:06 UTC
SOFTWARE VERSION:
2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 

1. Enable portrait mode with Ctrl-Shft-o.
2. Load a web page.
3. Hold the device in portrait mode until it rotates.
4. Tap a link.
5. Hold the device in landscape mode until it rotates.
6. Tap the back button in the toolbar.

EXPECTED OUTCOME:
The last page in history that was in portrait mode is either previewed in
portrait mode or rendered in landscape.

ACTUAL OUTCOME:
The last page's portrait preview is stretched to fit a landscape preview.

REPRODUCIBILITY:
Always

OTHER COMMENTS:
Not a big issue, but it does look quite ugly.

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; en-us)
AppleWebKit/531.9 (KHTML, like Gecko) Version/4.0.3 Safari/531.9
Comment 1 timeless 2010-01-03 06:02:04 UTC
"yep, we know"

(but for the rest of the audience, feel free to attach a screenshot so they can
point and laugh)
Comment 2 Ryan Abel (reporter) maemo.org 2010-01-03 21:20:47 UTC
Created an attachment (id=1905) [details]
Screenshot showing the stretched preview image
Comment 3 Andre Klapper maemo.org 2010-01-11 15:55:33 UTC
"With 2010.01-7 images I don't see stretched images. Closing as Already Fixed"
Comment 4 tuukka.tolvanen nokia 2010-01-16 18:26:56 UTC
*** Bug 8125 has been marked as a duplicate of this bug. ***
Comment 5 Andre Klapper maemo.org 2010-03-15 20:51:38 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).