Bug 7521 (int-152297)

Summary: N900 doesn't start charging
Product: [Maemo Official Platform] Core Reporter: henri
Component: generalAssignee: unassigned <nobody>
Status: CLOSED FIXED QA Contact: core-general-bugs
Severity: critical    
Priority: High CC: andre_klapper, firstknightfirst, frank.banul, goodboya3, henri, jon.hedemann, jubael, k_aexon, nivw2008, seb.palacio, simontemp, tri, vincent-maemo
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: N900   
OS: Maemo   

Description henri (reporter) 2009-12-31 11:14:37 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))

I left my N900 charging with an usb-cable with an iMac during the night. When I
woke up in the morning the N900 was dead although when I left it it was
charging. What I believe happened was that the iMac went into powersave-mode
and stopped charging through the usb. N900 did not recognize this but emptied
the battery completely. In the morning, the N900 did not respond, neither after
having it connected to a charger for 40 minutes. I tried different chargers and
nothing helped. I then tried another 3.7V battery from another Nokia phone
(which didn't fit so I had to press it against the pins) and the telephone
powered up. I switched back to the dead battery but the phone didn't start
charging (no lights etc). 

I will go to a shop and check that the battery would not have malfunctioned,
which I highly doubt. If this is the case the fault is with the battery.
Otherwise there is some critical bug with the N900. 


EXPECTED OUTCOME:

ACTUAL OUTCOME:

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)


EXTRA SOFTWARE INSTALLED:


OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US;
rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6
Comment 1 Andre Klapper maemo.org 2009-12-31 12:46:24 UTC
For future reference, please always use the bug template.

> N900 did not recognize this but emptied the battery completely.

What is there to "recognize"? N900 stops charging as it does not get any power
anymore I'd say, or does "powersaving mode" (whatever that exactly means for a
Mac) make sure that there is still enough power on USB to charge connected
devices?

> In the morning, the N900 did not respond, neither after having it connected 
> to a charger for 40 minutes.

What does this exactly mean? After you  plugged the N900 in a wall socket, did
the yellow LED light pulsate as a sign for charging?
Comment 2 henri (reporter) 2009-12-31 15:18:43 UTC
(In reply to comment #1)
> For future reference, please always use the bug template.
> 
> > N900 did not recognize this but emptied the battery completely.
> 
> What is there to "recognize"? N900 stops charging as it does not get any power
> anymore I'd say, or does "powersaving mode" (whatever that exactly means for a
> Mac) make sure that there is still enough power on USB to charge connected
> devices?
> 

Yes, but shouldn't the N900 leave enough juice in the battery so I could start
charging it in the morning again?

> > In the morning, the N900 did not respond, neither after having it connected 
> > to a charger for 40 minutes.
> 
> What does this exactly mean? After you  plugged the N900 in a wall socket, did
> the yellow LED light pulsate as a sign for charging?
> 

No LED's, no reaction at all after I had it plugged in to a wall socket for
over 40 minutes. I went to a store to recharge the battery and after that the
N900 worked OK again. 

What I believe happened is that the N900 did not recognize that the usb stopped
charging and emptied the battery completely. In the morning it did not
recognize (if that's possible?) that there even was a battery as there was no
current in it, and therefore didn't start charging it. 

Does being connected to a usb without getting charged empty the battery?
Comment 3 Vincent Lefevre 2010-01-03 14:29:15 UTC
Even though I plugged the USB cable from my PowerMac (while the battery was
almost completely charged) yesterday, my N900 didn't charge during the night
and the battery ended up being almost empty. When unplugging and replugging the
cable, the N900 started charging again.
Comment 4 Vincent Lefevre 2010-01-03 17:45:25 UTC
I can reproduce the problem: whenever I plug the USB cable in while the screen
is locked, the N900 doesn't charge (the LED remains off).
Comment 5 henri (reporter) 2010-01-03 19:28:25 UTC
My thoughts were that the bug was the fact that N900 empties it's battery
through the usb completely, being unable to recharge it in the morning. 

There is a high possibility that the usb on the Mac doesn't send any
electricity to the usb when in powersave-mode?
Comment 6 Vincent Lefevre 2010-01-03 23:20:20 UTC
(In reply to comment #5)
> There is a high possibility that the usb on the Mac doesn't send any
> electricity to the usb when in powersave-mode?

In my case, there's no such powersave mode, and the problem occurs while I'm
using the PowerMac. Also, the same problem occurs between my N900 and a laptop
under Linux: the N900 charges only when the USB cable is plugged in while the
screen of the N900 isn't locked.
Comment 7 Andre Klapper maemo.org 2010-01-04 17:30:34 UTC
...and confirming as per second reporter.
Comment 8 Frank Banul 2010-01-06 18:03:24 UTC
I'm seeing this as well. If the screen is blank, plugging in to a USB port or
Nokia AC adapter will not always start charging. I don't think I've ever seen
this when the screen is active.
Comment 9 Frank Banul 2010-01-06 21:38:16 UTC
More info: Came back from lunch, my MacBook Pro had gone to sleep. MacBook Pro
is connected to a powered USB hub. Plugged the blank screen N900 to the powered
USB hub. This woke the MacBook up. The USB Device Tree does not show the N900
as being present. The N900 is not charging.

Then I turned the N900 screen on and it started charging.
Comment 10 Jon Hedemann 2010-01-06 23:15:41 UTC
I've experienced a somewhat similar problem: 
When the N900 battery runs completely dry (not connected to any other
device/charger; just powers-off by itself) and I connect the phone to the
charger and connect this to a power outlet, the phone doesn't start changing
AND won't start when I press and hold the power-on button.
But if I remove the back cover, remove the battery and replace it again, and
then reconnect the phone to the power outlet-connected charger, THEN the phone
starts charging and I can power-on the phone by pressing and holding down the
power-on button.
Comment 11 Antodela 2010-01-07 00:36:56 UTC
Same here with a macbook pro. If the screen is locked the charge don't start
and also, leaving the phone in this state (connected to usb with no battery
charge) will result with an empty battery
Comment 12 Jon Hedemann 2010-01-08 02:30:36 UTC
(In reply to comment #10)
> I've experienced a somewhat similar problem: 
> When the N900 battery runs completely dry (not connected to any other
> device/charger; just powers-off by itself) and I connect the phone to the
> charger and connect this to a power outlet, the phone doesn't start changing
> AND won't start when I press and hold the power-on button.
> But if I remove the back cover, remove the battery and replace it again, and
> then reconnect the phone to the power outlet-connected charger, THEN the phone
> starts charging and I can power-on the phone by pressing and holding down the
> power-on button.
> 
Please disregard this comment. I somehow cannot recreate the situation and has
consequently marked this bug as INVALID. Sorry...
Comment 13 nivw2008 2010-01-11 21:59:05 UTC
after upgrading now to 44.1 firmware, I plug the charger to the N900 when it is
on and connected to the cellular and wifi.
the yellow led doesnt light
When I power the unit off, I can charge it.
Niv
Comment 14 Vincent Lefevre 2010-01-12 03:38:13 UTC
I haven't seen any change in the behavior after the firmware upgrade.
Comment 15 Antodela 2010-01-12 12:52:39 UTC
(In reply to comment #14)
> I haven't seen any change in the behavior after the firmware upgrade.
> 

Hi Vincent, have you already try to put the phone on charge with the display
turned on? Sometimes, with the lock display, the phone don't start the charge
until you disconnect it from micro usb, turn on the display and then connect
the micro usb.
Comment 16 Vincent Lefevre 2010-01-12 14:05:15 UTC
Antodela, I've never had any problem when the display is turned on, as I said
in comment #6. What I've said in comment #6 remains true after the firmware
upgrade (which didn't change anything concerning this bug).
Comment 17 Antodela 2010-01-12 14:19:51 UTC
Sorry, i've forgot your previous post. Anyway, someone says this is a minor
update and soon will be released the final.
Comment 18 nivw2008 2010-01-12 18:14:21 UTC
more testing:
the unit is turned off , and left for the night to charge fully.
during the day I used the N900, until the battery was red.
while the screen was dark (device was locked) I plugged in the wall charger -
it works!! yellow light comes on.
Comment 19 Jubael 2010-01-12 21:03:07 UTC
I have this problem, and I'm a nerd, so I was testing the battery and the
capacity to be turned on after powering down.

I ran the device until it shut down on it's own. I turned it on to make certain
that it was empty, and it came up with a "dim" screen showing nokia, and the
loading dots, and then went off again.

I plugged the device into multiple different devices (all dell devices, D630,
Optiplex 270 and 280) and USB 1.0 and USB 2.0 that were able to charge the
little 99 (I'm too lazy to say n900) and it didn't charge.

I plugged it into the wall supply and it didn't charge, and would not power on.

I reseated the battery, and it did not charge, and did not power on when
connected to a wall charger.

I tested again with a dell laptop USB port after reseating the battery, and the
charge indicator didn't light up.

I suspect that the standby mode doesn't allow for enough power for user errors,
and that the amount of energy left in the battery doesn't account for someone
trying to turn it on more than one time after it has automatically shut down. 

I believe further that the device should have a monitor in place that judges
when that good time to go into standby is. I further imply that this monitor
has a predetermined value that is nonambiguous and set by the manufacturer. 

I suggest a patch that raises that threshhold, perhaps has a low-power notice
that states it is _Required_ to plug in the device for charging or the battery
may suffer a complete discharge.

I suggest allowing the device with a battery and plugged into a wall to have a
hardware driven method for booting from a power source that is not dependent on
the batter having a charge.

I believe that recharging the battery by itself or replacing the battery will
resolve the my issue with being unable to charge and likely the same issue for
others.

I suspect that Mac shuts down all powered ports (including the wlan card) when
it goes into "standby."

My experiences and suggestions, only. I hope Nokia is listening. 

-jjj


(In reply to comment #12)
> (In reply to comment #10)
> > I've experienced a somewhat similar problem: 
> > When the N900 battery runs completely dry (not connected to any other
> > device/charger; just powers-off by itself) and I connect the phone to the
> > charger and connect this to a power outlet, the phone doesn't start changing
> > AND won't start when I press and hold the power-on button.
> > But if I remove the back cover, remove the battery and replace it again, and
> > then reconnect the phone to the power outlet-connected charger, THEN the phone
> > starts charging and I can power-on the phone by pressing and holding down the
> > power-on button.
> > 
> Please disregard this comment. I somehow cannot recreate the situation and has
> consequently marked this bug as INVALID. Sorry...
>
Comment 20 Kai 2010-01-13 14:43:57 UTC
I hava a problem that sounds much like the described and here's my description.

I usesa small mobile (micro) usb charger that holds a regular battery. As I
looked at the display and noticed that the battery does not charge anymore, I
firstly thought that the battery (of the mobile charger) was simply empty. So I
plugged in the wall charger and got the message that the (N900) battery is now
charging. But after about 5 seconds another message was displayed saying "not
charging".

After that I shutdown the N900 and removed the battery for a moment (as well as
the charger). After booting  the N900 completely again and plugging in the wall
charger, the battery was charging only for a moment. After a short period of
time, again the message "not charging" was displayed. The strange thing about
it is, that if the N900 is off and plugged to the wall charger, the led blinks
yellow, which indicates that the battery is getting charged (and in fact it is
charging). Switching the N900 on plugging it to any charger (wall, pc, mobile)
results in a short charging period and ends up in "not charging" and no yellow
led.
Comment 21 Seb 2010-01-13 16:04:41 UTC
I have experienced a similar bug and recreate it with the following: 
Device is on charge (wall)
Power off device.
Power on device.
Charge light stops.
Device is dead.
Remove and replace battery device powers on.

Is this a hardware or software fault?
Comment 22 Jubael 2010-01-13 20:38:23 UTC
My guess is that it is some kind of wonky hardware issue that doesn't let it
boot without believing there is battery power. Like there is a circuit breaker
of some kind that blows when powering on while connected to a wall. I wish it
would boot without a battery.

(In reply to comment #21)
> I have experienced a similar bug and recreate it with the following: 
> Device is on charge (wall)
> Power off device.
> Power on device.
> Charge light stops.
> Device is dead.
> Remove and replace battery device powers on.
> 
> Is this a hardware or software fault?
>
Comment 23 Andre Klapper maemo.org 2010-01-14 21:49:54 UTC
Is this still an issue in 2.2009.51-1 which was released today, and if you have
not done yet, can you please provide your steps again? Thanks!
Comment 24 Seb 2010-01-15 00:47:53 UTC
(In reply to comment #23)
> Is this still an issue in 2.2009.51-1 which was released today, and if you have
> not done yet, can you please provide your steps again? Thanks!
> 

Just tested after the update and it seems to have been resolved :) Well done
guys :)
Comment 25 Vincent Lefevre 2010-01-15 02:12:47 UTC
Works here too.
Comment 26 Andre Klapper maemo.org 2010-01-15 14:12:26 UTC
Nice! Thanks a lot for retesting!
Comment 27 Frank Banul 2010-01-15 16:16:22 UTC
Works for me.
Comment 28 Andre Klapper maemo.org 2010-02-23 22:39:02 UTC
So this report contains two issues actually.
One was fixed for 2.2009.51-1, the other one will be fixed in the next update
"PR1.2" (as it was just released in the internal build 2010.08-5)
Comment 29 Venomrush 2010-03-01 22:32:43 UTC
I can verify that charging works very well since PR1.1
Comment 30 First Knight 2010-05-19 12:08:47 UTC
I think i am facing this issue...

My phone went dead as it says battery depleted or somthig. It shut down. So Now
i plug the wall charger into my phone and vibrates showing a dim nokia sign.
then yellow blinks begins... blinks to about 5 times it died. Then it vibrates
again... and the whole process of 5 blinks and off.

After sometime.. everything went blank includes the screen and the light
indicator. Then the yellow light is lit and stays lit.

Is this the same as this?? Me is in PR1.1.1
Comment 31 Andre Klapper maemo.org 2010-05-20 15:24:09 UTC
(In reply to comment #30)
> Is this the same as this??

No.
Comment 32 suhail salim 2011-09-06 21:04:37 UTC
guys i need help ...!!i tryed many ways to fix it..but cant ...the prob is...
>>>>when i put my battry it automatically gets on..
>>>den when i connect ma mob wid de charger..it goes on den off...
>>>when i took my mobile to the shop he said its some problem with the board..
i still dono what to do..guys tell mee some thing.
i need some thing to do..ma dad dont know abut it..if he knows he is gonna
screw mee!!!