Bug 7470 (int-144883)

Summary: N900 does not support Skype Voicemail Settings
Product: [Maemo Official Applications] Chat & Call & SMS Reporter: Drew Freyman <drew.freyman>
Component: VoIPAssignee: rtcomm <rtcomm>
Status: RESOLVED FIXED QA Contact: internet-call-bugs
Severity: normal    
Priority: Medium CC: andre_klapper, eopage, mikhail.zabaluev
Version: 5.0:(10.2010.19-1)   
Target Milestone: 5.0/(20.2010.36-2)   
Hardware: N900   
OS: Maemo   

Description Drew Freyman (reporter) 2009-12-30 09:20:41 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Set Skype PC/Mac client to go to voicemail if not answered.
2. Receive call via SkypeIn number from another Skype user, Skype client rings,
don't pick up.
3. Skype voice mail picks up.
3. Shut down Skype PC client (or don't); go online with Skype on N900
4. Receive call via SkypeIn number or from another Skype user, N900 Skype
client rings, don't pick up
5. Skype voice mail does not pick up.


EXPECTED OUTCOME:
N900 Skype client should follow the voice mail parameters established by the
desktop client.

ACTUAL OUTCOME:
When using the N900 Skype client voice mail does not work.

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)
10/10

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; en-US)
AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.0.249.43 Safari/532.5
Comment 1 Andre Klapper maemo.org 2009-12-30 14:00:43 UTC
Thanks for reporting this. Confirming. This is currently being worked on.
Comment 2 Andre Klapper maemo.org 2010-02-12 13:30:47 UTC
This has been fixed in package
telepathy-spirit 0.5.5+0m5
which is part of the internal build version
10.2010.05-10
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 3 Andre Klapper maemo.org 2010-03-15 20:52:19 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 4 Mikhail Zabaluev nokia 2010-05-25 13:15:34 UTC
Unfortunately, we had a regression in the lead-up to PR1.2, so we had to
disable this feature for the time being. It should come in a future release.
Comment 5 Andre Klapper maemo.org 2010-05-27 02:23:58 UTC
Internal comment:
"Voicemail feature was get disabled for PR1.2 because of Skype video, now we
need to fix the issue and enable it again for next release."
Comment 6 Ed Page 2010-07-08 13:50:52 UTC
I have the opposite experience.  My voicemail settings are disabled on my
desktop (but normally logged out) but my account picks up voicemail anyways. 
This is with PR1.2.  I cannot remember what the experience was like with
previous releases (I swap back and forth between SIP and Skype for my needs).
Comment 7 Andre Klapper maemo.org 2010-08-09 13:11:11 UTC
Reception and playback of Skype voicemail in N900 has been fixed in package
skyhost 1.10.591-0+0m5
which is part of the internal build version
2010.31-3
(Note: 2010 is the year, and the number after is the week.)

Sending Skype voicemail from N900 is not yet implemented.

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 8 Andre Klapper maemo.org 2010-10-25 17:13:02 UTC
The problem reported here should be fixed in the update that was released today
for public: The Maemo5 update version 20.2010.36-2 (also called "PR1.3"
sometimes). Please leave a comment if the problem is not fixed for you in this
update version.