Bug 7361

Summary: Make a phone call to a contact from the sms view
Product: [Maemo Official Applications] Chat & Call & SMS Reporter: zaheer merali <zaheermerali>
Component: MessagingAssignee: rtcomm <rtcomm>
Status: VERIFIED FIXED QA Contact: im-chat-bugs
Severity: enhancement    
Priority: Low CC: aliamerali, andre_klapper, javiermon, mikhail.zabaluev, wolf.pld
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: All   
OS: Maemo   

Description zaheer merali (reporter) 2009-12-27 02:38:50 UTC
SOFTWARE VERSION: PR1.0 (2009.42.11)
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 

Receive an sms from someone and you feel like calling him.

EXPECTED OUTCOME:
An option to call that number that sent you the message would be good to have
in the menu.

ACTUAL OUTCOME:
Menu only has Clear Conversation.

REPRODUCIBILITY:
always
Comment 1 Andre Klapper maemo.org 2009-12-28 15:37:32 UTC
This is actually the same as bug 6152 - there is a new "Open contact card"
option in the net major update from the main menu, plus currently you can
always click the icon of that person to get there in 1.2009.42-11.

*** This bug has been marked as a duplicate of bug 6152 ***
Comment 2 zaheer merali (reporter) 2009-12-28 15:46:50 UTC
#6152 is about the call log screen, this is about the sms messaging view and
lack of ability to call the phone number that sms'ed you. so reopening.
Comment 3 Mikhail Zabaluev nokia 2009-12-28 15:48:38 UTC
(In reply to comment #2)
> #6152 is about the call log screen, this is about the sms messaging view and
> lack of ability to call the phone number that sms'ed you.

There was a bug for that, too. Sorry.
Comment 4 Andre Klapper maemo.org 2010-01-05 19:27:06 UTC
If it's no duplicate then it's just fixed internally.

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 5 Andre Klapper maemo.org 2010-01-05 19:28:39 UTC
*** Bug 7539 has been marked as a duplicate of this bug. ***
Comment 6 zaheer merali (reporter) 2010-01-05 20:27:37 UTC
what build number has this fixed?
Comment 7 Andre Klapper maemo.org 2010-01-14 13:45:56 UTC
I must admit that I don't know if the fix is already included in today's
2.2009.51-1 update release or not. Checking and reporting back is welcome!
Comment 8 zaheer merali (reporter) 2010-01-14 13:50:54 UTC
Ok now there is an open contact card, and you can click on the avatar icon for
the person to get the contact card.

However there is no way of knowing the phone number that sms'ed you from a
contact that has multiple numbers and hence call them on that number.

From the call log, bug 6152 was fixed and when you select contact it shows you
just the number that called and offers you to call back or sms.
Comment 9 Andre Klapper maemo.org 2010-03-15 20:52:17 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 10 Bartosz Taudul 2010-05-26 18:24:37 UTC
(In reply to comment #8)
> However there is no way of knowing the phone number that sms'ed you from a
> contact that has multiple numbers and hence call them on that number.
In PR1.2 the number from which the SMS was sent is highlighted.