Bug 7279 (int-151883)

Summary: scrollbar instead of kinetic scrolling
Product: [Maemo Official Applications] Chat & Call & SMS Reporter: Andrej Krutak <andree>
Component: MessagingAssignee: rtcomm <rtcomm>
Status: CLOSED FIXED QA Contact: im-chat-bugs
Severity: normal    
Priority: Medium CC: andree, andre_klapper, joppu1, mikhail.zabaluev, tri
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: N900   
OS: Maemo   
Attachments: screenshot

Description Andrej Krutak (reporter) 2009-12-23 20:48:45 UTC
SOFTWARE VERSION:
2009.42-11 

EXACT STEPS LEADING TO PROBLEM: 
1. Optionally restart device :)
2. Start messaging app and open any conversation

EXPECTED OUTCOME:
I can browse through messages using kinetic scrolling

ACTUAL OUTCOME:
A scrollbar appears on the right (and the messages list layout is somewhat
broken) - and the kinetic scrolling doesn't work (I have to use the scrollbar).

REPRODUCIBILITY:
currently always

EXTRA SOFTWARE INSTALLED:
plugin-account-haze , but i guess it shouldn't be relevant

OTHER COMMENTS:
-
Comment 1 Andrej Krutak (reporter) 2009-12-23 20:52:43 UTC
Created an attachment (id=1836) [details]
screenshot
Comment 2 Johannes Siipola 2009-12-30 18:16:00 UTC
Seems very unusual, the avatars are also positioned incorrectly and the
messaging view should always have kinetic scrolling. Seems very much like a
Haze bug.
Comment 3 Andrej Krutak (reporter) 2009-12-31 13:13:36 UTC
I'd say that telepathy-haze only interconnects telepathy and pidgin protocols,
and there's no direct gui functionality (at least when talking about the
"messaging view") in it - thus I don't suppose telepathy-haze is the problem... 

After uninstalling telepathy-haze, the problem still occured (still also in sms
conversations)...
Comment 4 Mikhail Zabaluev nokia 2010-01-12 18:32:46 UTC
We couldn't reproduce it in any of our newer builds, so we believe it's been
fixed at some point after the release 2.2009.42-11.
Please reopen if you still see it after the next software update.
Comment 5 Andre Klapper maemo.org 2010-01-14 12:28:56 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 6 Andrej Krutak (reporter) 2010-01-14 22:54:20 UTC
yeah, the problem transformed into https://bugs.maemo.org/show_bug.cgi?id=7957
for me... :) don't know whether it's connected, probably not - however the
scrolling now works again as expected.. I'll get back here, if it changed in
future...
Comment 7 Venomrush 2010-03-01 22:40:45 UTC
Verifying
I can browse through messages using kinetic scrolling since PR1.1