Bug 7222 (int-145003)

Summary: Company Directory not present
Product: [Maemo Official Platform] Synchronization Reporter: Jason <slacknet>
Component: Mail for ExchangeAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: activesync-bugs
Severity: normal    
Priority: Medium CC: andre_klapper, chris_saturn, commerce, vitaly.repin
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: All   
OS: Maemo   

Description Jason (reporter) 2009-12-22 08:48:39 UTC
unable to access company directory, using MfE, we have over 10,000 mail enabled
accounts in exchange, I am in no way going to put them into a local address
book. MfE is unusable at this point for me. Might have to move back to N95
until resolved.

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. New Mail
2. Add person to the to: line
3. No company directory.

EXPECTED OUTCOME: To have company directory 

ACTUAL OUTCOME: It's not there

REPRODUCIBILITY: 100/100
(always, less than 1/10, 5/10, 9/10)

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
should not be to hard.

User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1;
Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729;
Media Center PC 6.0; OfficeLiveConnector.1.4; OfficeLivePatch.1.3)
Comment 1 Vitaly Repin 2009-12-22 09:29:27 UTC
this is not a bug but a feature request.

anyway, this is fixed. wait for sw. update.

bugs (CRs) in internal tracker: 143939, 145003
Comment 2 Andre Klapper maemo.org 2009-12-22 15:59:22 UTC
Vitaly: Thanks!

This has been fixed in package
osso-addressbook 4.20091111+0m5
which is part of the internal build version
2.2009.47-5
(Note: 2009 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 3 Andre Klapper maemo.org 2010-01-14 12:26:07 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 4 Eugene Garcia 2010-01-16 05:35:35 UTC
I have updated to PR 1.1 and I still do not see my company directory.

I am following the same steps laid out in the initial bug.

1. New mail
2. Add person in to: field
3. No company directory
Comment 5 Vitaly Repin 2010-01-16 11:30:30 UTC
(In reply to comment #4)
> I have updated to PR 1.1 and I still do not see my company directory.

Company directory is accessible through Contacts application.  

Open "Contacts" application and select "Get Contacts" menu item.  After that
choose "Import from Exchange".