Bug 7211 (int-151699)

Summary: "Unable to play media. Media format not supported" for recently recorded video
Product: [Maemo Official Applications] Media player Reporter: taril <n900nseries>
Component: GeneralAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: media-player-bugs
Severity: normal    
Priority: Low CC: andre_klapper, ivan.daniluk, kremikoleva, lius_m147, turist
Version: 5.0/(2.2009.51-1)   
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: All   
OS: Maemo   

Description taril (reporter) 2009-12-22 01:43:18 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. open the camera
2. record something, must be a video!
4. play the recorded video
3. close the camera
4. open the browser (Firefox)
5. close the browser (all the opened webpages or bookmark window)
6. open media palyer
7. try to play a video file, or your recorded video

EXPECTED OUTCOME:
media player plays the videos
ACTUAL OUTCOME:
media player writes you "UNABLE TO PLAY MEDIA. MEDIA FORMAT NOT SUPPORTED" for
all video type
REPRODUCIBILITY: 6/10
(always, less than 1/10, 5/10, 9/10)

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
only system reboot helps

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.6)
Gecko/20091201 SUSE/3.5.6-5.1 Firefox/3.5.6
Comment 1 Andre Klapper maemo.org 2009-12-22 19:08:20 UTC
Thanks for the report! I can reproduce this sometimes:

From internal version 51-8:
EXACT STEPS LEADING TO PROBLEM: 
1. open the camera slide (app starts)
2. record a video for more than 10 seconds
3. play the recorded video from the button in the lower right corner
4. Close the Media Player.
5. close the standby camera application and then the hardware lense.
6. open the browser, get bookmarks list
7. close the browser
8. open media player and click "Videos".
9. try to play your recorded video

> "UNABLE TO PLAY MEDIA. MEDIA FORMAT NOT SUPPORTED"
This happened once to me. I also had Media Player just showing the 5 bubbles
("loading") for more than a minute without any error message and then finally
showing the on screen menu with the three buttons (Back | Play | Forward).

> REPRODUCIBILITY: 6/10
Here it was 2/3.

Also, simply closing and restarting the Media Player seemed to make it work
again.
Comment 2 taril (reporter) 2009-12-22 23:29:30 UTC
Ive also noticed that when Media Player unable to play video files, when I open
the camera's len cover, Camera application is aborted with "OPERATION FAILED"
message!!!
Comment 3 Andre Klapper maemo.org 2009-12-29 18:23:58 UTC
I can imagine that bug 7147 has some similar reasons.
Comment 4 Eugene 2010-01-13 12:38:16 UTC
I have the same issue as in the comment #2. This bug and the bug 6823(media
player won't play any video files now). I wonder why do these bugs have low
priority and Normal(this one) severity? Top Nokia's phone that cannot play any
video file at all, non-functional camera and eating battery after this
unsuccessful try in 1-2 hours?

Really, is there any activity on these issues? The problem is, I cannot return
my N900 anymore because it was DDP device so I'm stuck with the bugzilla,
waiting for any activity here.
Comment 5 taril (reporter) 2010-01-17 12:22:03 UTC
I tried to reproduce this bug with 51-1 without success. :-D
Has anyone tried?
Comment 6 Eugene 2010-01-18 11:22:33 UTC
The bug is still present in the latest 51-1. Reproducibilty 100%
Comment 7 Andre Klapper maemo.org 2010-01-18 18:01:56 UTC
Neither me nor Nokia testers can reproduce this in the current internal version
2010.03-1. Closing as FIXED.

A future public update will include the fix. (This is not always already the
next public update.)
To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 8 Eugene 2010-01-18 18:23:14 UTC
>> Neither me nor Nokia testers can reproduce this in the current internal version 2010.03-1. Closing as FIXED.

As I wrote in the bug 6823, I can re-flash my device to any version and provide
SSH access to Nokia engineers anytime. But no one responded :(
Comment 9 Kremi Koleva 2010-03-02 10:55:17 UTC
When I try t play the recorded video media player writes - ''UNABLE TO PLAY
MEDIA. MEDIA FORMAT NOT SUPPORTED'' ...
I`m stuck with this ...
And also the camera is non-functional after that.
Comment 10 taril (reporter) 2010-03-02 13:30:44 UTC
Did you upgrade your phone with PR 1.1.1?
Comment 11 Kremi Koleva 2010-03-02 17:15:55 UTC
(In reply to comment #10)
> Did you upgrade your phone with PR 1.1.1?
> Yes.
Comment 12 Andre Klapper maemo.org 2010-03-15 20:54:51 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 13 Eugene 2010-05-26 23:01:31 UTC
The bug is not fixed in PR 1.2!

Dear Nokia developers,

Please tell us what we can do to have video working?
Comment 14 Andre Klapper maemo.org 2010-05-27 00:05:21 UTC
(In reply to comment #13)
> The bug is not fixed in PR 1.2!
> Please tell us what we can do to have video working?

When you provide more info than just a short "not fixed", so this could be
debugged? :)
Comment 15 Eugene 2010-05-27 00:15:04 UTC
(In reply to comment #14)
> When you provide more info than just a short "not fixed", so this could be
> debugged? :)

Step to reproduce:
1. Open media player -> Video.
2. Open video file "Nokia N900".
3. No video either without additional codecs or with them.

Version: 10.2010.19-1

P.S. I can arrange remove ssh to this device if necessary.
Comment 16 Andre Klapper maemo.org 2010-05-27 18:38:27 UTC
(In reply to comment #15)
> Step to reproduce:
> 1. Open media player -> Video.
> 2. Open video file "Nokia N900".
> 3. No video either without additional codecs or with them.

Works fine here on an N900 updated via SSU to 10.2010.19-1 this morning.
Only additional apps installed were/are "Bounce" and "Angry Birds".
Comment 17 Eugene 2010-05-28 07:17:28 UTC
> Works fine here on an N900 updated via SSU to 10.2010.19-1 this morning.
> Only additional apps installed were/are "Bounce" and "Angry Birds".

It always worked fine on my second N900. But that does not help another N900 I
have. Probably HW differences between these two devices.
Comment 18 Ivan Daniluk 2010-06-15 16:01:36 UTC
I confirm this bug in PR1.2. I didn't test it with PR1.1 cause bought phone
after the PR1.2 was available. 
I record a few videos, after short time want to view it and get "Unable to play
media. Media format not supported" error. Camera stops record videos - it
starts recording and simply closes with message "Operation failed".

Reboot helps, but not for long.
Comment 19 Lius Widjaja 2010-10-16 09:04:55 UTC
(In reply to comment #18)
> I confirm this bug in PR1.2. I didn't test it with PR1.1 cause bought phone
> after the PR1.2 was available. 
> I record a few videos, after short time want to view it and get "Unable to play
> media. Media format not supported" error. Camera stops record videos - it
> starts recording and simply closes with message "Operation failed".
> 
> Reboot helps, but not for long.
> 

Same here. Reproducibility 6/10 tries, by following the exact same steps. I can
confirm this after only 3 weeks of purchasing my N900. A reboot/hard reset
helps but only temporarily. Reflashing (PR 1.2 Global version) does not help. I
OCed my N900 to 850mhz using Titan's kernel - maybe that is the reason for
this?

Can we please reopen?
Comment 20 Andre Klapper maemo.org 2010-10-16 15:12:21 UTC
(In reply to comment #19)
> I OCed my N900 to 850mhz using Titan's kernel - maybe that is the reason for
> this? Can we please reopen?

No, as you are not using the default kernel which might be related.
Comment 21 Andre Klapper maemo.org 2010-10-26 19:57:36 UTC
If this still happens in 20.2010.36-2 with the default kernel please file a new
bug report. Thanks!