Bug 7127 (int-153446)

Summary: Add option to disable smiley icons in conversations
Product: [Maemo Official Applications] Chat & Call & SMS Reporter: Dawid Lorenz <adlorenz>
Component: MessagingAssignee: rtcomm <rtcomm>
Status: RESOLVED WONTFIX QA Contact: im-chat-bugs
Severity: enhancement    
Priority: Low CC: andre_klapper, linda_cz_vn, maemo.org, maemo, maemo, mikhail.zabaluev
Version: 5.0:(10.2010.19-1)   
Target Milestone: ---   
Hardware: N900   
OS: Maemo   

Description Dawid Lorenz (reporter) 2009-12-19 02:31:32 UTC
SOFTWARE VERSION:
(Settings > General > About product)
2009.42-11

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Start conversation (SMS or IM)
2. Type a text-smiley (ie. :) )
3. See it converted automagically to graphic icon representing that smiley

EXPECTED OUTCOME:
An option in Conversation settings panel (or somewhere in general system
settings) to enable/disable smiley icons instead of text-based smileys

ACTUAL OUTCOME:
Text smileys are currently *always* replaced with smiley icons

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.9.1.6)
Gecko/20091216 Fedora/3.5.6-1.fc12 Firefox/3.5.6
Comment 1 Andre Klapper maemo.org 2009-12-20 14:54:33 UTC
--> enhancement.
Comment 2 Mikhail Zabaluev nokia 2009-12-21 17:23:46 UTC
No UI breakthroughs are forthcoming, but at least we can make it hackable by
changing a text file.
Comment 3 Dawid Lorenz (reporter) 2009-12-21 17:27:46 UTC
(In reply to comment #2)
> No UI breakthroughs are forthcoming, but at least we can make it hackable by
> changing a text file.

Thanks. I can live with this, however if UI widget to control that option
*will* come eventually, it's even better. :)
Comment 4 Dawid Lorenz (reporter) 2009-12-21 17:28:38 UTC
(In reply to comment #2)
> No UI breakthroughs are forthcoming, but at least we can make it hackable by
> changing a text file.

Forgot to ask... which file exactly needs to be hacked?
Comment 5 Mikhail Zabaluev nokia 2009-12-21 17:33:59 UTC
(In reply to comment #4)
> Forgot to ask... which file exactly needs to be hacked?

It may not exist yet in the software you have, please bear with us :)
Comment 6 Dawid Lorenz (reporter) 2009-12-21 17:36:37 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > Forgot to ask... which file exactly needs to be hacked?
> 
> It may not exist yet in the software you have, please bear with us :)

OK, I'm going into Patient Waiting Mode then. Many thanks! :)
Comment 7 Marcin Juszkiewicz 2010-01-10 18:48:03 UTC
*** Bug 7787 has been marked as a duplicate of this bug. ***
Comment 8 Marcin Juszkiewicz 2010-01-14 14:17:15 UTC
present in 51.1
Comment 9 Dawid Lorenz (reporter) 2010-01-14 14:23:30 UTC
(In reply to comment #8)
> present in 51.1
> 

As a text-file hack, as suggested in comment #2, or is it an UI settings
option?

(didn't receive 51.1 update notification on my device yet)
Comment 10 Marcin Juszkiewicz 2010-01-14 14:26:06 UTC
(In reply to comment #9)
> (In reply to comment #8)
> > present in 51.1
> > 
> 
> As a text-file hack, as suggested in comment #2, or is it an UI settings
> option?

No, I meant "but still present in 51.1"
Comment 11 Mikhail Zabaluev nokia 2010-01-14 14:29:59 UTC
(In reply to comment #9)
> (In reply to comment #8)
> > present in 51.1
> > 
> 
> As a text-file hack, as suggested in comment #2, or is it an UI settings
> option?

It's not there yet as of the release 2.2009.51-1.
Comment 12 Dawid Lorenz (reporter) 2010-01-14 15:09:27 UTC
(In reply to comment #11)
> > As a text-file hack, as suggested in comment #2, or is it an UI settings
> > option?
> 
> It's not there yet as of the release 2.2009.51-1.

Oh, misunderstood. Thanks.
Comment 13 Mikhail Zabaluev nokia 2010-02-21 17:51:24 UTC
Here's the recipe of smiley elimination for the upcoming Maemo 5 releases.

The theme files will be under '/usr/share/rtcom-messaging-ui/smilies'.
The directory 'user' contains the generic smilie theme, service-specific themes
are put under 'service'. To disable smilies, edit the appropriate .def file and
remove any or all lines under '[Smilies]'.
You can configure the match patterns, add new smilies, etc. Enjoy.

The bug as filed would still go to WONTFIX for Fremantle, though.
Comment 14 Dawid Lorenz (reporter) 2010-02-21 22:00:10 UTC
(In reply to comment #13)
> Here's the recipe of smiley elimination for the upcoming Maemo 5 releases.
> 
> The theme files will be under '/usr/share/rtcom-messaging-ui/smilies'.
> The directory 'user' contains the generic smilie theme, service-specific themes
> are put under 'service'. To disable smilies, edit the appropriate .def file and
> remove any or all lines under '[Smilies]'.
> You can configure the match patterns, add new smilies, etc. Enjoy.

Thanks!

> The bug as filed would still go to WONTFIX for Fremantle, though.

Harmattan, probably? :)
Comment 15 Mikhail Zabaluev nokia 2010-02-22 16:06:02 UTC
(In reply to comment #14)
> Harmattan, probably? :)

The request survives there, yes.
Comment 16 Dawid Lorenz (reporter) 2010-05-25 14:42:05 UTC
(In reply to comment #13)
> Here's the recipe of smiley elimination for the upcoming Maemo 5 releases.
> 
> The theme files will be under '/usr/share/rtcom-messaging-ui/smilies'.
> The directory 'user' contains the generic smilie theme, service-specific themes
> are put under 'service'. To disable smilies, edit the appropriate .def file and
> remove any or all lines under '[Smilies]'.
> You can configure the match patterns, add new smilies, etc. Enjoy.

I can confirm this solution as working in PR1.2. Thanks!
Comment 17 Linda 2010-07-05 19:36:25 UTC
Can anyone here pls tell me how to do it... i just can't make it work.
I need a tutorial step by step...
i tried to copy /usr/share/rtcom-messaging-ui/smilies in xterminal but it said
permission denied... I would be appreciate for any help
Comment 18 Andre Klapper maemo.org 2010-07-05 21:05:57 UTC
(In reply to comment #17)
> permission denied

Try it as root - see http://wiki.maemo.org/Root_access
Comment 19 Andre Klapper maemo.org 2010-09-06 17:38:32 UTC
For your interest:
Currently also looks like a WONTFIX for Harmattan according to Nokia.
Comment 20 Dawid Lorenz (reporter) 2010-09-06 17:40:44 UTC
(In reply to comment #19)
> For your interest:
> Currently also looks like a WONTFIX for Harmattan according to Nokia.
> 

Well done, Nokia. :(
Comment 21 Andre Klapper maemo.org 2010-11-20 22:54:20 UTC
Yes, also WONTFIX for Harmattan according to Nokia. Next option might be to
check MeeGo (don't know, have not tried this particular request) and
bugs.meego.com.