Bug 7103

Summary: Lagging when starting Maemo core applications
Product: [Maemo Official Applications] Utilities Reporter: Venomrush <tri>
Component: X TerminalAssignee: unassigned <nobody>
Status: RESOLVED WONTFIX QA Contact: osso-xterm-bugs
Severity: normal    
Priority: Low CC: andre_klapper
Version: 5.0/(1.2009.42-11)   
Target Milestone: ---   
Hardware: N900   
OS: Maemo   
Bug Depends on:    
Bug Blocks: 5825    

Description Venomrush (reporter) 2009-12-18 11:49:52 UTC
SOFTWARE VERSION:
As above

EXACT STEPS LEADING TO PROBLEM: 
1. Close all applications running in the background.
2. Start Terminal and immediately when Terminal opens type top and Enter

EXPECTED OUTCOME:
Command top typed in Terminal

When application opens, users expect it to be ready to used straight away. 
At current state, users usually have to wait several seconds before the
application can be used, not exactly sure what is being done from the moment
the application shown on screen to the usable state.

ACTUAL OUTCOME:
Switches to Contacts and start searching for 'top' as a contact instead

REPRODUCIBILITY:
Always

OTHER COMMENTS:
Similar behavior seen when going to Settings and start scrolling through the
list, as soon as Setting is opened, start scrolling and notice the lag.
Sometimes skips out to Task Manager.
Comment 1 Andre Klapper maemo.org 2009-12-18 14:24:13 UTC
This is "kind of expected behaviour", see bug 5825. Same underlying reason for
Settings.
As stupid as I find the current behaviour personally, Nokia currently has no
plans to change this.